( Default Namespace ) Namespace

[image]

EsentSerialization Class Library
( Default Namespace ) Namespace
Send Feedback

ESENT Serialization .NET class library is an object persistence framework that uses Extensible Storage Engine data storage technology.
Since Extensible Storage Engine is a Windows built-in component, no installation or administration is required. And due to the ESE feature set, it's eminently suitable for both desktop applications, and highly-loaded servers. ESE is a core of Microsoft Exchange Server and Active Directory, and it's also used by Windows Mail and Windows Desktop Search.

This class library has been developed by Konstantin. You may want to take a look at the project's homepage to check if the new version is available.
The library is free to use and redistribute.
Unless paid for that, the creator of the library only provides minimal support.

This documentation is for version 1.7 of the library.

Classes

 | Class | Description
Public class | EnumerableEx | This static class implements a pair of generic extension over the IEnumerable<>
Public class | EsentSerializationUtils | This static class contains a few utility methods.

Structures

 | Structure | Description
Public structure | ByteArray | This struct is used as a ESE bookmarks.
Public structure | pair<(Of <(<'tFirst, tSecond>)>)> | Represents a read-only pair of 2 values.
Send feedback on this topic to the author of the library.


ByteArray Structure

[image]

EsentSerialization Class Library
ByteArray Structure
See Also Send Feedback

This struct is used as a ESE bookmarks.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Structure ByteArray _
    Implements IEquatable(Of ByteArray), IComparable(Of ByteArray)
C#
public struct ByteArray : IEquatable<ByteArray>,
    IComparable<ByteArray>

Remarks

Besides, it's used virtually anywhere byte arrays needs to be stored.

See Also

(Default Namespace) Namespace


ByteArray Constructor

[image] [image]

EsentSerialization Class Library
ByteArray Constructor
ByteArray Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ByteArray(array<Byte>[]()[][]) | Construct from byte[]
Public method | ByteArray(IEnumerable<(Of <<'(Byte>)>>)) | Construct from IEnumerable<byte>

See Also

ByteArray Structure
(Default Namespace) Namespace


ByteArray Constructor (Byte[])

[image]

EsentSerialization Class Library
ByteArray Constructor (array<Byte>[]()[][])
ByteArray Structure See Also Send Feedback

Construct from byte[]

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    data As Byte() _
)
C#
public ByteArray(
    byte[] data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

Remarks

This constructor doesn't copy the data, instead it saves the reference to the array.

See Also

ByteArray Structure
ByteArray Overload
(Default Namespace) Namespace


ByteArray Constructor (IEnumerable(Byte))

[image]

EsentSerialization Class Library
ByteArray Constructor (IEnumerable<(Of <(<'Byte>)>)>)
ByteArray Structure See Also Send Feedback

Construct from IEnumerable<byte>

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    data As IEnumerable(Of Byte) _
)
C#
public ByteArray(
    IEnumerable<byte> data
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Byte >)>)>

See Also

ByteArray Structure
ByteArray Overload
(Default Namespace) Namespace


ByteArray Methods

[image] [image]

EsentSerialization Class Library
ByteArray Methods
ByteArray Structure See Also Send Feedback

The ByteArray type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Implement IComparable<ByteArray>.CompareTo method.
 | ComputeHash | Compute the hash function.
Public method | Equals | Compare for equality with either another ByteArray, or byte[] (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Compute the hash function. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Public method | isEmpty | Returns true if this array is empty.
 | Join | Create new byte array by concatenating several arrays.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IEquatable<(Of <<'(ByteArray>)>>)..::..Equals |

See Also

ByteArray Structure
(Default Namespace) Namespace


IEquatable(ByteArray).Equals Method

[image]

EsentSerialization Class Library
ByteArray..::..IEquatable<(Of <(<'ByteArray>)>)>..::..Equals Method
ByteArray Structure See Also Send Feedback

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function Equals ( _
    that As ByteArray _
) As Boolean Implements IEquatable(Of ByteArray).Equals
C#
bool IEquatable<ByteArray>.Equals(
    ByteArray that
)

Parameters

that
Type: (Default Namespace)..::..ByteArray

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

ByteArray Structure
(Default Namespace) Namespace


CompareTo Method

[image]

EsentSerialization Class Library
ByteArray..::..CompareTo Method
ByteArray Structure See Also Send Feedback

Implement IComparable<ByteArray>.CompareTo method.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function CompareTo ( _
    that As ByteArray _
) As Integer
C#
public int CompareTo(
    ByteArray that
)

Parameters

that
Type: (Default Namespace)..::..ByteArray

Return Value

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

ByteArray Structure
(Default Namespace) Namespace


ComputeHash Method

[image]

EsentSerialization Class Library
ByteArray..::..ComputeHash Method
ByteArray Structure See Also Send Feedback

Compute the hash function.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function ComputeHash ( _
    data As Byte() _
) As Integer
C#
public static int ComputeHash(
    byte[] data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

Return Value

See Also

ByteArray Structure
(Default Namespace) Namespace


Equals Method

[image]

EsentSerialization Class Library
ByteArray..::..Equals Method
ByteArray Structure See Also Send Feedback

Compare for equality with either another ByteArray, or byte[]

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object

See Also

ByteArray Structure
(Default Namespace) Namespace


GetHashCode Method

[image]

EsentSerialization Class Library
ByteArray..::..GetHashCode Method
ByteArray Structure See Also Send Feedback

Compute the hash function.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

See Also

ByteArray Structure
(Default Namespace) Namespace


isEmpty Method

[image]

EsentSerialization Class Library
ByteArray..::..isEmpty Method
ByteArray Structure See Also Send Feedback

Returns true if this array is empty.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function isEmpty As Boolean
C#
public bool isEmpty()

Return Value

See Also

ByteArray Structure
(Default Namespace) Namespace


Join Method

[image]

EsentSerialization Class Library
ByteArray..::..Join Method
ByteArray Structure See Also Send Feedback

Create new byte array by concatenating several arrays.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function Join ( _
    ParamArray arrs As Object() _
) As ByteArray
C#
public static ByteArray Join(
    params Object[] arrs
)

Parameters

arrs
Type: array< System..::..Object >[]()[][]

Return Value

See Also

ByteArray Structure
(Default Namespace) Namespace


ByteArray Operators

[image] [image]

EsentSerialization Class Library
ByteArray Operators
ByteArray Structure See Also Send Feedback

The ByteArray type exposes the following members.

Operators

Name | Description
Equality | Compare for equality
Inequality | Compare for equality

See Also

ByteArray Structure
(Default Namespace) Namespace


Equality Operator

[image]

EsentSerialization Class Library
ByteArray..::..Equality Operator
ByteArray Structure See Also Send Feedback

Compare for equality

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Operator = ( _
    a As ByteArray, _
    b As ByteArray _
) As Boolean
C#
public static bool operator ==(
    ByteArray a,
    ByteArray b
)

Parameters

a
Type: (Default Namespace)..::..ByteArray
b
Type: (Default Namespace)..::..ByteArray

Return Value

True of they are equal.

Remarks

Two empty byte arrays are always equal.

See Also

ByteArray Structure
(Default Namespace) Namespace


Inequality Operator

[image]

EsentSerialization Class Library
ByteArray..::..Inequality Operator
ByteArray Structure See Also Send Feedback

Compare for equality

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Operator <> ( _
    a As ByteArray, _
    b As ByteArray _
) As Boolean
C#
public static bool operator !=(
    ByteArray a,
    ByteArray b
)

Parameters

a
Type: (Default Namespace)..::..ByteArray
b
Type: (Default Namespace)..::..ByteArray

Return Value

True of they are not equal.

See Also

ByteArray Structure
(Default Namespace) Namespace


ByteArray Properties

[image] [image]

EsentSerialization Class Library
ByteArray Properties
ByteArray Structure See Also Send Feedback

The ByteArray type exposes the following members.

Properties

 | Name | Description
Public property | data | Get the data.
 | Empty | An empty ByteArray

See Also

ByteArray Structure
(Default Namespace) Namespace


data Property

[image]

EsentSerialization Class Library
ByteArray..::..data Property
ByteArray Structure See Also Send Feedback

Get the data.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property data As Byte()
    Get
C#
public byte[] data { get; }

See Also

ByteArray Structure
(Default Namespace) Namespace


Empty Property

[image]

EsentSerialization Class Library
ByteArray..::..Empty Property
ByteArray Structure See Also Send Feedback

An empty ByteArray

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared ReadOnly Property Empty As ByteArray
    Get
C#
public static ByteArray Empty { get; }

See Also

ByteArray Structure
(Default Namespace) Namespace


EnumerableEx Class

[image]

EsentSerialization Class Library
EnumerableEx Class
See Also Send Feedback

This static class implements a pair of generic extension over the IEnumerable<>

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class EnumerableEx
C#
public static class EnumerableEx

Inheritance Hierarchy

System..::..Object
(Default Namespace)..::..EnumerableEx

See Also

(Default Namespace) Namespace


EnumerableEx Methods

[image] [image]

EsentSerialization Class Library
EnumerableEx Methods
EnumerableEx Class See Also Send Feedback

The EnumerableEx type exposes the following members.

Methods

Name | Description
Concat2<(Of <<'(ET, T>)>>) | Concatenate the nested IEnumerable's into a single IEnumerable.
FindIndex<(Of <<'(T>)>>) | Finds the index of the first item matching an expression in an enumerable.
ForEach<(Of <<'(TSource>)>>) | Execute the action once for each element in the collection.
GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned.
MergeSortedSequences<(Of <<'(tElt>)>>) | Merge two sorted sequences into single sorted sequence
Reverse<(Of <<'(tElt>)>>) | Return IEnumerable that lists elements in the reverse order. Unlike LINQ's reverse(), this one is O(1).
SequentialJoin<(Of <<'(E1, E2>)>>) | Iterate over the { E1 from seq1, E2 from seq2 } pairs of the elements.
Shuffle<(Of <<'(T>)>>) | Shuffle the elements randomly.
ToHashSet<(Of <<'(T>)>>) | Put all elements to the hashset.
unique<(Of <<'(tSource>)>>) | Selectively skip some elements from the input sequence based on their uniqueness. If several elements are equal, return the 1-st one, skip the rest of them.
uniqueBy<(Of <<'(tSource, tKey>)>>) | Selectively skip some elements from the input sequence based on their key uniqueness. If several elements share the same key value, return the 1-st one, skip the rest of them.

Extension Methods

Name Description

See Also

EnumerableEx Class
(Default Namespace) Namespace


Concat2(ET, T) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..Concat2<(Of <(<'ET, T>)>)> Method
EnumerableEx Class See Also Send Feedback

Concatenate the nested IEnumerable's into a single IEnumerable.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Concat2(Of ET As {Object, IEnumerable(Of T)}, T) ( _
    items As IEnumerable(Of ET) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Concat2<ET, T>(
    this IEnumerable<ET> items
)
where ET : Object, IEnumerable<T>

Parameters

items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'ET>)>)>

Type Parameters

ET
T

See Also

EnumerableEx Class
(Default Namespace) Namespace


FindIndex(T) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..FindIndex<(Of <(<'T>)>)> Method
EnumerableEx Class See Also Send Feedback

Finds the index of the first item matching an expression in an enumerable.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FindIndex(Of T) ( _
    items As IEnumerable(Of T), _
    predicate As Func(Of T, Boolean) _
) As Integer
C#
public static int FindIndex<T>(
    this IEnumerable<T> items,
    Func<T, bool> predicate
)

Parameters

items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
The enumerable to search.
predicate
Type: System..::..Func <(Of <(<'T, Boolean >)>)>
The expression to test the items against.

Type Parameters

T

Return Value

The index of the first matching item, or -1 if no items match.

See Also

EnumerableEx Class
(Default Namespace) Namespace


ForEach(TSource) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..ForEach<(Of <(<'TSource>)>)> Method
EnumerableEx Class See Also Send Feedback

Execute the action once for each element in the collection.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ForEach(Of TSource) ( _
    src As IEnumerable(Of TSource), _
    act As Action(Of TSource) _
)
C#
public static void ForEach<TSource>(
    this IEnumerable<TSource> src,
    Action<TSource> act
)

Parameters

src
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'TSource>)>)>
The collection
act
Type: System..::..Action <(Of <(<'TSource>)>)>
The action to execute

Type Parameters

TSource
Elements

See Also

EnumerableEx Class
(Default Namespace) Namespace


MergeSortedSequences(tElt) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..MergeSortedSequences<(Of <(<'tElt>)>)> Method
EnumerableEx Class See Also Send Feedback

Merge two sorted sequences into single sorted sequence

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function MergeSortedSequences(Of tElt) ( _
    seq0 As IEnumerable(Of tElt), _
    seq1 As IEnumerable(Of tElt), _
    comparer As Func(Of tElt, tElt, Integer) _
) As IEnumerable(Of tElt)
C#
public static IEnumerable<tElt> MergeSortedSequences<tElt>(
    IEnumerable<tElt> seq0,
    IEnumerable<tElt> seq1,
    Func<tElt, tElt, int> comparer
)

Parameters

seq0
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'tElt>)>)>
seq1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'tElt>)>)>
comparer
Type: System..::..Func <(Of <(<'tElt, tElt, Int32 >)>)>

Type Parameters

tElt

Return Value

Remarks

If the input sequences were not sorted, the result is undefined.

See Also

EnumerableEx Class
(Default Namespace) Namespace


Reverse(tElt) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..Reverse<(Of <(<'tElt>)>)> Method
EnumerableEx Class See Also Send Feedback

Return IEnumerable that lists elements in the reverse order. Unlike LINQ's reverse(), this one is O(1).

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Reverse(Of tElt) ( _
    list As IList(Of tElt) _
) As IEnumerable(Of tElt)
C#
public static IEnumerable<tElt> Reverse<tElt>(
    this IList<tElt> list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<'tElt>)>)>

Type Parameters

tElt

Return Value

See Also

EnumerableEx Class
(Default Namespace) Namespace


SequentialJoin(E1, E2) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..SequentialJoin<(Of <(<'E1, E2>)>)> Method
EnumerableEx Class See Also Send Feedback

Iterate over the { E1 from seq1, E2 from seq2 } pairs of the elements.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function SequentialJoin(Of E1, E2) ( _
    seq1 As IEnumerable(Of E1), _
    seq2 As IEnumerable(Of E2), _
    proc As Func(Of E1, E2, Integer) _
) As pair(Of Integer, Integer)
C#
public static pair<int, int> SequentialJoin<E1, E2>(
    IEnumerable<E1> seq1,
    IEnumerable<E2> seq2,
    Func<E1, E2, int> proc
)

Parameters

seq1
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'E1>)>)>
seq2
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'E2>)>)>
proc
Type: System..::..Func <(Of <(<'E1, E2, Int32 >)>)>
The functor return value has the following meaning: 0 = go to both next E1 and E2 >0 = keep current E1 position, only advance the E2 <0 = advance the E1 position, keep current E2 position.

Type Parameters

E1
E2

Return Value

Count of the elements from seq1 and seq2 that were processed by proc.

See Also

EnumerableEx Class
(Default Namespace) Namespace


Shuffle(T) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..Shuffle<(Of <(<'T>)>)> Method
EnumerableEx Class See Also Send Feedback

Shuffle the elements randomly.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Shuffle(Of T) ( _
    source As IEnumerable(Of T), _
    rng As Random _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> Shuffle<T>(
    this IEnumerable<T> source,
    Random rng
)

Parameters

source
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>
rng
Type: System..::..Random

Type Parameters

T

Return Value

See Also

EnumerableEx Class
(Default Namespace) Namespace


ToHashSet(T) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..ToHashSet<(Of <(<'T>)>)> Method
EnumerableEx Class See Also Send Feedback

Put all elements to the hashset.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToHashSet(Of T) ( _
    items As IEnumerable(Of T) _
) As HashSet(Of T)
C#
public static HashSet<T> ToHashSet<T>(
    this IEnumerable<T> items
)

Parameters

items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'T>)>)>

Type Parameters

T

See Also

EnumerableEx Class
(Default Namespace) Namespace


unique(tSource) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..unique<(Of <(<'tSource>)>)> Method
EnumerableEx Class See Also Send Feedback

Selectively skip some elements from the input sequence based on their uniqueness. If several elements are equal, return the 1-st one, skip the rest of them.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function unique(Of tSource) ( _
    src As IEnumerable(Of tSource) _
) As IEnumerable(Of tSource)
C#
public static IEnumerable<tSource> unique<tSource>(
    this IEnumerable<tSource> src
)

Parameters

src
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'tSource>)>)>

Type Parameters

tSource

Return Value

See Also

EnumerableEx Class
(Default Namespace) Namespace


uniqueBy(tSource, tKey) Method

[image]

EsentSerialization Class Library
EnumerableEx..::..uniqueBy<(Of <(<'tSource, tKey>)>)> Method
EnumerableEx Class See Also Send Feedback

Selectively skip some elements from the input sequence based on their key uniqueness. If several elements share the same key value, return the 1-st one, skip the rest of them.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function uniqueBy(Of tSource, tKey) ( _
    src As IEnumerable(Of tSource), _
    keySelecta As Func(Of tSource, tKey) _
) As IEnumerable(Of tSource)
C#
public static IEnumerable<tSource> uniqueBy<tSource, tKey>(
    this IEnumerable<tSource> src,
    Func<tSource, tKey> keySelecta
)

Parameters

src
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'tSource>)>)>
keySelecta
Type: System..::..Func <(Of <(<'tSource, tKey>)>)>

Type Parameters

tSource
tKey

Return Value

See Also

EnumerableEx Class
(Default Namespace) Namespace


EsentSerializationUtils Class

[image]

EsentSerialization Class Library
EsentSerializationUtils Class
See Also Send Feedback

This static class contains a few utility methods.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class EsentSerializationUtils
C#
public static class EsentSerializationUtils

Inheritance Hierarchy

System..::..Object
(Default Namespace)..::..EsentSerializationUtils

See Also

(Default Namespace) Namespace


EsentSerializationUtils Methods

[image] [image]

EsentSerialization Class Library
EsentSerializationUtils Methods
EsentSerializationUtils Class See Also Send Feedback

The EsentSerializationUtils type exposes the following members.

Methods

Name | Description
code | Get the HRESULT code from the Exception
EscapeASCII | Escape the input ASCII data.
EscapeUnicode | Escape USC2 Unicode data so it doesn't break the TSV file structure.
SelectPairs<(Of <<'(tSource, tFirst, tSecond>)>>) | Select two values from each element in the input sequence. Return the sequence of the selected pairs.
UnescapeASCII | Unescape ASCII data
UnescapeUnicode | Unescape Unicode text previously escaped with EscapeUnicode(array<Byte>[]()[][], Int32)

Extension Methods

Name Description

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


code Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..code Method
EsentSerializationUtils Class See Also Send Feedback

Get the HRESULT code from the Exception

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function code ( _
    ex As Exception _
) As Integer
C#
public static int code(
    this Exception ex
)

Parameters

ex
Type: System..::..Exception

Return Value

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


EscapeASCII Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..EscapeASCII Method
EsentSerializationUtils Class See Also Send Feedback

Escape the input ASCII data.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function EscapeASCII ( _
    buff As Byte(), _
    cbSize As Integer _
) As String
C#
public static string EscapeASCII(
    byte[] buff,
    int cbSize
)

Parameters

buff
Type: array< System..::..Byte >[]()[][]
cbSize
Type: System..::..Int32

Return Value

string where all the weird characters are escaped with \##

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


EscapeUnicode Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..EscapeUnicode Method
EsentSerializationUtils Class See Also Send Feedback

Escape USC2 Unicode data so it doesn't break the TSV file structure.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function EscapeUnicode ( _
    buff As Byte(), _
    cbSize As Integer _
) As String
C#
public static string EscapeUnicode(
    byte[] buff,
    int cbSize
)

Parameters

buff
Type: array< System..::..Byte >[]()[][]
cbSize
Type: System..::..Int32

Return Value

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


SelectPairs(tSource, tFirst, tSecond) Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..SelectPairs<(Of <(<'tSource, tFirst, tSecond>)>)> Method
EsentSerializationUtils Class See Also Send Feedback

Select two values from each element in the input sequence. Return the sequence of the selected pairs.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SelectPairs(Of tSource, tFirst, tSecond) ( _
    src As IEnumerable(Of tSource), _
    selectFirst As Func(Of tSource, tFirst), _
    selectSecond As Func(Of tSource, tSecond) _
) As IEnumerable(Of pair(Of tFirst, tSecond))
C#
public static IEnumerable<pair<tFirst, tSecond>> SelectPairs<tSource, tFirst, tSecond>(
    this IEnumerable<tSource> src,
    Func<tSource, tFirst> selectFirst,
    Func<tSource, tSecond> selectSecond
)

Parameters

src
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'tSource>)>)>
Source sequence
selectFirst
Type: System..::..Func <(Of <(<'tSource, tFirst>)>)>
first selector
selectSecond
Type: System..::..Func <(Of <(<'tSource, tSecond>)>)>
second selector

Type Parameters

tSource
tFirst
tSecond

Return Value

Sequence of pairs

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


UnescapeASCII Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..UnescapeASCII Method
EsentSerializationUtils Class See Also Send Feedback

Unescape ASCII data

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function UnescapeASCII ( _
    chars As IEnumerable(Of Char) _
) As IEnumerable(Of Byte)
C#
public static IEnumerable<byte> UnescapeASCII(
    IEnumerable<char> chars
)

Parameters

chars
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Char >)>)>

Return Value

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


UnescapeUnicode Method

[image]

EsentSerialization Class Library
EsentSerializationUtils..::..UnescapeUnicode Method
EsentSerializationUtils Class See Also Send Feedback

Unescape Unicode text previously escaped with EscapeUnicode(array<Byte>[]()[][], Int32)

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function UnescapeUnicode ( _
    chars As IEnumerable(Of Char) _
) As IEnumerable(Of Byte)
C#
public static IEnumerable<byte> UnescapeUnicode(
    IEnumerable<char> chars
)

Parameters

chars
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Char >)>)>

Return Value

See Also

EsentSerializationUtils Class
(Default Namespace) Namespace


pair(tFirst, tSecond) Structure

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)> Structure
See Also Send Feedback

Represents a read-only pair of 2 values.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Structure pair(Of tFirst, tSecond)
C#
public struct pair<tFirst, tSecond>

Type Parameters

tFirst
Type of the first element
tSecond
Type of the second element

Remarks

System.Collections.Generic.KeyValuePair<> is ~the same, however the name is much longer.

See Also

(Default Namespace) Namespace


pair(tFirst, tSecond) Constructor

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)> Constructor
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

__ctor

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    f As tFirst, _
    s As tSecond _
)
C#
public pair(
    tFirst f,
    tSecond s
)

Parameters

f
Type: tFirst
The first value
s
Type: tSecond
The second value

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


pair(tFirst, tSecond) Fields

[image] [image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)> Fields
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The pair<(Of <(<'tFirst, tSecond>)>)> type exposes the following members.

Fields

 | Name | Description
Public field | first | The first value.
Public field | second | The second value.

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


first Field

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)>..::..first Field
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The first value.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly first As tFirst
C#
public readonly tFirst first

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


second Field

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)>..::..second Field
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The second value.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly second As tSecond
C#
public readonly tSecond second

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


pair(tFirst, tSecond) Methods

[image] [image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)> Methods
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The pair<(Of <(<'tFirst, tSecond>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


pair(tFirst, tSecond) Properties

[image] [image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)> Properties
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The pair<(Of <(<'tFirst, tSecond>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | fieldFirst | The first value.
Public property | fieldSecond | The second value.

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


fieldFirst Property

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)>..::..fieldFirst Property
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The first value.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property fieldFirst As tFirst
    Get
C#
public tFirst fieldFirst { get; }

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


fieldSecond Property

[image]

EsentSerialization Class Library
pair<(Of <(<'tFirst, tSecond>)>)>..::..fieldSecond Property
pair<(Of <(<'tFirst, tSecond>)>)> Structure See Also Send Feedback

The second value.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property fieldSecond As tSecond
    Get
C#
public tSecond fieldSecond { get; }

See Also

pair<(Of <(<'tFirst, tSecond>)>)> Structure
(Default Namespace) Namespace


Microsoft.Isam.Esent.Serialization Namespace

[image]

EsentSerialization Class Library
Microsoft.Isam.Esent.Serialization Namespace
Send Feedback

This namespace contains classes to access the ESENT database.

To access the database, first you need to create either EseSerializer instance if you're creating a desktop application where you have full control over the threads, or SessionPool instance if you're creating e.g. WCF server application or other type of highly multithreaded software system, or AspSessionPool instance if you're building an ASP.NET web application.

Each of them provides you the way to create instances of iSerializerSession interface: see EseSerializer.OpenDatabase, SessionPool.GetSession, and AspSessionPool.GetSession methods.

If you're using EseSerializer and your application uses reasonable count of threads (like my SMS Control Center software, where there's a GUI thread, a lazy DB backup thread that only wakes up once in 40 minutes, and one thread for every GSM gateway), then it's a good idea to keep iSerializerSession for the lifetime of the thread who uses the session. Sessions obtained from EseSerializer are expensive: they're the only owner of the underlying DB session and table cursors, so when you dispose them, the underlying DB resources are disposed as well.

If however you're using SessionPool or AspSessionPool, then don't forget to release a session to the pool by disposing it as soon as you've done with it. Sessions obtained from a session pool are cheap: when you dispose them, no DB sessions/cursor are disposed, instead they are recycled to the pool.

You can then use iSerializerSession interface to get individual tables from the session: see getTable( Cursor<tRow> ), getTable( Recordset<tRow> ), and getTable( BookmarkedRecordset<tRow> ) methods.

Cursors/recordsets are cheap: by default they share the DB cursor that was already opened and stored in the session.
If you do need an exclusive copy of the table cursor that is not shared by all cursors/recordsets within the same session, you can create it by calling Recordset.CreateOwnCursor method for recordsets, or Cursor.CreateOwnCopy for cursors. In this case, you must properly dispose the recordset/cursor. Unless you've used the Cursor.CreateOwnCopy or Recordset.CreateOwnCursor API, it's not necessary to dispose the cursors / recordsets.

And, you can use iSerializerSession interface to begin database transactions: see the iSerializerSession.BeginTransaction method, that returns a new instance of iSerializerTransaction interface.

It is highly recommended that the application always be in the context of a transaction when calling any ESE APIs. If this is not done, the database engine will automatically wrap each ESE API call in a transaction on behalf of the application. The cost of these very short transactions can add up quickly in some cases.

Classes

 | Class | Description
Public class | AspSessionPool | This class maintains the pool of the ESENT sessions, to serve ASP.NET requests coming to your web application.
Public class | BookmarkedRecordset<(Of <(<'tRow>)>)> | This class represents a subset of records from the Cursor<(Of <(<'tRow>)>)>, with records kept together with its bookmarks, allowing to modify the records.
Public class | BookmarkedRow<(Of <(<'tRow>)>)> | This class wraps a database row of some type, including the cursor and the bookmark.
Public class | Cursor<(Of <(<'tRow>)>)> | This class represents opened table cursor, and implements operations like add and remove.
Public class | EditableObjectList<(Of <(<'tRow>)>)> | This class wraps a ESENT table, to allow editing with DataGridView.
Public class | EseColumnAttrubuteBase | Abstract base class for ESE column attributes that defines record field types.
Public class | EseCursorBase | This abstract class represents opened table cursor.
Public class | EseSerializer | Represents a ESENT database.
Public class | EseTextFieldBase | Base class for text attributes.
Public class | OptionallyNullableColumn | Abstract base class for the columns that may either be nullable or not, depending on whether the field/property type is nullable or not.
Public class | Recordset<(Of <(<'tRow>)>)> | This class represents a subset of records from the Cursor<(Of <(<'tRow>)>)>.
Public class | SessionPool | This class maintains the pool of the ESENT sessions, to implement e.g. multithreaded software processing network requests.
Public class | Subst | This utility class maps drive letters just like command line 'subst.exe'.
Public class | TypeSerializer | This class performs table management task for a single serialized type.
Public class | TypeSerializer..::..ColumnInfo | This class represents the table column, and implements the get/set operations.
Public class | VirtualMode<(Of <(<'tRow>)>)> | This class implements virtual-mode data grid view.

Structures

 | Structure | Description
Public structure | NotifyTableChangedArgs | The argument for the TableChanged event.

Interfaces

 | Interface | Description
Public interface | iNotifyTableChanged | This interface allows a client to receive notifications when the table is changed.
Public interface | iSerializerSession | This interface represents a database session.
Public interface | iSerializerTransaction | This interface represents a database transaction.
Public interface | iTypeSerializer | Serializer instance for the specific record type
Public interface | SessionPool..::..iPooledSession | This is the helper interface supported by iSerializerSession objects being returned from GetSession()()()() method.

Delegates

 | Delegate | Description
Public delegate | NotifyTableChangedHandler |

Enumerations

 | Enumeration | Description
Public enumeration | eColumnKind | Column kind enumeration is used for some checks.
Public enumeration | EseSerializer..::..ePerformanceOptions | This enum holds a presets for various DB settings affecting ESENT performance.
Public enumeration | ImportExportFormat | Table import/export format.
Public enumeration | NotifyTableChangedAction | This enum defines what operation caused the TableChanged event.


AspSessionPool Class

[image]

EsentSerialization Class Library
AspSessionPool Class
See Also Send Feedback

This class maintains the pool of the ESENT sessions, to serve ASP.NET requests coming to your web application.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class AspSessionPool
C#
public class AspSessionPool

Remarks

You should not attempt to create more then one AspSessionPool instance in the same process: both database location, and DB instance name are hard-coded.

This class encapsulates a SessionPool instance. In the same process, you may use either EseSerializer, SessionPool, or AspSessionPool, but not both.

You should store the only instance of AspSessionPool object in your Application.

The database is located in "~/App_Data/ESENT" folder.
This class uses Subst to mount "~/App_Data" to a drive letter.
NTFS encryption is not used for the database.

NB: only use this class within an ASP.NET web application.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..AspSessionPool

See Also

Microsoft.Isam.Esent.Serialization Namespace


AspSessionPool Constructor

[image] [image]

EsentSerialization Class Library
AspSessionPool Constructor
AspSessionPool Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AspSessionPool(array<Type>[]()[][]) | Construct the session pool.
Public method | AspSessionPool(Int32, array<Type>[]()[][]) | Construct the pool.

See Also

AspSessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


AspSessionPool Constructor (Type[])

[image]

EsentSerialization Class Library
AspSessionPool Constructor (array<Type>[]()[][])
AspSessionPool Class See Also Send Feedback

Construct the session pool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    ParamArray arrTypes As Type() _
)
C#
public AspSessionPool(
    params Type[] arrTypes
)

Parameters

arrTypes
Type: array< System..::..Type >[]()[][]
The array of record types. In every session, the corresponding tables will be already opened for you.

Remarks

You should store the only instance of AspSessionPool object in your Application.

See Also

AspSessionPool Class
AspSessionPool Overload
Microsoft.Isam.Esent.Serialization Namespace


AspSessionPool Constructor (Int32, Type[])

[image]

EsentSerialization Class Library
AspSessionPool Constructor (Int32, array<Type>[]()[][])
AspSessionPool Class See Also Send Feedback

Construct the pool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    maxSessions As Integer, _
    ParamArray arrTypes As Type() _
)
C#
public AspSessionPool(
    int maxSessions,
    params Type[] arrTypes
)

Parameters

maxSessions
Type: System..::..Int32
Maximum count of the sessions to open, 0 = unlimited.
arrTypes
Type: array< System..::..Type >[]()[][]
The array of record types. In every session, the corresponding tables will be already opened for you.

See Also

AspSessionPool Class
AspSessionPool Overload
Microsoft.Isam.Esent.Serialization Namespace


AspSessionPool Methods

[image] [image]

EsentSerialization Class Library
AspSessionPool Methods
AspSessionPool Class See Also Send Feedback

The AspSessionPool type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Close all sessions, and the whole database as well.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSession | Get the ESENT session from the pool.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

AspSessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
AspSessionPool..::..Dispose Method
AspSessionPool Class See Also Send Feedback

Close all sessions, and the whole database as well.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose ( _
    context As HttpContext _
)
C#
public void Dispose(
    HttpContext context
)

Parameters

context
Type: System.Web..::..HttpContext
The HttpContext is used for tracing.

Remarks

You should dispose the AspSessionPool when your application shuts down.

One way to do that - write the similar code in your Global.asax:

CopyC#
 1void Application_End( object sender, EventArgs e )
 2{
 3    // Dispose the AspSessionPool object.
 4    var sp = Application[ appkeySessionPool ] as Microsoft.Isam.Esent.Serialization.AspSessionPool;
 5    if( null != sp )
 6    {
 7        sp.Dispose( Context );
 8        Application[ appkeySessionPool ] = null;
 9    }
10}

See Also

AspSessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


GetSession Method

[image]

EsentSerialization Class Library
AspSessionPool..::..GetSession Method
AspSessionPool Class See Also Send Feedback

Get the ESENT session from the pool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GetSession ( _
    context As HttpContext _
) As iSerializerSession
C#
public iSerializerSession GetSession(
    HttpContext context
)

Parameters

context
Type: System.Web..::..HttpContext

Return Value

Return the session.

Remarks

If context.Items contains the existing ESENT session, the old session is returned to the caller.

Even if context.Items does not contain the session, this operation is inexpensive: usually the method returns the last session released to the pool.

NB: You must call Dispose exactly once for each iSerializerSession instance returned by this method. The recommended construction is:

CopyC#
1using( iSerializerSession sess = m_sessionPool.GetSession( context ) )
2using( iSerializerTransaction trans = sess.beginTransaction() )
3{
4    // Do whatever you need with the data: obtain cursors/recordsets, search, modify records, etc..
5    trans.Commit();        // Or don't, if you need the transaction to roll back.
6}

See Also

AspSessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRecordset(tRow) Class

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class represents a subset of records from the Cursor<(Of <(<'tRow>)>)>, with records kept together with its bookmarks, allowing to modify the records.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class BookmarkedRecordset(Of tRow As New) _
    Inherits Recordset(Of tRow)
C#
public class BookmarkedRecordset<tRow> : Recordset<tRow>
where tRow : new()

Type Parameters

tRow
Record type.

Remarks

The class is pretty much the same as Recordset<(Of <(<'tRow>)>)>. The only difference is it enumerates BookmarkedRow<(Of <(<'tRow>)>)> instead of just tRow, thus allowing to modify or remove records.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..Recordset <(Of <(<'tRow>)>)>
Microsoft.Isam.Esent.Serialization..::..BookmarkedRecordset<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRecordset(tRow) Constructor

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)> Constructor
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _cursor As Cursor(Of tRow) _
)
C#
public BookmarkedRecordset(
    Cursor<tRow> _cursor
)

Parameters

_cursor
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<' tRow >)>)>

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRecordset(tRow) Methods

[image] [image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)> Methods
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

The BookmarkedRecordset<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | all | Get the enumerator of the records rows.
Public method | applyFilter | Apply the filter, and move the cursor to the first matching record. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | Clone |
Public method | Count | Apply filter, then count the records. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | CountToEnd | Count the records from the current cursor position to the end of the current range. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | CreateOwnCursor | Duplicate the ESENT cursor to get the own copy for this recordset. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | Dispose | Dispose the object. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | Equals | (Inherited from Object.)
Public method | EraseAll | Erase all the items that match the search filter. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | EstimateRecordsCount | Roughly estimate the count of the records matching the currently set filter. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterClear()()()() | Clear any filter, i.e. set the sort order to the non-reversed primary index, and cancel navigation limitations. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterClear(Boolean) | Set the sort order to the primary index, cancel navigation limitations, and optionally reverse the records. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterFindBetween | Filter the recordset only including the records listed on the specified index, where the indexed columns values are between the specified values. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterFindBetweenInv | Same as filterFindBetween(String, array<Object>[]()[][], array<Object>[]()[][]), but the order is flipped, i.e. records are returned from end to start. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterFindEqual | Include the records where the indexed columns values are exactly the same as the supplied arguments. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterFindEqualInv | Include the records, where the indexed columns values are exactly the same as the supplied arguments. The output is reversed. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterFindSubstring | Filter the recordset only including the records listed on the specified index, where the indexed columns values are the same as the supplied arguments. The last supplied argument however is threated like it contains the wildcard at the end. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterSort | Set the sort order to the specified index, and optionally reverse the records. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Protected method | Finalize | (Inherited from Object.)
Public method | getFirst | Return the first value in the recordset, or null when there's no records matching the filter.
Public method | getFirstBookmark | Get the bookmark of the first record in the recordset, or ByteArray.Empty when there's no records matching the filter. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | isEmpty | Apply the filter, and move the cursor to the first matching record. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | tryGotoBookmark | Apply the search filter, and goto the bookmark (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | tryMoveFirst | Move the cursor to the first record. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | tryMoveLast | Move the cursor to the last recored. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | tryMoveNext | (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | tryMovePrevious | (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | uniq | Same as all(), but unduplicates the output.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


all Method

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)>..::..all Method
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the enumerator of the records rows.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function all As IEnumerable(Of BookmarkedRow(Of tRow))
C#
public IEnumerable<BookmarkedRow<tRow>> all()

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace
Recordset<(Of <(<'tRow>)>)>..::..all()()()()


Clone Method

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)>..::..Clone Method
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Clone As BookmarkedRecordset(Of tRow)
C#
public BookmarkedRecordset<tRow> Clone()

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterClear Method

[image] [image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)>..::..filterClear Method
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | filterClear()()()() | Clear any filter, i.e. set the sort order to the non-reversed primary index, and cancel navigation limitations. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public method | filterClear(Boolean) | Set the sort order to the primary index, cancel navigation limitations, and optionally reverse the records. (Inherited from Recordset<(Of <(<'tRow>)>)>.)

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


getFirst Method

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)>..::..getFirst Method
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Return the first value in the recordset, or null when there's no records matching the filter.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getFirst As BookmarkedRow(Of tRow)
C#
public BookmarkedRow<tRow> getFirst()

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


uniq Method

[image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)>..::..uniq Method
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Same as all(), but unduplicates the output.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function uniq As IEnumerable(Of BookmarkedRow(Of tRow))
C#
public IEnumerable<BookmarkedRow<tRow>> uniq()

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace
Recordset<(Of <(<'tRow>)>)>..::..uniq()()()()


BookmarkedRecordset(tRow) Properties

[image] [image]

EsentSerialization Class Library
BookmarkedRecordset<(Of <(<'tRow>)>)> Properties
BookmarkedRecordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

The BookmarkedRecordset<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | canEstimateRecordsCount | Return true if the EstimateRecordsCount is supported. (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public property | cursor | The table cursor (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public property | idSession | ESENT session ID (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public property | idTable | ESENT table ID (Inherited from Recordset<(Of <(<'tRow>)>)>.)
Public property | session | EsentSerialization session (Inherited from Recordset<(Of <(<'tRow>)>)>.)

See Also

BookmarkedRecordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Class

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class wraps a database row of some type, including the cursor and the bookmark.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class BookmarkedRow(Of tRow As New) _
    Implements IEditableObject
C#
public class BookmarkedRow<tRow> : IEditableObject
where tRow : new()

Type Parameters

tRow
Record type.

Remarks

Useful if you're going to update the records. It implements IEditableObject interface, allowing it to be used as e.g. data source of a WinForms control.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..BookmarkedRow<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Constructor

[image] [image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Constructor
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BookmarkedRow<(Of <(<'tRow>)>)>(Cursor<(Of <<'(tRow>)>>), tRow) | Construct the new record.
Public method | BookmarkedRow<(Of <(<'tRow>)>)>(Cursor<(Of <<'(tRow>)>>), ByteArray, tRow) | Construct the record that's already in the DB.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Constructor (Cursor(tRow), tRow)

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Constructor (Cursor<(Of <(<'tRow>)>)>, tRow)
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct the new record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    cursor As Cursor(Of tRow), _
    obj As tRow _
)
C#
public BookmarkedRow(
    Cursor<tRow> cursor,
    tRow obj
)

Parameters

cursor
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<' tRow >)>)>
obj
Type: tRow

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
BookmarkedRow<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Constructor (Cursor(tRow), ByteArray, tRow)

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Constructor (Cursor<(Of <(<'tRow>)>)>, ByteArray, tRow)
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct the record that's already in the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    cursor As Cursor(Of tRow), _
    bookmark As ByteArray, _
    obj As tRow _
)
C#
public BookmarkedRow(
    Cursor<tRow> cursor,
    ByteArray bookmark,
    tRow obj
)

Parameters

cursor
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<' tRow >)>)>
bookmark
Type: (Default Namespace)..::..ByteArray
obj
Type: tRow

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
BookmarkedRow<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Methods

[image] [image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Methods
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

The BookmarkedRow<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete this record from the database.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Reload | Reload this object from the DB.
Public method | Save | Save the object to the DB, by either adding a new object, or updating the existing object
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)
Public method | Update | Save all object's fields to the DB.
Public method | UpdateField | Save the specified field value to the DB.
Public method | UpdateFields | Save several field values to the DB.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IEditableObject..::..BeginEdit |
Explicit interface implemetation | IEditableObject..::..CancelEdit |
Explicit interface implemetation | IEditableObject..::..EndEdit |

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


IEditableObject.BeginEdit Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..IEditableObject..::..BeginEdit Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub BeginEdit Implements IEditableObject.BeginEdit
C#
void IEditableObject.BeginEdit()

Implements

IEditableObject..::..BeginEdit()()()()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


IEditableObject.CancelEdit Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..IEditableObject..::..CancelEdit Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub CancelEdit Implements IEditableObject.CancelEdit
C#
void IEditableObject.CancelEdit()

Implements

IEditableObject..::..CancelEdit()()()()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


IEditableObject.EndEdit Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..IEditableObject..::..EndEdit Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub EndEdit Implements IEditableObject.EndEdit
C#
void IEditableObject.EndEdit()

Implements

IEditableObject..::..EndEdit()()()()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Delete Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..Delete Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Delete this record from the database.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Delete
C#
public void Delete()

Remarks

The write transaction must be already opened.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Reload Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..Reload Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Reload this object from the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Reload
C#
public void Reload()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Save Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..Save Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Save the object to the DB, by either adding a new object, or updating the existing object

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Save
C#
public void Save()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


ToString Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..ToString Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Returns a String that represents the current Object.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString()

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Update Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..Update Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Save all object's fields to the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Update
C#
public void Update()

Remarks

The write transaction must be already opened.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


UpdateField Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..UpdateField Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Save the specified field value to the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub UpdateField ( _
    strFieldName As String _
)
C#
public void UpdateField(
    string strFieldName
)

Parameters

strFieldName
Type: System..::..String

Remarks

The write transaction must be already opened.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


UpdateFields Method

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..UpdateFields Method
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

Save several field values to the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub UpdateFields ( _
    ParamArray arrFields As String() _
)
C#
public void UpdateFields(
    params string[] arrFields
)

Parameters

arrFields
Type: array< System..::..String >[]()[][]

Remarks

The write transaction must be already opened.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRow(tRow) Properties

[image] [image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)> Properties
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

The BookmarkedRow<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | bookmark | The bookmark. If this object represents a record that was not yet added to the database, this field will be empty.
Public property | cursor | The DB cursor.
Public property | obj | The record.

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


bookmark Property

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..bookmark Property
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

The bookmark. If this object represents a record that was not yet added to the database, this field will be empty.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property bookmark As ByteArray
    Get
C#
public ByteArray bookmark { get; }

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


cursor Property

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..cursor Property
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

The DB cursor.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property cursor As Cursor(Of tRow)
    Get
C#
public Cursor<tRow> cursor { get; }

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


obj Property

[image]

EsentSerialization Class Library
BookmarkedRow<(Of <(<'tRow>)>)>..::..obj Property
BookmarkedRow<(Of <(<'tRow>)>)> Class See Also Send Feedback

The record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property obj As tRow
    Get
    Set
C#
public tRow obj { get; set; }

See Also

BookmarkedRow<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Cursor(tRow) Class

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class represents opened table cursor, and implements operations like add and remove.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class Cursor(Of tRow As New) _
    Inherits EseCursorBase
C#
public sealed class Cursor<tRow> : EseCursorBase
where tRow : new()

Type Parameters

tRow
Type of the records stored in the table (a type marked with [EseTable] attribute).

Remarks

For the search/sort/query functionality use Recordset<(Of <(<'tRow>)>)> or BookmarkedRecordset<(Of <(<'tRow>)>)>.
For data binding use either EditableObjectList<(Of <(<'tRow>)>)> ( small to medium datasets ) or VirtualMode<(Of <(<'tRow>)>)> ( large datasets ).

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..EseCursorBase
Microsoft.Isam.Esent.Serialization..::..Cursor<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


Cursor(tRow) Constructor

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)> Constructor
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct the cursor.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    session As iSerializerSession, _
    serializer As iTypeSerializer, _
    idTable As JET_TABLEID, _
    isReadOnly As Boolean _
)
C#
public Cursor(
    iSerializerSession session,
    iTypeSerializer serializer,
    JET_TABLEID idTable,
    bool isReadOnly
)

Parameters

session
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession
serializer
Type: Microsoft.Isam.Esent.Serialization..::..iTypeSerializer
idTable
Type: JET_TABLEID
isReadOnly
Type: System..::..Boolean

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Cursor(tRow) Methods

[image] [image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)> Methods
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

The Cursor<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an item to the table.
Public method | AddRange | Add several items to the table.
Public method | BookmarkedRecordset | Construct BookmarkedRecordset<> object containing all records in this table
Public method | CreateOwnCopy | Duplicate the cursor within the session, so the returned copy has its own position, selected index, index range.
Public method | delAt | Delete the record at the specified bookmark.
Public method | delCurrent | Delete the record at the current cursor position.
Public method | Dispose | (Inherited from EseCursorBase.)
Protected method | Duplicate | Duplicate the cursor, and take the ownership of the copy. (Inherited from EseCursorBase.)
Public method | Equals | (Inherited from Object.)
Public method | FetchFields | Fetch the specified fields from the database.
Public method | FetchSingleField | Fetch the specific field from the current record of this table. (Inherited from EseCursorBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | getAt | Get the item at the specified bookmark.
Public method | getBookmark | Get bookmark of the current record. (Inherited from EseCursorBase.)
Public method | GetColumnId | Resolve column name to JET_COLUMNID. (Inherited from EseCursorBase.)
Public method | getCurrent | Get the item at the current cursor position
Public method | GetHashCode | (Inherited from Object.)
Public method | getSearchKey | Get the search key of the current record in the currently set index. (Inherited from EseCursorBase.)
Public method | GetType | (Inherited from Object.)
Public method | gotoBookmark | Positions a cursor to an index entry for the record that is associated with the specified bookmark. The bookmark can be used with any index defined over a table. (Inherited from EseCursorBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | onRecordAdded | Fire INotifyCollectionChanged.TableChanged event, when a new record is inserted into the table. (Inherited from EseCursorBase.)
Protected method | onRecordDeleted | Fire INotifyCollectionChanged.TableChanged event, when a record is erased from the table. (Inherited from EseCursorBase.)
Protected method | onRecordUpdated(ByteArray) | Fire INotifyCollectionChanged.TableChanged event, when the existing record is updated. (Inherited from EseCursorBase.)
Protected method | onRecordUpdated(ByteArray, String) | Fire INotifyCollectionChanged.TableChanged event, when a single field of the existing record is updated (Inherited from EseCursorBase.)
Public method | RawRead | Read all fields of the object. (Inherited from EseCursorBase.)
Public method | RawWrite | Write all fields of the record. (Inherited from EseCursorBase.)
Public method | Recordset | Construct Recordset<> object containing all records in this table
Public method | RemoveAll | Remove all records from the table.
Public method | ResetIndex | Switch to the primary index, and remove the cursor's navigation limitations. (Inherited from EseCursorBase.)
Public method | SaveSingleField | Update the value of the specific field of the current record. (Inherited from EseCursorBase.)
Public method | setAt | Update all fields of the item at the specified bookmark.
Public method | ToString | (Inherited from Object.)
Public method | tryGotoBookmark | Try go to the bookmark, return false on JET_err.NoCurrentRecord condition. (Inherited from EseCursorBase.)
Public method | TryMoveFirst | (Inherited from EseCursorBase.)
Public method | TryMoveLast | (Inherited from EseCursorBase.)
Public method | tryMoveNext | (Inherited from EseCursorBase.)
Public method | tryMovePrevious | (Inherited from EseCursorBase.)
Public method | trySeek | Navigate to the search key previously retrieved by getSearchKey(). (Inherited from EseCursorBase.)
Public method | Update | Update all fields of the item at the current cursor position
Public method | UpdateField | Update the specified field of the item at the current cursor position.
Public method | UpdateFields | Update the specified fields of the item at the current cursor position.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Add Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..Add Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Add an item to the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Add ( _
    newItem As tRow _
) As ByteArray
C#
public ByteArray Add(
    tRow newItem
)

Parameters

newItem
Type: tRow

Return Value

The bookmark of the newly added item.

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


AddRange Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..AddRange Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Add several items to the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub AddRange ( _
    newItems As IEnumerable(Of tRow) _
)
C#
public void AddRange(
    IEnumerable<tRow> newItems
)

Parameters

newItems
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' tRow >)>)>

Remarks

Only fires single NotifyTableChanged event with 'Reset' action.

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BookmarkedRecordset Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..BookmarkedRecordset Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct BookmarkedRecordset<> object containing all records in this table

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function BookmarkedRecordset As BookmarkedRecordset(Of tRow)
C#
public BookmarkedRecordset<tRow> BookmarkedRecordset()

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


CreateOwnCopy Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..CreateOwnCopy Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Duplicate the cursor within the session, so the returned copy has its own position, selected index, index range.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function CreateOwnCopy As Cursor(Of tRow)
C#
public Cursor<tRow> CreateOwnCopy()

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


delAt Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..delAt Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Delete the record at the specified bookmark.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub delAt ( _
    bookmark As ByteArray _
)
C#
public void delAt(
    ByteArray bookmark
)

Parameters

bookmark
Type: (Default Namespace)..::..ByteArray

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


delCurrent Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..delCurrent Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Delete the record at the current cursor position.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub delCurrent
C#
public void delCurrent()

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


FetchFields Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..FetchFields Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Fetch the specified fields from the database.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub FetchFields ( _
    item As tRow, _
    ParamArray fields As String() _
)
C#
public void FetchFields(
    tRow item,
    params string[] fields
)

Parameters

item
Type: tRow
fields
Type: array< System..::..String >[]()[][]

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


getAt Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..getAt Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the item at the specified bookmark.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getAt ( _
    bookmark As ByteArray _
) As tRow
C#
public tRow getAt(
    ByteArray bookmark
)

Parameters

bookmark
Type: (Default Namespace)..::..ByteArray

Return Value

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


getCurrent Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..getCurrent Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the item at the current cursor position

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getCurrent As tRow
C#
public tRow getCurrent()

Return Value

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


onRecordUpdated Method

[image] [image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..onRecordUpdated Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | onRecordUpdated(ByteArray) | Fire INotifyCollectionChanged.TableChanged event, when the existing record is updated. (Inherited from EseCursorBase.)
Protected method | onRecordUpdated(ByteArray, String) | Fire INotifyCollectionChanged.TableChanged event, when a single field of the existing record is updated (Inherited from EseCursorBase.)

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Recordset Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..Recordset Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct Recordset<> object containing all records in this table

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Recordset As Recordset(Of tRow)
C#
public Recordset<tRow> Recordset()

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


RemoveAll Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..RemoveAll Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Remove all records from the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function RemoveAll As Integer
C#
public int RemoveAll()

Return Value

The count of the erased records

Remarks

Only fires single NotifyTableChanged event with 'Reset' action.

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


setAt Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..setAt Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Update all fields of the item at the specified bookmark.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub setAt ( _
    bookmark As ByteArray, _
    obj As tRow _
)
C#
public void setAt(
    ByteArray bookmark,
    tRow obj
)

Parameters

bookmark
Type: (Default Namespace)..::..ByteArray
obj
Type: tRow

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Update Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..Update Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Update all fields of the item at the current cursor position

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Update ( _
    item As tRow _
)
C#
public void Update(
    tRow item
)

Parameters

item
Type: tRow

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


UpdateField Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..UpdateField Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Update the specified field of the item at the current cursor position.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub UpdateField ( _
    item As tRow, _
    field As String _
)
C#
public void UpdateField(
    tRow item,
    string field
)

Parameters

item
Type: tRow
field
Type: System..::..String

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


UpdateFields Method

[image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)>..::..UpdateFields Method
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

Update the specified fields of the item at the current cursor position.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub UpdateFields ( _
    item As tRow, _
    ParamArray fields As String() _
)
C#
public void UpdateFields(
    tRow item,
    params string[] fields
)

Parameters

item
Type: tRow
fields
Type: array< System..::..String >[]()[][]

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Cursor(tRow) Properties

[image] [image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)> Properties
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

The Cursor<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | bOwnsTable | Set to true for table-owning cursors. (Inherited from EseCursorBase.)
Public property | bReadOnly | Set to true for readonly cursors. (Inherited from EseCursorBase.)
Public property | idSession | Session ID (Inherited from EseCursorBase.)
Public property | idTable | Table ID (Inherited from EseCursorBase.)
Public property | serializer | The serializer for the records type. (Inherited from EseCursorBase.)
Public property | session | The session (Inherited from EseCursorBase.)
Public property | tableName | Get ESE table name. (Inherited from EseCursorBase.)

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Cursor(tRow) Events

[image] [image]

EsentSerialization Class Library
Cursor<(Of <(<'tRow>)>)> Events
Cursor<(Of <(<'tRow>)>)> Class See Also Send Feedback

The Cursor<(Of <(<'tRow>)>)> type exposes the following members.

Events

 | Name | Description
Public event | TableChanged | INotifyCollectionChanged implementation (Inherited from EseCursorBase.)

See Also

Cursor<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


eColumnKind Enumeration

[image]

EsentSerialization Class Library
eColumnKind Enumeration
See Also Send Feedback

Column kind enumeration is used for some checks.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Enumeration eColumnKind
C#
public enum eColumnKind

Members

Member name | Description
Binary |
Unicode |
ASCII |
GetPropertiesCollection |

See Also

Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Class

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class wraps a ESENT table, to allow editing with DataGridView.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EditableObjectList(Of tRow As New) _
    Inherits BindingList(Of BookmarkedRow(Of tRow)) _
    Implements ITypedList
C#
public class EditableObjectList<tRow> : BindingList<BookmarkedRow<tRow>>,
    ITypedList
where tRow : new()

Type Parameters

tRow
Type of the records stored in the table (a type marked with [EseTable] attribute).

Remarks

Don't use it for long lists, since all records are stored in RAM.
This class also used internally by VirtualMode<(Of <(<'tRow>)>)>, to automatically populate DataGridView's columns.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' BookmarkedRow <(Of <(<'tRow>)>)>>)>)>
System.ComponentModel..::..BindingList <(Of <(<' BookmarkedRow <(Of <(<'tRow>)>)>>)>)>
Microsoft.Isam.Esent.Serialization..::..EditableObjectList<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Constructor

[image] [image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Constructor
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditableObjectList<(Of <(<'tRow>)>)>()()()() |
Public method | EditableObjectList<(Of <(<'tRow>)>)>(BookmarkedRecordset<(Of <<'(tRow>)>>)) | Construct, adding the records from the provided recordset.
Public method | EditableObjectList<(Of <(<'tRow>)>)>(iSerializerSession) | Construct, adding all records from the specified table.

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Constructor

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Constructor
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EditableObjectList()

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
EditableObjectList<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Constructor (BookmarkedRecordset(tRow))

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Constructor (BookmarkedRecordset<(Of <(<'tRow>)>)>)
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct, adding the records from the provided recordset.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    rs As BookmarkedRecordset(Of tRow) _
)
C#
public EditableObjectList(
    BookmarkedRecordset<tRow> rs
)

Parameters

rs
Type: Microsoft.Isam.Esent.Serialization..::..BookmarkedRecordset <(Of <(<' tRow >)>)>

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
EditableObjectList<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Constructor (iSerializerSession)

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Constructor (iSerializerSession)
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct, adding all records from the specified table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    sess As iSerializerSession _
)
C#
public EditableObjectList(
    iSerializerSession sess
)

Parameters

sess
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
EditableObjectList<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Methods

[image] [image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Methods
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

The EditableObjectList<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | AddNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | AddNewCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | ApplySortCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | CancelNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | Clear | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | ClearItems | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | Contains | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | CopyTo | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | EndNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | FindCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | GetEnumerator | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | Insert | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | InsertItem | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnAddingNew | (Overrides BindingList<(Of <(<'T>)>)>..::..OnAddingNew(AddingNewEventArgs).)
Protected method | OnListChanged | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | Remove | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | RemoveAt | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | RemoveItem | The create and edit operations are implemented by the BookmarkedRow<>, that's why here we only need to handle the records deletion. (Overrides BindingList<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | RemoveSortCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | ResetBindings | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | ResetItem | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected method | SetItem | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ITypedList..::..GetItemProperties |
Explicit interface implemetation | ITypedList..::..GetListName |
Explicit interface implemetation | IList..::..Add | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..AddIndex | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..AddNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..ApplySort | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..Contains | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..Find | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..IndexOf | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..Insert | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..Remove | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..RemoveIndex | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..RemoveSort | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


ITypedList.GetItemProperties Method

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..ITypedList..::..GetItemProperties Method
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function GetItemProperties ( _
    listAccessors As PropertyDescriptor() _
) As PropertyDescriptorCollection Implements ITypedList.GetItemProperties
C#
PropertyDescriptorCollection ITypedList.GetItemProperties(
    PropertyDescriptor[] listAccessors
)

Parameters

listAccessors
Type: array< System.ComponentModel..::..PropertyDescriptor >[]()[][]

Implements

ITypedList..::..GetItemProperties(array<PropertyDescriptor>[]()[][])

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


ITypedList.GetListName Method

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..ITypedList..::..GetListName Method
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function GetListName ( _
    listAccessors As PropertyDescriptor() _
) As String Implements ITypedList.GetListName
C#
string ITypedList.GetListName(
    PropertyDescriptor[] listAccessors
)

Parameters

listAccessors
Type: array< System.ComponentModel..::..PropertyDescriptor >[]()[][]

Implements

ITypedList..::..GetListName(array<PropertyDescriptor>[]()[][])

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


OnAddingNew Method

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..OnAddingNew Method
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Overrides Sub OnAddingNew ( _
    e As AddingNewEventArgs _
)
C#
protected override void OnAddingNew(
    AddingNewEventArgs e
)

Parameters

e
Type: System.ComponentModel..::..AddingNewEventArgs

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


RemoveItem Method

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..RemoveItem Method
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

The create and edit operations are implemented by the BookmarkedRow<>, that's why here we only need to handle the records deletion.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
C#
protected override void RemoveItem(
    int index
)

Parameters

index
Type: System..::..Int32

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Properties

[image] [image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Properties
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

The EditableObjectList<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | AllowNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | AllowRemove | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | Count | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | idTable |
Protected property | IsSortedCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | Item | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected property | Items | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | RaiseListChangedEvents | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | serializer |
Public property | session |
Protected property | SortDirectionCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected property | SortPropertyCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected property | SupportsChangeNotificationCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected property | SupportsSearchingCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Protected property | SupportsSortingCore | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public property | table |

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IBindingList..::..AllowEdit | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..AllowNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..AllowRemove | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..IsSorted | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IList..::..Item | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IRaiseItemChangedEvents..::..RaisesItemChangedEvents | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..SortDirection | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..SortProperty | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..SupportsChangeNotification | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..SupportsSearching | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | IBindingList..::..SupportsSorting | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | (Inherited from Collection <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


idTable Property

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..idTable Property
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idTable As JET_TABLEID
    Get
C#
public JET_TABLEID idTable { get; }

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


serializer Property

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..serializer Property
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property serializer As iTypeSerializer
    Get
C#
public iTypeSerializer serializer { get; }

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


session Property

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..session Property
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property session As iSerializerSession
    Get
C#
public iSerializerSession session { get; }

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


table Property

[image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)>..::..table Property
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property table As Cursor(Of tRow)
    Get
C#
public Cursor<tRow> table { get; }

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EditableObjectList(tRow) Events

[image] [image]

EsentSerialization Class Library
EditableObjectList<(Of <(<'tRow>)>)> Events
EditableObjectList<(Of <(<'tRow>)>)> Class See Also Send Feedback

The EditableObjectList<(Of <(<'tRow>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)
Public event | ListChanged | (Inherited from BindingList <(Of <(<' BookmarkedRow <(Of <(<' tRow >)>)>>)>)>.)

See Also

EditableObjectList<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Class

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase Class
See Also Send Feedback

Abstract base class for ESE column attributes that defines record field types.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)> _
Public MustInherit Class EseColumnAttrubuteBase _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public abstract class EseColumnAttrubuteBase : Attribute

Remarks

The specific classes are in the Microsoft.Isam.Esent.Serialization.Attributes namespace.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseAutoIdAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDCSAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64ArrayAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortBinaryAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTimeZoneAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseVersionAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseXmlSerializedAttribute
Microsoft.Isam.Esent.Serialization..::..EseTextFieldBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn

See Also

Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Constructor

[image] [image]

EsentSerialization Class Library
EseColumnAttrubuteBase Constructor
EseColumnAttrubuteBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | EseColumnAttrubuteBase()()()() | Initialize with the default column name, which is the name of the field/property, BTW.
Protected method | EseColumnAttrubuteBase(String) | Initialize with non-default column name.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Constructor

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase Constructor
EseColumnAttrubuteBase Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property, BTW.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub New
C#
protected EseColumnAttrubuteBase()

See Also

EseColumnAttrubuteBase Class
EseColumnAttrubuteBase Overload
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Constructor (String)

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase Constructor (String)
EseColumnAttrubuteBase Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub New ( _
    _columnName As String _
)
C#
protected EseColumnAttrubuteBase(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseColumnAttrubuteBase Class
EseColumnAttrubuteBase Overload
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Fields

[image] [image]

EsentSerialization Class Library
EseColumnAttrubuteBase Fields
EseColumnAttrubuteBase Class See Also Send Feedback

The EseColumnAttrubuteBase type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


columnName Field

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..columnName Field
EseColumnAttrubuteBase Class See Also Send Feedback

Name for this column in the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly columnName As String
C#
public readonly string columnName

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Methods

[image] [image]

EsentSerialization Class Library
EseColumnAttrubuteBase Methods
EseColumnAttrubuteBase Class See Also Send Feedback

The EseColumnAttrubuteBase type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB.
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition.
Public method | getColumnKind | Get the Column kind
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column.
Protected method | makeKeyException | Throw new "MakeKey failed" exception.
Protected method | makeNullKey | Try to make a null key.
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database.
Protected method | serializeNull | Try to store a null value.
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Is called by the framework to verify the attribute is compatible with the field type. The implementation must throw an exception if it's not.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..Deserialize Method
EseColumnAttrubuteBase Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustOverride Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public abstract Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
ESENT cursor.
idColumn
Type: JET_COLUMNID
ID of the column.

Return Value

The column value for the current record.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..getColumnDef Method
EseColumnAttrubuteBase Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustOverride Function getColumnDef As JET_COLUMNDEF
C#
public abstract JET_COLUMNDEF getColumnDef()

Return Value

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


getColumnKind Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..getColumnKind Method
EseColumnAttrubuteBase Class See Also Send Feedback

Get the Column kind

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overridable Function getColumnKind As eColumnKind
C#
public virtual eColumnKind getColumnKind()

Return Value

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..MakeKey Method
EseColumnAttrubuteBase Class See Also Send Feedback

Make search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overridable Sub MakeKey ( _
    cur As EseCursorBase, _
    value As Object, _
    flags As MakeKeyGrbit _
)
C#
public virtual void MakeKey(
    EseCursorBase cur,
    Object value,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
ESENT cursor.
value
Type: System..::..Object
The key value supplied by the user.
flags
Type: MakeKeyGrbit
Bit flags for JetMakeKey.

Remarks

This abstract base class always throws an exception instead of calling JetMakeKey API.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


makeKeyException Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..makeKeyException Method
EseColumnAttrubuteBase Class See Also Send Feedback

Throw new "MakeKey failed" exception.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub makeKeyException ( _
    val As Object _
)
C#
protected void makeKeyException(
    Object val
)

Parameters

val
Type: System..::..Object
The incorrect key value supplied by the user.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


makeNullKey Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..makeNullKey Method
EseColumnAttrubuteBase Class See Also Send Feedback

Try to make a null key.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Function makeNullKey ( _
    cur As EseCursorBase, _
    value As Object, _
    flags As MakeKeyGrbit _
) As Boolean
C#
protected bool makeNullKey(
    EseCursorBase cur,
    Object value,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
ESENT cursor.
value
Type: System..::..Object
The value that might be null. If it's not null, this method silently returns false. If it is null but the column is not nullable, this method throws an exception.
flags
Type: MakeKeyGrbit
Key options.

Return Value

true if the field is nullable, and the value is null, and the JetMakeKey was called.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..Serialize Method
EseColumnAttrubuteBase Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustOverride Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public abstract void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
ESENT cursor.
idColumn
Type: JET_COLUMNID
ID of the column.
value
Type: System..::..Object
The value to store.
bNewRecord
Type: System..::..Boolean
Is set to true if we're inserting a new record. Is set to false if we're updating an existing record.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


serializeNull Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..serializeNull Method
EseColumnAttrubuteBase Class See Also Send Feedback

Try to store a null value.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Function serializeNull ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object _
) As Boolean
C#
protected bool serializeNull(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
ESENT cursor
idColumn
Type: JET_COLUMNID
ID of the column
value
Type: System..::..Object
The value that might be null. If it's not null, this method silently returns false.

Return Value

true if the field is nullable, and the value is null, and JetSetColumn was called.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..verifyTypeSupport Method
EseColumnAttrubuteBase Class See Also Send Feedback

Is called by the framework to verify the attribute is compatible with the field type. The implementation must throw an exception if it's not.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustOverride Sub verifyTypeSupport ( _
    t As Type _
)
C#
public abstract void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property the attribute is applied to.

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseColumnAttrubuteBase Properties

[image] [image]

EsentSerialization Class Library
EseColumnAttrubuteBase Properties
EseColumnAttrubuteBase Class See Also Send Feedback

The EseColumnAttrubuteBase type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable.
Public property | TypeId | (Inherited from Attribute.)

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseColumnAttrubuteBase..::..bFieldNullable Property
EseColumnAttrubuteBase Class See Also Send Feedback

Returns true if this column is nullable.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustOverride ReadOnly Property bFieldNullable As Boolean
    Get
C#
public abstract bool bFieldNullable { get; }

See Also

EseColumnAttrubuteBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseCursorBase Class

[image]

EsentSerialization Class Library
EseCursorBase Class
See Also Send Feedback

This abstract class represents opened table cursor.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustInherit Class EseCursorBase _
    Implements IDisposable, iNotifyTableChanged
C#
public abstract class EseCursorBase : IDisposable,
    iNotifyTableChanged

Remarks

This class implements the properties &methods that don't depend on the record type.
NB! Several cursors of the same table on the same session share the underlying ESENT cursor object, thus they share cursor position, current index, index range limitations, transaction state, everything. This is done to avoid JET_paramMaxCursors limitation (=1024 by default) even for a heavily loaded highly concurrent application. This also brings some side effects, of course. That's why you can always create a separate copy of the cursor, when you need that.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..EseCursorBase
Microsoft.Isam.Esent.Serialization..::..Cursor<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


EseCursorBase Constructor

[image]

EsentSerialization Class Library
EseCursorBase Constructor
EseCursorBase Class See Also Send Feedback

Construct a detached cursor.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub New ( _
    session As iSerializerSession, _
    serializer As iTypeSerializer, _
    idTable As JET_TABLEID, _
    bReadonly As Boolean _
)
C#
protected EseCursorBase(
    iSerializerSession session,
    iTypeSerializer serializer,
    JET_TABLEID idTable,
    bool bReadonly
)

Parameters

session
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession
serializer
Type: Microsoft.Isam.Esent.Serialization..::..iTypeSerializer
idTable
Type: JET_TABLEID
bReadonly
Type: System..::..Boolean

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseCursorBase Methods

[image] [image]

EsentSerialization Class Library
EseCursorBase Methods
EseCursorBase Class See Also Send Feedback

The EseCursorBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Protected method | Duplicate | Duplicate the cursor, and take the ownership of the copy.
Public method | Equals | (Inherited from Object.)
Public method | FetchSingleField | Fetch the specific field from the current record of this table.
Protected method | Finalize | (Inherited from Object.)
Public method | getBookmark | Get bookmark of the current record.
Public method | GetColumnId | Resolve column name to JET_COLUMNID.
Public method | GetHashCode | (Inherited from Object.)
Public method | getSearchKey | Get the search key of the current record in the currently set index.
Public method | GetType | (Inherited from Object.)
Public method | gotoBookmark | Positions a cursor to an index entry for the record that is associated with the specified bookmark. The bookmark can be used with any index defined over a table.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | onRecordAdded | Fire INotifyCollectionChanged.TableChanged event, when a new record is inserted into the table.
Protected method | onRecordDeleted | Fire INotifyCollectionChanged.TableChanged event, when a record is erased from the table.
Protected method | onRecordUpdated(ByteArray) | Fire INotifyCollectionChanged.TableChanged event, when the existing record is updated.
Protected method | onRecordUpdated(ByteArray, String) | Fire INotifyCollectionChanged.TableChanged event, when a single field of the existing record is updated
Public method | RawRead | Read all fields of the object.
Public method | RawWrite | Write all fields of the record.
Public method | ResetIndex | Switch to the primary index, and remove the cursor's navigation limitations.
Public method | SaveSingleField | Update the value of the specific field of the current record.
Public method | ToString | (Inherited from Object.)
Public method | tryGotoBookmark | Try go to the bookmark, return false on JET_err.NoCurrentRecord condition.
Public method | TryMoveFirst |
Public method | TryMoveLast |
Public method | tryMoveNext |
Public method | tryMovePrevious |
Public method | trySeek | Navigate to the search key previously retrieved by getSearchKey().

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
EseCursorBase..::..Dispose Method
EseCursorBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


Duplicate Method

[image]

EsentSerialization Class Library
EseCursorBase..::..Duplicate Method
EseCursorBase Class See Also Send Feedback

Duplicate the cursor, and take the ownership of the copy.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub Duplicate
C#
protected void Duplicate()

Remarks

NB: this can only be done for a non-table owning cursor.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


FetchSingleField Method

[image]

EsentSerialization Class Library
EseCursorBase..::..FetchSingleField Method
EseCursorBase Class See Also Send Feedback

Fetch the specific field from the current record of this table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function FetchSingleField ( _
    fName As String _
) As Object
C#
public Object FetchSingleField(
    string fName
)

Parameters

fName
Type: System..::..String
ESE column name to load from the table.

Return Value

The field value.

Remarks

This method was implemented because sometimes, e.g. while traversing the DB-backed tree searching for something, you only need the value of a single field.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


getBookmark Method

[image]

EsentSerialization Class Library
EseCursorBase..::..getBookmark Method
EseCursorBase Class See Also Send Feedback

Get bookmark of the current record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getBookmark As ByteArray
C#
public ByteArray getBookmark()

Return Value

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


GetColumnId Method

[image]

EsentSerialization Class Library
EseCursorBase..::..GetColumnId Method
EseCursorBase Class See Also Send Feedback

Resolve column name to JET_COLUMNID.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GetColumnId ( _
    fName As String _
) As JET_COLUMNID
C#
public JET_COLUMNID GetColumnId(
    string fName
)

Parameters

fName
Type: System..::..String
ESE column name to resolve.

Return Value

Column ID.

Remarks

Column IDs are persistent for the lifetime of the serializer: i.e. all sessions will get the same result.

Knowing the Column ID, you may use Esent.Interop functionality in conjunction with the ESENT serialization framework: see idSession and idTable properties. This is useful for some special cases: to fetch values from secondary index to save HDD seeks, to use Api.EscrowUpdate method, and so on.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


getSearchKey Method

[image]

EsentSerialization Class Library
EseCursorBase..::..getSearchKey Method
EseCursorBase Class See Also Send Feedback

Get the search key of the current record in the currently set index.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getSearchKey As ByteArray
C#
public ByteArray getSearchKey()

Return Value

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


gotoBookmark Method

[image]

EsentSerialization Class Library
EseCursorBase..::..gotoBookmark Method
EseCursorBase Class See Also Send Feedback

Positions a cursor to an index entry for the record that is associated with the specified bookmark. The bookmark can be used with any index defined over a table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub gotoBookmark ( _
    bk As ByteArray _
)
C#
public void gotoBookmark(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray
The bookmark used to position the cursor.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


onRecordAdded Method

[image]

EsentSerialization Class Library
EseCursorBase..::..onRecordAdded Method
EseCursorBase Class See Also Send Feedback

Fire INotifyCollectionChanged.TableChanged event, when a new record is inserted into the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub onRecordAdded ( _
    bk As ByteArray _
)
C#
protected void onRecordAdded(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


onRecordDeleted Method

[image]

EsentSerialization Class Library
EseCursorBase..::..onRecordDeleted Method
EseCursorBase Class See Also Send Feedback

Fire INotifyCollectionChanged.TableChanged event, when a record is erased from the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub onRecordDeleted ( _
    bk As ByteArray _
)
C#
protected void onRecordDeleted(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


onRecordUpdated Method

[image] [image]

EsentSerialization Class Library
EseCursorBase..::..onRecordUpdated Method
EseCursorBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | onRecordUpdated(ByteArray) | Fire INotifyCollectionChanged.TableChanged event, when the existing record is updated.
Protected method | onRecordUpdated(ByteArray, String) | Fire INotifyCollectionChanged.TableChanged event, when a single field of the existing record is updated

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


onRecordUpdated Method (ByteArray)

[image]

EsentSerialization Class Library
EseCursorBase..::..onRecordUpdated Method (ByteArray)
EseCursorBase Class See Also Send Feedback

Fire INotifyCollectionChanged.TableChanged event, when the existing record is updated.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub onRecordUpdated ( _
    bk As ByteArray _
)
C#
protected void onRecordUpdated(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray

See Also

EseCursorBase Class
onRecordUpdated Overload
Microsoft.Isam.Esent.Serialization Namespace


onRecordUpdated Method (ByteArray, String)

[image]

EsentSerialization Class Library
EseCursorBase..::..onRecordUpdated Method (ByteArray, String)
EseCursorBase Class See Also Send Feedback

Fire INotifyCollectionChanged.TableChanged event, when a single field of the existing record is updated

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub onRecordUpdated ( _
    bk As ByteArray, _
    strField As String _
)
C#
protected void onRecordUpdated(
    ByteArray bk,
    string strField
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray
strField
Type: System..::..String

See Also

EseCursorBase Class
onRecordUpdated Overload
Microsoft.Isam.Esent.Serialization Namespace


RawRead Method

[image]

EsentSerialization Class Library
EseCursorBase..::..RawRead Method
EseCursorBase Class See Also Send Feedback

Read all fields of the object.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function RawRead As Byte()()
C#
public byte[][] RawRead()

Return Value

Array of column data.

Remarks

Tables with multivalued or auto-increment columns are unsupported by this API.

This methods returns raw bytes stored by the ESENT database. Initially, it was implemented for data replication across the network.

Don't use this API with long values over ~1MB: it'll be not that effective.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace
EseCursorBase..::..RawWrite(array<array<Byte>[]()[][]>[]()[][])


RawWrite Method

[image]

EsentSerialization Class Library
EseCursorBase..::..RawWrite Method
EseCursorBase Class See Also Send Feedback

Write all fields of the record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub RawWrite ( _
    data As Byte()() _
)
C#
public void RawWrite(
    byte[][] data
)

Parameters

data
Type: array<array< System..::..Byte >[]()[][]>[]()[][]
Array of column data.

Remarks

Tables with multivalued or auto-increment columns are unsupported by this API.

A write transaction must be opened.

This method will first try to construct a search key on the primary index using the provided values. If the record is found, this method will update it. Otherwise, a new record will be inserted into the table.

Achtung! Because this API was implemented to provide maximum throughput when importing/exporting the data, it performs almost no data validation. If you're using it to copy records across tables or over the network, be absolutely sure the row class definition is exactly the same.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace
EseCursorBase..::..RawRead()()()()


ResetIndex Method

[image]

EsentSerialization Class Library
EseCursorBase..::..ResetIndex Method
EseCursorBase Class See Also Send Feedback

Switch to the primary index, and remove the cursor's navigation limitations.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub ResetIndex
C#
public void ResetIndex()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


SaveSingleField Method

[image]

EsentSerialization Class Library
EseCursorBase..::..SaveSingleField Method
EseCursorBase Class See Also Send Feedback

Update the value of the specific field of the current record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub SaveSingleField ( _
    fName As String, _
    value As Object _
)
C#
public void SaveSingleField(
    string fName,
    Object value
)

Parameters

fName
Type: System..::..String
ESE column name to load from the table.
value
Type: System..::..Object
New field value.

Remarks

This method was implemented as the performance optimization: when you only need to update a single field, and you don't have the complete object.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


tryGotoBookmark Method

[image]

EsentSerialization Class Library
EseCursorBase..::..tryGotoBookmark Method
EseCursorBase Class See Also Send Feedback

Try go to the bookmark, return false on JET_err.NoCurrentRecord condition.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryGotoBookmark ( _
    bk As ByteArray _
) As Boolean
C#
public bool tryGotoBookmark(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray
The bookmark used to position the cursor.

Return Value

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


TryMoveFirst Method

[image]

EsentSerialization Class Library
EseCursorBase..::..TryMoveFirst Method
EseCursorBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function TryMoveFirst As Boolean
C#
public bool TryMoveFirst()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


TryMoveLast Method

[image]

EsentSerialization Class Library
EseCursorBase..::..TryMoveLast Method
EseCursorBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function TryMoveLast As Boolean
C#
public bool TryMoveLast()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


tryMoveNext Method

[image]

EsentSerialization Class Library
EseCursorBase..::..tryMoveNext Method
EseCursorBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMoveNext As Boolean
C#
public bool tryMoveNext()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


tryMovePrevious Method

[image]

EsentSerialization Class Library
EseCursorBase..::..tryMovePrevious Method
EseCursorBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMovePrevious As Boolean
C#
public bool tryMovePrevious()

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


trySeek Method

[image]

EsentSerialization Class Library
EseCursorBase..::..trySeek Method
EseCursorBase Class See Also Send Feedback

Navigate to the search key previously retrieved by getSearchKey().

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function trySeek ( _
    key As ByteArray _
) As Boolean
C#
public bool trySeek(
    ByteArray key
)

Parameters

key
Type: (Default Namespace)..::..ByteArray

Return Value

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseCursorBase Properties

[image] [image]

EsentSerialization Class Library
EseCursorBase Properties
EseCursorBase Class See Also Send Feedback

The EseCursorBase type exposes the following members.

Properties

 | Name | Description
Public property | bOwnsTable | Set to true for table-owning cursors.
Public property | bReadOnly | Set to true for readonly cursors.
Public property | idSession | Session ID
Public property | idTable | Table ID
Public property | serializer | The serializer for the records type.
Public property | session | The session
Public property | tableName | Get ESE table name.

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


bOwnsTable Property

[image]

EsentSerialization Class Library
EseCursorBase..::..bOwnsTable Property
EseCursorBase Class See Also Send Feedback

Set to true for table-owning cursors.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property bOwnsTable As Boolean
    Get
C#
public bool bOwnsTable { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


bReadOnly Property

[image]

EsentSerialization Class Library
EseCursorBase..::..bReadOnly Property
EseCursorBase Class See Also Send Feedback

Set to true for readonly cursors.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property bReadOnly As Boolean
    Get
C#
public bool bReadOnly { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


idSession Property

[image]

EsentSerialization Class Library
EseCursorBase..::..idSession Property
EseCursorBase Class See Also Send Feedback

Session ID

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idSession As JET_SESID
    Get
C#
public JET_SESID idSession { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


idTable Property

[image]

EsentSerialization Class Library
EseCursorBase..::..idTable Property
EseCursorBase Class See Also Send Feedback

Table ID

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idTable As JET_TABLEID
    Get
C#
public JET_TABLEID idTable { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


serializer Property

[image]

EsentSerialization Class Library
EseCursorBase..::..serializer Property
EseCursorBase Class See Also Send Feedback

The serializer for the records type.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property serializer As iTypeSerializer
    Get
C#
public iTypeSerializer serializer { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


session Property

[image]

EsentSerialization Class Library
EseCursorBase..::..session Property
EseCursorBase Class See Also Send Feedback

The session

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property session As iSerializerSession
    Get
C#
public iSerializerSession session { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


tableName Property

[image]

EsentSerialization Class Library
EseCursorBase..::..tableName Property
EseCursorBase Class See Also Send Feedback

Get ESE table name.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property tableName As String
    Get
C#
public string tableName { get; }

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseCursorBase Events

[image] [image]

EsentSerialization Class Library
EseCursorBase Events
EseCursorBase Class See Also Send Feedback

The EseCursorBase type exposes the following members.

Events

 | Name | Description
Public event | TableChanged | INotifyCollectionChanged implementation

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


TableChanged Event

[image]

EsentSerialization Class Library
EseCursorBase..::..TableChanged Event
EseCursorBase Class See Also Send Feedback

INotifyCollectionChanged implementation

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Event TableChanged As NotifyTableChangedHandler
C#
public event NotifyTableChangedHandler TableChanged

Implements

iNotifyTableChanged..::..TableChanged

See Also

EseCursorBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Class

[image]

EsentSerialization Class Library
EseSerializer Class
See Also Send Feedback

Represents a ESENT database.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseSerializer _
    Implements IDisposable
C#
public class EseSerializer : IDisposable

Remarks

This class is the heart of the whole EsentSerialization library.

It owns the database's JET_INSTANCE, and it owns a collection of the TypeSerializer objects for every record type.

You should not attempt to create more then one EseSerializer instance in the same process: the DB instance name is hard-coded.

In the same process, you may use either EseSerializer, SessionPool, or AspSessionPool, but not both.

Here's the recommended C# code for a desktop or console application:

CopyC#
 1// The application entry point
 2static void Main()
 3{
 4    string strDatabasePath = Environment.ExpandEnvironmentVariables( @"%APPDATA%\MyCompany\MySoftware" );
 5    using( EseSerializer serializer = new EseSerializer( strDatabasePath, false, true ) )
 6    using( iSerializerSession sess = serializer.OpenDatabase( true ) )
 7    {
 8        if( serializer.isNewDatabase )
 9        {
10            // If you need some records to be presented in a newly created DB, add them here.
11        }
12
13        // Run your software; use 'sess' variable to access the DB.
14    }
15}

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..EseSerializer

See Also

Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Constructor

[image] [image]

EsentSerialization Class Library
EseSerializer Constructor
EseSerializer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseSerializer(String, Boolean, Boolean) | Construct the serializer.
Public method | EseSerializer(String, Boolean, IEnumerable<(Of <<'(Type>)>>)) | Construct the serializer.
Public method | EseSerializer(String, Boolean, Boolean, IEnumerable<(Of <<'(Type>)>>)) | Construct the serializer.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Constructor (String, Boolean, Boolean)

[image]

EsentSerialization Class Library
EseSerializer Constructor (String, Boolean, Boolean)
EseSerializer Class See Also Send Feedback

Construct the serializer.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strFolder As String, _
    bEncryptDatabase As Boolean, _
    bAddEntryAssemblyRecordTypes As Boolean _
)
C#
public EseSerializer(
    string strFolder,
    bool bEncryptDatabase,
    bool bAddEntryAssemblyRecordTypes
)

Parameters

strFolder
Type: System..::..String
Database folder
bEncryptDatabase
Type: System..::..Boolean
Set to true to encrypt the database.
bAddEntryAssemblyRecordTypes
Type: System..::..Boolean
Set to false to add no types to the database at this time. In this case you'll have to call AddSerializedType(Type) for each record type you're going to use with ESENT. Or, set to true to add every type in the main assembly that has [EseTable] applied.

See Also

EseSerializer Class
EseSerializer Overload
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Constructor (String, Boolean, IEnumerable(Type))

[image]

EsentSerialization Class Library
EseSerializer Constructor (String, Boolean, IEnumerable<(Of <(<'Type>)>)>)
EseSerializer Class See Also Send Feedback

Construct the serializer.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strFolder As String, _
    bEncryptDatabase As Boolean, _
    typesToAdd As IEnumerable(Of Type) _
)
C#
public EseSerializer(
    string strFolder,
    bool bEncryptDatabase,
    IEnumerable<Type> typesToAdd
)

Parameters

strFolder
Type: System..::..String
Database folder
bEncryptDatabase
Type: System..::..Boolean
Set to true to encrypt the database.
typesToAdd
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Type >)>)>
Record types to add.

See Also

EseSerializer Class
EseSerializer Overload
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Constructor (String, Boolean, Boolean, IEnumerable(Type))

[image]

EsentSerialization Class Library
EseSerializer Constructor (String, Boolean, Boolean, IEnumerable<(Of <(<'Type>)>)>)
EseSerializer Class See Also Send Feedback

Construct the serializer.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strFolder As String, _
    bEncryptDatabase As Boolean, _
    bSubstituteDriveLetter As Boolean, _
    typesToAdd As IEnumerable(Of Type) _
)
C#
public EseSerializer(
    string strFolder,
    bool bEncryptDatabase,
    bool bSubstituteDriveLetter,
    IEnumerable<Type> typesToAdd
)

Parameters

strFolder
Type: System..::..String
Database folder
bEncryptDatabase
Type: System..::..Boolean
Set to true to encrypt the database.
bSubstituteDriveLetter
Type: System..::..Boolean
Set to true to use Subst.Mount before opening the DB.
typesToAdd
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Type >)>)>
Record types to add.

See Also

EseSerializer Class
EseSerializer Overload
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Fields

[image] [image]

EsentSerialization Class Library
EseSerializer Fields
EseSerializer Class See Also Send Feedback

The EseSerializer type exposes the following members.

Fields

 | Name | Description
Public field | folderDatabase | The folder where the DB is located.
 | s_paramIndexTuplesLengthMin | This parameter specifies the minimum tuple length in a tuple index.
 | s_PerformanceOptions | Set this value before the creation of EseSerializer, SessionPool or AspSessionPool.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


folderDatabase Field

[image]

EsentSerialization Class Library
EseSerializer..::..folderDatabase Field
EseSerializer Class See Also Send Feedback

The folder where the DB is located.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly folderDatabase As String
C#
public readonly string folderDatabase

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


s_paramIndexTuplesLengthMin Field

[image]

EsentSerialization Class Library
EseSerializer..::..s_paramIndexTuplesLengthMin Field
EseSerializer Class See Also Send Feedback

This parameter specifies the minimum tuple length in a tuple index.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared s_paramIndexTuplesLengthMin As Integer
C#
public static int s_paramIndexTuplesLengthMin

Remarks

The default value is 3.
Be sure to set this parameter before you construct the EseSerializer class instance.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


s_PerformanceOptions Field

[image]

EsentSerialization Class Library
EseSerializer..::..s_PerformanceOptions Field
EseSerializer Class See Also Send Feedback

Set this value before the creation of EseSerializer, SessionPool or AspSessionPool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared s_PerformanceOptions As EseSerializer..::..ePerformanceOptions
C#
public static EseSerializer..::..ePerformanceOptions s_PerformanceOptions

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace
Microsoft.Isam.Esent.Serialization..::..EseSerializer..::..ePerformanceOptions


EseSerializer Methods

[image] [image]

EsentSerialization Class Library
EseSerializer Methods
EseSerializer Class See Also Send Feedback

The EseSerializer type exposes the following members.

Methods

 | Name | Description
Public method | AddSerializedType | Add the record type to serializer.
Public method | BackupDatabase | Backup the database.
Public method | Dispose | Close the DB.
Public method | EnsureDatabaseExists | Create the database if it's not exists on the HDD.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindSerializerForType | Find the TypeSerializer for the specified record type.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OpenDatabase | Open or create the DB,and return the session interface of the newly created DB session.
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


AddSerializedType Method

[image]

EsentSerialization Class Library
EseSerializer..::..AddSerializedType Method
EseSerializer Class See Also Send Feedback

Add the record type to serializer.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function AddSerializedType ( _
    t As Type _
) As Boolean
C#
public bool AddSerializedType(
    Type t
)

Parameters

t
Type: System..::..Type
The record type to add.

Return Value

False if the type was already added.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


BackupDatabase Method

[image]

EsentSerialization Class Library
EseSerializer..::..BackupDatabase Method
EseSerializer Class See Also Send Feedback

Backup the database.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub BackupDatabase ( _
    s As Stream, _
    bCompress As Boolean _
)
C#
public void BackupDatabase(
    Stream s,
    bool bCompress
)

Parameters

s
Type: System.IO..::..Stream
The destination stream to write the backup.
bCompress
Type: System..::..Boolean
True to compress the backup.

Remarks

This function saves a full DB backup while the engine and database are online and active. It uses JetBeginExternalBackup API.

The data storage format is either tar, or tar.gzip.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
EseSerializer..::..Dispose Method
EseSerializer Class See Also Send Feedback

Close the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


EnsureDatabaseExists Method

[image]

EsentSerialization Class Library
EseSerializer..::..EnsureDatabaseExists Method
EseSerializer Class See Also Send Feedback

Create the database if it's not exists on the HDD.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub EnsureDatabaseExists
C#
public void EnsureDatabaseExists()

Remarks

Normally, this is called from OpenDatabase(Boolean).
You should only use this method if you're creating database session manually.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


FindSerializerForType Method

[image]

EsentSerialization Class Library
EseSerializer..::..FindSerializerForType Method
EseSerializer Class See Also Send Feedback

Find the TypeSerializer for the specified record type.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function FindSerializerForType ( _
    t As Type _
) As TypeSerializer
C#
public TypeSerializer FindSerializerForType(
    Type t
)

Parameters

t
Type: System..::..Type

Return Value

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


OpenDatabase Method

[image]

EsentSerialization Class Library
EseSerializer..::..OpenDatabase Method
EseSerializer Class See Also Send Feedback

Open or create the DB,and return the session interface of the newly created DB session.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function OpenDatabase ( _
    bOpenAllTables As Boolean _
) As iSerializerSession
C#
public iSerializerSession OpenDatabase(
    bool bOpenAllTables
)

Parameters

bOpenAllTables
Type: System..::..Boolean
True to open tables for every record type currently added to the serializer.

Return Value

iSerializerSession to access the DB.

Remarks

You should call this method on every thread (including the main thread) that's going to use the database.

Below is the recommended C# code:

CopyC#
 1// Your thread procedure
 2void ThreadProc()
 3{
 4    using( iSerializerSession sess = m_serializer.OpenDatabase( false ) )
 5    {
 6        // Open the table in this session ( note we've passed false to the OpenDatabase call )
 7        sess.AddType( typeof( MyRecordClass ) );
 8
 9        // Run your thread; use 'sess' variable to access the DB.
10    }
11}

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer Properties

[image] [image]

EsentSerialization Class Library
EseSerializer Properties
EseSerializer Class See Also Send Feedback

The EseSerializer type exposes the following members.

Properties

 | Name | Description
Public property | bDatabaseEncrypted | True if the DB is NTFS-encrypted
Public property | idInstance |
Public property | isNewDatabase | True if the new DB has been created by the last OpenDatabase call.
Public property | pathDatabase | The full path of the main DB file, which is located inside the folderDatabase.

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


bDatabaseEncrypted Property

[image]

EsentSerialization Class Library
EseSerializer..::..bDatabaseEncrypted Property
EseSerializer Class See Also Send Feedback

True if the DB is NTFS-encrypted

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property bDatabaseEncrypted As Boolean
    Get
C#
public bool bDatabaseEncrypted { get; }

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


idInstance Property

[image]

EsentSerialization Class Library
EseSerializer..::..idInstance Property
EseSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idInstance As JET_INSTANCE
    Get
C#
public JET_INSTANCE idInstance { get; }

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


isNewDatabase Property

[image]

EsentSerialization Class Library
EseSerializer..::..isNewDatabase Property
EseSerializer Class See Also Send Feedback

True if the new DB has been created by the last OpenDatabase call.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property isNewDatabase As Boolean
    Get
C#
public bool isNewDatabase { get; }

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


pathDatabase Property

[image]

EsentSerialization Class Library
EseSerializer..::..pathDatabase Property
EseSerializer Class See Also Send Feedback

The full path of the main DB file, which is located inside the folderDatabase.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property pathDatabase As String
    Get
C#
public string pathDatabase { get; }

See Also

EseSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


EseSerializer.ePerformanceOptions Enumeration

[image]

EsentSerialization Class Library
EseSerializer..::..ePerformanceOptions Enumeration
EseSerializer Class See Also Send Feedback

This enum holds a presets for various DB settings affecting ESENT performance.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Enumeration ePerformanceOptions
C#
public enum ePerformanceOptions

Members

Member name | Description
Default |
OptimizedMedium |
GetPropertiesCollection |

See Also

Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Class

[image]

EsentSerialization Class Library
EseTextFieldBase Class
See Also Send Feedback

Base class for text attributes.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustInherit Class EseTextFieldBase _
    Inherits EseColumnAttrubuteBase
C#
public abstract class EseTextFieldBase : EseColumnAttrubuteBase

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..EseTextFieldBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseMultiTextAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTextAttribute

See Also

Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Constructor

[image] [image]

EsentSerialization Class Library
EseTextFieldBase Constructor
EseTextFieldBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseTextFieldBase()()()() | Initialize with the default column name, which is the name of the field/property, BTW.
Public method | EseTextFieldBase(String) | Initialize with non-default column name.

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Constructor

[image]

EsentSerialization Class Library
EseTextFieldBase Constructor
EseTextFieldBase Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property, BTW.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseTextFieldBase()

See Also

EseTextFieldBase Class
EseTextFieldBase Overload
Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Constructor (String)

[image]

EsentSerialization Class Library
EseTextFieldBase Constructor (String)
EseTextFieldBase Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strName As String _
)
C#
public EseTextFieldBase(
    string strName
)

Parameters

strName
Type: System..::..String

See Also

EseTextFieldBase Class
EseTextFieldBase Overload
Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Fields

[image] [image]

EsentSerialization Class Library
EseTextFieldBase Fields
EseTextFieldBase Class See Also Send Feedback

The EseTextFieldBase type exposes the following members.

Fields

 | Name | Description
Public field | allowNulls |
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_maxChars | Maximum value length, in characters.

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


allowNulls Field

[image]

EsentSerialization Class Library
EseTextFieldBase..::..allowNulls Field
EseTextFieldBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public allowNulls As Boolean
C#
public bool allowNulls

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


m_maxChars Field

[image]

EsentSerialization Class Library
EseTextFieldBase..::..m_maxChars Field
EseTextFieldBase Class See Also Send Feedback

Maximum value length, in characters.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected m_maxChars As Integer
C#
protected int m_maxChars

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Methods

[image] [image]

EsentSerialization Class Library
EseTextFieldBase Methods
EseTextFieldBase Class See Also Send Feedback

The EseTextFieldBase type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Inherited from EseColumnAttrubuteBase.)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Inherited from EseColumnAttrubuteBase.)
Public method | getColumnKind | (Overrides EseColumnAttrubuteBase..::..getColumnKind()()()().)
Protected method | getEncoding | Get the System.Text.Encoding to use.
Public method | GetHashCode | (Inherited from Attribute.)
Protected method | getTextBaseColumnDef |
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Inherited from EseColumnAttrubuteBase.)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Is called by the framework to verify the attribute is compatible with the field type. The implementation must throw an exception if it's not. (Inherited from EseColumnAttrubuteBase.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


getColumnKind Method

[image]

EsentSerialization Class Library
EseTextFieldBase..::..getColumnKind Method
EseTextFieldBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnKind As eColumnKind
C#
public override eColumnKind getColumnKind()

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


getEncoding Method

[image]

EsentSerialization Class Library
EseTextFieldBase..::..getEncoding Method
EseTextFieldBase Class See Also Send Feedback

Get the System.Text.Encoding to use.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Function getEncoding As Encoding
C#
protected Encoding getEncoding()

Return Value

Either Unicode or ASCII.

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


getTextBaseColumnDef Method

[image]

EsentSerialization Class Library
EseTextFieldBase..::..getTextBaseColumnDef Method
EseTextFieldBase Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Function getTextBaseColumnDef As JET_COLUMNDEF
C#
protected JET_COLUMNDEF getTextBaseColumnDef()

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseTextFieldBase..::..MakeKey Method
EseTextFieldBase Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


EseTextFieldBase Properties

[image] [image]

EsentSerialization Class Library
EseTextFieldBase Properties
EseTextFieldBase Class See Also Send Feedback

The EseTextFieldBase type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from EseColumnAttrubuteBase.)
Public property | bUnicode | Is this column stores the Unicode text?
Public property | maxChars | Maximum value length, in characters.
Public property | TypeId | (Inherited from Attribute.)

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


bUnicode Property

[image]

EsentSerialization Class Library
EseTextFieldBase..::..bUnicode Property
EseTextFieldBase Class See Also Send Feedback

Is this column stores the Unicode text?

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property bUnicode As Boolean
    Get
    Set
C#
public bool bUnicode { get; set; }

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


maxChars Property

[image]

EsentSerialization Class Library
EseTextFieldBase..::..maxChars Property
EseTextFieldBase Class See Also Send Feedback

Maximum value length, in characters.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property maxChars As Integer
    Get
    Set
C#
public int maxChars { get; set; }

See Also

EseTextFieldBase Class
Microsoft.Isam.Esent.Serialization Namespace


ImportExportFormat Enumeration

[image]

EsentSerialization Class Library
ImportExportFormat Enumeration
See Also Send Feedback

Table import/export format.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Enumeration ImportExportFormat
C#
public enum ImportExportFormat

Members

Member name | Description
TSV |
Binary |
GetPropertiesCollection |

See Also

Microsoft.Isam.Esent.Serialization Namespace


iNotifyTableChanged Interface

[image]

EsentSerialization Class Library
iNotifyTableChanged Interface
See Also Send Feedback

This interface allows a client to receive notifications when the table is changed.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Interface iNotifyTableChanged
C#
public interface iNotifyTableChanged

Remarks

This interface is implemented by EseCursorBase class.

NB: if you're using ESE in highly concurrent environment (e.g. network server like the AD), and you've called EseTableAttribute.setEventsDispatcher, then events might ruin the parallelism.
If your situation is that tight, just ignore this interface, and implement your own notifications mechanism. Unless you've called EseTableAttribute.setEventsDispatcher, events are not dispatched across threads.

See Also

Microsoft.Isam.Esent.Serialization Namespace


iNotifyTableChanged Events

[image] [image]

EsentSerialization Class Library
iNotifyTableChanged Events
iNotifyTableChanged Interface See Also Send Feedback

The iNotifyTableChanged type exposes the following members.

Events

 | Name | Description
Public event | TableChanged | This event occurs after the table has been changed.

See Also

iNotifyTableChanged Interface
Microsoft.Isam.Esent.Serialization Namespace


TableChanged Event

[image]

EsentSerialization Class Library
iNotifyTableChanged..::..TableChanged Event
iNotifyTableChanged Interface See Also Send Feedback

This event occurs after the table has been changed.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Event TableChanged As NotifyTableChangedHandler
C#
event NotifyTableChangedHandler TableChanged

See Also

iNotifyTableChanged Interface
Microsoft.Isam.Esent.Serialization Namespace


iSerializerSession Interface

[image]

EsentSerialization Class Library
iSerializerSession Interface
See Also Send Feedback

This interface represents a database session.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Interface iSerializerSession _
    Inherits IDisposable
C#
public interface iSerializerSession : IDisposable

Remarks

The session object allows you to begin transactions, and obtain the cached table objects.

If your application is multi-threaded, you should use separate session for every thread.

If your application is an ASP.NET web application, you should use the SessionPool object.

See Also

Microsoft.Isam.Esent.Serialization Namespace


iSerializerSession Methods

[image] [image]

EsentSerialization Class Library
iSerializerSession Methods
iSerializerSession Interface See Also Send Feedback

The iSerializerSession type exposes the following members.

Methods

 | Name | Description
Public method | AddType | Open the table in this session.
Public method | BeginTransaction | Begins a transaction.
Public method | ClearTable | Clear the whole table.
Public method | Dispose | (Inherited from IDisposable.)
Public method | DisposeLastSession | Same as IDisposable.Dispose, but also detaches the DB just before the JetEndSession call.
Public method | ExportTable | Export the whole table to the specified stream.
Public method | ExportTables | Export the specified tables into the ZIP file.
Public method | GetAllTypes | Enumerate opened tables.
Public method | getTable<(Of <<'(tRow>)>>)(BookmarkedRecordset<(Of <<'(tRow>)>>)%) | Get the BookmarkedRecordset object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Cursor<(Of <<'(tRow>)>>)%) | Get the Cursor object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Recordset<(Of <<'(tRow>)>>)%) | Get the Recordset object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Boolean, Cursor<(Of <<'(tRow>)>>)%) |
Public method | GetType | Resolve table name into the record's type.
Public method | ImportTable | Import the table from a stream.
Public method | ImportTables | Import all tables contained inside the ZIP file.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


AddType Method

[image]

EsentSerialization Class Library
iSerializerSession..::..AddType Method
iSerializerSession Interface See Also Send Feedback

Open the table in this session.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub AddType ( _
    tRecord As Type _
)
C#
void AddType(
    Type tRecord
)

Parameters

tRecord
Type: System..::..Type

Remarks

If this type was not added to the EseSerializer who owns this session, it will be added by this method. So, be ready for SerializationException about wrong DB schema.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


BeginTransaction Method

[image]

EsentSerialization Class Library
iSerializerSession..::..BeginTransaction Method
iSerializerSession Interface See Also Send Feedback

Begins a transaction.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function BeginTransaction As iSerializerTransaction
C#
iSerializerTransaction BeginTransaction()

Remarks

You must ( commit or rollback ) and/or Dispose() the returned transaction, otherwise the unmanaged resources will leak pretty fast.

In support of snapshot isolation, the database engine stores all versions of all modified data in memory since the time when the oldest active transaction on any session was first started. It is important to make transactions as short in duration as possible under high load scenarios. The class library provides the method to "pulse" the transaction.

It is highly recommended that the application always be in the context of a transaction when calling ESE APIs that retrieve or update data. If this is not done, the database engine will automatically wrap each ESE API call of this type in a transaction on behalf of the application. The cost of these very short transactions can add up quickly in some cases.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ClearTable Method

[image]

EsentSerialization Class Library
iSerializerSession..::..ClearTable Method
iSerializerSession Interface See Also Send Feedback

Clear the whole table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function ClearTable ( _
    idTable As JET_TABLEID _
) As Integer
C#
int ClearTable(
    JET_TABLEID idTable
)

Parameters

idTable
Type: JET_TABLEID

Return Value

Count of the erased records.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


DisposeLastSession Method

[image]

EsentSerialization Class Library
iSerializerSession..::..DisposeLastSession Method
iSerializerSession Interface See Also Send Feedback

Same as IDisposable.Dispose, but also detaches the DB just before the JetEndSession call.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub DisposeLastSession
C#
void DisposeLastSession()

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ExportTable Method

[image]

EsentSerialization Class Library
iSerializerSession..::..ExportTable Method
iSerializerSession Interface See Also Send Feedback

Export the whole table to the specified stream.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub ExportTable ( _
    tRecord As Type, _
    stm As Stream, _
    fmt As ImportExportFormat _
)
C#
void ExportTable(
    Type tRecord,
    Stream stm,
    ImportExportFormat fmt
)

Parameters

tRecord
Type: System..::..Type
stm
Type: System.IO..::..Stream
fmt
Type: Microsoft.Isam.Esent.Serialization..::..ImportExportFormat
Export format.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ExportTables Method

[image]

EsentSerialization Class Library
iSerializerSession..::..ExportTables Method
iSerializerSession Interface See Also Send Feedback

Export the specified tables into the ZIP file.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub ExportTables ( _
    tRecords As Type(), _
    exportFile As String _
)
C#
void ExportTables(
    Type[] tRecords,
    string exportFile
)

Parameters

tRecords
Type: array< System..::..Type >[]()[][]
Record types to export.
exportFile
Type: System..::..String
Path of the ZIP file to create.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


GetAllTypes Method

[image]

EsentSerialization Class Library
iSerializerSession..::..GetAllTypes Method
iSerializerSession Interface See Also Send Feedback

Enumerate opened tables.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function GetAllTypes As IEnumerable(Of pair(Of Type, String))
C#
IEnumerable<pair<Type, string>> GetAllTypes()

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


getTable Method

[image] [image]

EsentSerialization Class Library
iSerializerSession..::..getTable Method
iSerializerSession Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | getTable<(Of <<'(tRow>)>>)(BookmarkedRecordset<(Of <<'(tRow>)>>)%) | Get the BookmarkedRecordset object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Cursor<(Of <<'(tRow>)>>)%) | Get the Cursor object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Recordset<(Of <<'(tRow>)>>)%) | Get the Recordset object for a table.
Public method | getTable<(Of <<'(tRow>)>>)(Boolean, Cursor<(Of <<'(tRow>)>>)%) |

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


getTable(tRow) Method (BookmarkedRecordset(tRow))

[image]

EsentSerialization Class Library
iSerializerSession..::..getTable<(Of <(<'tRow>)>)> Method (BookmarkedRecordset<(Of <(<'tRow>)>)>%)
iSerializerSession Interface See Also Send Feedback

Get the BookmarkedRecordset object for a table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub getTable(Of tRow As New) ( _
    <OutAttribute> ByRef res As BookmarkedRecordset(Of tRow) _
)
C#
void getTable<tRow>(
    out BookmarkedRecordset<tRow> res
)
where tRow : new()

Parameters

res
Type: Microsoft.Isam.Esent.Serialization..::..BookmarkedRecordset <(Of <(<'tRow>)>)>%

Type Parameters

tRow

See Also

iSerializerSession Interface
getTable Overload
Microsoft.Isam.Esent.Serialization Namespace


getTable(tRow) Method (Cursor(tRow))

[image]

EsentSerialization Class Library
iSerializerSession..::..getTable<(Of <(<'tRow>)>)> Method (Cursor<(Of <(<'tRow>)>)>%)
iSerializerSession Interface See Also Send Feedback

Get the Cursor object for a table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub getTable(Of tRow As New) ( _
    <OutAttribute> ByRef res As Cursor(Of tRow) _
)
C#
void getTable<tRow>(
    out Cursor<tRow> res
)
where tRow : new()

Parameters

res
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<'tRow>)>)>%

Type Parameters

tRow

See Also

iSerializerSession Interface
getTable Overload
Microsoft.Isam.Esent.Serialization Namespace


getTable(tRow) Method (Recordset(tRow))

[image]

EsentSerialization Class Library
iSerializerSession..::..getTable<(Of <(<'tRow>)>)> Method (Recordset<(Of <(<'tRow>)>)>%)
iSerializerSession Interface See Also Send Feedback

Get the Recordset object for a table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub getTable(Of tRow As New) ( _
    <OutAttribute> ByRef res As Recordset(Of tRow) _
)
C#
void getTable<tRow>(
    out Recordset<tRow> res
)
where tRow : new()

Parameters

res
Type: Microsoft.Isam.Esent.Serialization..::..Recordset <(Of <(<'tRow>)>)>%

Type Parameters

tRow

See Also

iSerializerSession Interface
getTable Overload
Microsoft.Isam.Esent.Serialization Namespace


getTable(tRow) Method (Boolean, Cursor(tRow))

[image]

EsentSerialization Class Library
iSerializerSession..::..getTable<(Of <(<'tRow>)>)> Method (Boolean, Cursor<(Of <(<'tRow>)>)>%)
iSerializerSession Interface See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub getTable(Of tRow As New) ( _
    bReadOnly As Boolean, _
    <OutAttribute> ByRef res As Cursor(Of tRow) _
)
C#
void getTable<tRow>(
    bool bReadOnly,
    out Cursor<tRow> res
)
where tRow : new()

Parameters

bReadOnly
Type: System..::..Boolean
res
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<'tRow>)>)>%

Type Parameters

tRow

See Also

iSerializerSession Interface
getTable Overload
Microsoft.Isam.Esent.Serialization Namespace


GetType Method

[image]

EsentSerialization Class Library
iSerializerSession..::..GetType Method
iSerializerSession Interface See Also Send Feedback

Resolve table name into the record's type.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function GetType ( _
    strTableName As String _
) As Type
C#
Type GetType(
    string strTableName
)

Parameters

strTableName
Type: System..::..String
The table name; the value is case-sensitive.

Return Value

Record type, or null if the table was not found.

Remarks

This function only looks through the tables opened in this session.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ImportTable Method

[image]

EsentSerialization Class Library
iSerializerSession..::..ImportTable Method
iSerializerSession Interface See Also Send Feedback

Import the table from a stream.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub ImportTable ( _
    tRecord As Type, _
    stm As Stream, _
    fmt As ImportExportFormat _
)
C#
void ImportTable(
    Type tRecord,
    Stream stm,
    ImportExportFormat fmt
)

Parameters

tRecord
Type: System..::..Type
stm
Type: System.IO..::..Stream
fmt
Type: Microsoft.Isam.Esent.Serialization..::..ImportExportFormat
Import format

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ImportTables Method

[image]

EsentSerialization Class Library
iSerializerSession..::..ImportTables Method
iSerializerSession Interface See Also Send Feedback

Import all tables contained inside the ZIP file.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub ImportTables ( _
    importFile As String _
)
C#
void ImportTables(
    string importFile
)

Parameters

importFile
Type: System..::..String
ZIP file to read.

Remarks

All existing data in those tables will be erased. You must open all those types in this session before this call.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


iSerializerSession Properties

[image] [image]

EsentSerialization Class Library
iSerializerSession Properties
iSerializerSession Interface See Also Send Feedback

The iSerializerSession type exposes the following members.

Properties

 | Name | Description
Public property | idDatabase | Native database ID.
Public property | idSession | Native session ID
Public property | isInTransaction |
Public property | serializer | The EseSerializer who owns this session.
Public property | transaction | If this session is currently in transaction, returns the transaction, otherwise returns null.

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


idDatabase Property

[image]

EsentSerialization Class Library
iSerializerSession..::..idDatabase Property
iSerializerSession Interface See Also Send Feedback

Native database ID.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property idDatabase As JET_DBID
    Get
C#
JET_DBID idDatabase { get; }

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


idSession Property

[image]

EsentSerialization Class Library
iSerializerSession..::..idSession Property
iSerializerSession Interface See Also Send Feedback

Native session ID

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property idSession As JET_SESID
    Get
C#
JET_SESID idSession { get; }

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


isInTransaction Property

[image]

EsentSerialization Class Library
iSerializerSession..::..isInTransaction Property
iSerializerSession Interface See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property isInTransaction As Boolean
    Get
C#
bool isInTransaction { get; }

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


serializer Property

[image]

EsentSerialization Class Library
iSerializerSession..::..serializer Property
iSerializerSession Interface See Also Send Feedback

The EseSerializer who owns this session.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property serializer As EseSerializer
    Get
C#
EseSerializer serializer { get; }

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


transaction Property

[image]

EsentSerialization Class Library
iSerializerSession..::..transaction Property
iSerializerSession Interface See Also Send Feedback

If this session is currently in transaction, returns the transaction, otherwise returns null.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property transaction As iSerializerTransaction
    Get
C#
iSerializerTransaction transaction { get; }

See Also

iSerializerSession Interface
Microsoft.Isam.Esent.Serialization Namespace


iSerializerTransaction Interface

[image]

EsentSerialization Class Library
iSerializerTransaction Interface
See Also Send Feedback

This interface represents a database transaction.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Interface iSerializerTransaction _
    Inherits IDisposable
C#
public interface iSerializerTransaction : IDisposable

Remarks

You must ( Commit() or LazyCommit() or Rollback() ) and/or Dispose() the transaction, otherwise the unmanaged resources will leak enormously fast.

See Also

Microsoft.Isam.Esent.Serialization Namespace


iSerializerTransaction Methods

[image] [image]

EsentSerialization Class Library
iSerializerTransaction Methods
iSerializerTransaction Interface See Also Send Feedback

The iSerializerTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commit the transaction and flush the transaction log. Doing so will close this transaction.
Public method | Dispose | (Inherited from IDisposable.)
Public method | LazyCommit | Commit the transaction, but this API does not wait for the transaction to be flushed to the transaction log file before returning to the caller. Doing so will close this transaction.
Public method | LazyCommitAndReopen | Call LazyCommit, then re-open this transaction, using the same session.
Public method | Rollback | Rollback the transaction. Doing so will close this transaction.
Public method | TryLockCurrentRecord | Try to lock the current record.

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


Commit Method

[image]

EsentSerialization Class Library
iSerializerTransaction..::..Commit Method
iSerializerTransaction Interface See Also Send Feedback

Commit the transaction and flush the transaction log. Doing so will close this transaction.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub Commit
C#
void Commit()

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


LazyCommit Method

[image]

EsentSerialization Class Library
iSerializerTransaction..::..LazyCommit Method
iSerializerTransaction Interface See Also Send Feedback

Commit the transaction, but this API does not wait for the transaction to be flushed to the transaction log file before returning to the caller. Doing so will close this transaction.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub LazyCommit
C#
void LazyCommit()

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


LazyCommitAndReopen Method

[image]

EsentSerialization Class Library
iSerializerTransaction..::..LazyCommitAndReopen Method
iSerializerTransaction Interface See Also Send Feedback

Call LazyCommit, then re-open this transaction, using the same session.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub LazyCommitAndReopen
C#
void LazyCommitAndReopen()

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


Rollback Method

[image]

EsentSerialization Class Library
iSerializerTransaction..::..Rollback Method
iSerializerTransaction Interface See Also Send Feedback

Rollback the transaction. Doing so will close this transaction.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub Rollback
C#
void Rollback()

Remarks

IDisposable.Dispose does the same.

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


TryLockCurrentRecord Method

[image]

EsentSerialization Class Library
iSerializerTransaction..::..TryLockCurrentRecord Method
iSerializerTransaction Interface See Also Send Feedback

Try to lock the current record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function TryLockCurrentRecord ( _
    cur As EseCursorBase _
) As Boolean
C#
bool TryLockCurrentRecord(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The current record on this cursor will be locked for writing.

Remarks

This is useful if you're going to update this record at some later point in this transaction.

See Also

iSerializerTransaction Interface
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer Interface

[image]

EsentSerialization Class Library
iTypeSerializer Interface
See Also Send Feedback

Serializer instance for the specific record type

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Interface iTypeSerializer
C#
public interface iTypeSerializer

See Also

Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer Methods

[image] [image]

EsentSerialization Class Library
iTypeSerializer Methods
iTypeSerializer Interface See Also Send Feedback

The iTypeSerializer type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Fetch all object's fields from the current record of the specified table.
Public method | DeserializeField | Fetch the specific object's field from the current record of the specified table.
Public method | FetchSingleField | Fetch the specific field from the current record of the specified table.
Public method | GetColumnId | Resolve column name to JET_COLUMNID.
Public method | getIndexColumnAttribute | Return the instance of the EseColumnAttrubuteBase-based attribute class of the column covered by the specified index.
Public method | getIndexColumnCount | Return the count of the columns indexed by the specified index.
Public method | RawIndex | Get index of the specified field on the record's raw data.
Public method | RawRead | Read all fields of the record under the cursor.
Public method | RawWrite | Write all fields of the record.
Public method | RecreateTable | Drop the table with all the data, and create the new table.
Public method | SaveSingleField | Update the value of the specific field of the current record.
Public method | Serialize | Store all fields of the record in the table.
Public method | SerializeField | Store only the specific field of the record.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


Deserialize Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..Deserialize Method
iTypeSerializer Interface See Also Send Feedback

Fetch all object's fields from the current record of the specified table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub Deserialize ( _
    cur As EseCursorBase, _
    rec As Object _
)
C#
void Deserialize(
    EseCursorBase cur,
    Object rec
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor
rec
Type: System..::..Object
The fields / properties of this object will be filled with the values fetched from the database.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


DeserializeField Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..DeserializeField Method
iTypeSerializer Interface See Also Send Feedback

Fetch the specific object's field from the current record of the specified table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub DeserializeField ( _
    cur As EseCursorBase, _
    rec As Object, _
    fName As String _
)
C#
void DeserializeField(
    EseCursorBase cur,
    Object rec,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
rec
Type: System..::..Object
The object to receive the new field value.
fName
Type: System..::..String
ESE column name to load from the table.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


FetchSingleField Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..FetchSingleField Method
iTypeSerializer Interface See Also Send Feedback

Fetch the specific field from the current record of the specified table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function FetchSingleField ( _
    cur As EseCursorBase, _
    fName As String _
) As Object
C#
Object FetchSingleField(
    EseCursorBase cur,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
fName
Type: System..::..String
ESE column name to load from the table.

Return Value

The field value.

Remarks

This method was implemented because sometimes, e.g. while traversing the DB-backed tree searching for something, you only need the value of a single field.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


GetColumnId Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..GetColumnId Method
iTypeSerializer Interface See Also Send Feedback

Resolve column name to JET_COLUMNID.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function GetColumnId ( _
    cur As EseCursorBase, _
    fName As String _
) As JET_COLUMNID
C#
JET_COLUMNID GetColumnId(
    EseCursorBase cur,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
fName
Type: System..::..String
ESE column name to resolve.

Return Value

Column ID.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


getIndexColumnAttribute Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..getIndexColumnAttribute Method
iTypeSerializer Interface See Also Send Feedback

Return the instance of the EseColumnAttrubuteBase-based attribute class of the column covered by the specified index.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function getIndexColumnAttribute ( _
    strIndexName As String, _
    iCol As Integer _
) As EseColumnAttrubuteBase
C#
EseColumnAttrubuteBase getIndexColumnAttribute(
    string strIndexName,
    int iCol
)

Parameters

strIndexName
Type: System..::..String
Name of the index
iCol
Type: System..::..Int32
Zero-based column ID. Valid values are from 0 to getIndexColumnCount( strIndexName ) - 1

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


getIndexColumnCount Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..getIndexColumnCount Method
iTypeSerializer Interface See Also Send Feedback

Return the count of the columns indexed by the specified index.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function getIndexColumnCount ( _
    strIndexName As String _
) As Integer
C#
int getIndexColumnCount(
    string strIndexName
)

Parameters

strIndexName
Type: System..::..String
Name of the index to query the indexed columns count.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


RawIndex Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..RawIndex Method
iTypeSerializer Interface See Also Send Feedback

Get index of the specified field on the record's raw data.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function RawIndex ( _
    fieldName As String _
) As Integer
C#
int RawIndex(
    string fieldName
)

Parameters

fieldName
Type: System..::..String
ESE column name to resolve.

Return Value

Zero-based index of this column.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


RawRead Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..RawRead Method
iTypeSerializer Interface See Also Send Feedback

Read all fields of the record under the cursor.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function RawRead ( _
    cur As EseCursorBase _
) As Byte()()
C#
byte[][] RawRead(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.

Return Value

Array of column data.

Remarks

This method should not be used routinely, to read the fields. It was designed for replicating the records over a network.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


RawWrite Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..RawWrite Method
iTypeSerializer Interface See Also Send Feedback

Write all fields of the record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub RawWrite ( _
    cur As EseCursorBase, _
    data As Byte()() _
)
C#
void RawWrite(
    EseCursorBase cur,
    byte[][] data
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
data
Type: array<array< System..::..Byte >[]()[][]>[]()[][]
Array of column data.

Remarks

This method will first try to construct a search key on the primary index. If the record is found, this method will update it. Otherwise, a new record will be inserted into the table.

This method performs very little type checking. Please, ensure the source data came from the table with exactly the same columns schema.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


RecreateTable Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..RecreateTable Method
iTypeSerializer Interface See Also Send Feedback

Drop the table with all the data, and create the new table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub RecreateTable ( _
    sess As iSerializerSession _
)
C#
void RecreateTable(
    iSerializerSession sess
)

Parameters

sess
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession

Remarks

Achtung! Calling this method will destroy all the data stored in the table.

If you're accessing the DB with a session pool (either SessionPool or AspSessionPool), you must reopen the DB after recreating a table: the pool caches the table cursor, and the old cursor handles are no longer valid after the table is recreated.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


SaveSingleField Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..SaveSingleField Method
iTypeSerializer Interface See Also Send Feedback

Update the value of the specific field of the current record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub SaveSingleField ( _
    cur As EseCursorBase, _
    fName As String, _
    value As Object _
)
C#
void SaveSingleField(
    EseCursorBase cur,
    string fName,
    Object value
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
fName
Type: System..::..String
ESE column name to load from the table.
value
Type: System..::..Object
New field value.

Remarks

The writable transaction must be opened before this call.

This method was implemented as the performance optimization: when you only need to update a single field, and you don't have the complete object.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


Serialize Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..Serialize Method
iTypeSerializer Interface See Also Send Feedback

Store all fields of the record in the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub Serialize ( _
    cur As EseCursorBase, _
    rec As Object, _
    bNewRecord As Boolean _
)
C#
void Serialize(
    EseCursorBase cur,
    Object rec,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor
rec
Type: System..::..Object
The object to store in the database. The type of the object must match the table.
bNewRecord
Type: System..::..Boolean
True for INSERT operations, false for UPDATE operations.

Remarks

The writable transaction must be opened before this call.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


SerializeField Method

[image]

EsentSerialization Class Library
iTypeSerializer..::..SerializeField Method
iTypeSerializer Interface See Also Send Feedback

Store only the specific field of the record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub SerializeField ( _
    cur As EseCursorBase, _
    rec As Object, _
    fName As String _
)
C#
void SerializeField(
    EseCursorBase cur,
    Object rec,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor
rec
Type: System..::..Object
The object to store in the database. The type of the object must match the table.
fName
Type: System..::..String
ESE column name to store in the table.

Remarks

The writable transaction must be opened before this call.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer Properties

[image] [image]

EsentSerialization Class Library
iTypeSerializer Properties
iTypeSerializer Interface See Also Send Feedback

The iTypeSerializer type exposes the following members.

Properties

 | Name | Description
Public property | tableAttribute | Get the [EseTable] attribute instance.

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


tableAttribute Property

[image]

EsentSerialization Class Library
iTypeSerializer..::..tableAttribute Property
iTypeSerializer Interface See Also Send Feedback

Get the [EseTable] attribute instance.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
ReadOnly Property tableAttribute As EseTableAttribute
    Get
C#
EseTableAttribute tableAttribute { get; }

See Also

iTypeSerializer Interface
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedAction Enumeration

[image]

EsentSerialization Class Library
NotifyTableChangedAction Enumeration
See Also Send Feedback

This enum defines what operation caused the TableChanged event.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Enumeration NotifyTableChangedAction
C#
public enum NotifyTableChangedAction

Members

Member name | Description
Add |
Remove |
Update |
Reset |
GetPropertiesCollection |

See Also

Microsoft.Isam.Esent.Serialization Namespace
Microsoft.Isam.Esent.Serialization..::..iNotifyTableChanged


NotifyTableChangedArgs Structure

[image]

EsentSerialization Class Library
NotifyTableChangedArgs Structure
See Also Send Feedback

The argument for the TableChanged event.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Structure NotifyTableChangedArgs
C#
public struct NotifyTableChangedArgs

See Also

Microsoft.Isam.Esent.Serialization Namespace
Microsoft.Isam.Esent.Serialization..::..iNotifyTableChanged


NotifyTableChangedArgs Constructor

[image] [image]

EsentSerialization Class Library
NotifyTableChangedArgs Constructor
NotifyTableChangedArgs Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | NotifyTableChangedArgs(NotifyTableChangedAction) |
Public method | NotifyTableChangedArgs(NotifyTableChangedAction, ByteArray) |
Public method | NotifyTableChangedArgs(NotifyTableChangedAction, ByteArray, String) |

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedArgs Constructor (NotifyTableChangedAction)

[image]

EsentSerialization Class Library
NotifyTableChangedArgs Constructor (NotifyTableChangedAction)
NotifyTableChangedArgs Structure See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    action As NotifyTableChangedAction _
)
C#
public NotifyTableChangedArgs(
    NotifyTableChangedAction action
)

Parameters

action
Type: Microsoft.Isam.Esent.Serialization..::..NotifyTableChangedAction

See Also

NotifyTableChangedArgs Structure
NotifyTableChangedArgs Overload
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedArgs Constructor (NotifyTableChangedAction, ByteArray)

[image]

EsentSerialization Class Library
NotifyTableChangedArgs Constructor (NotifyTableChangedAction, ByteArray)
NotifyTableChangedArgs Structure See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    action As NotifyTableChangedAction, _
    bookmark As ByteArray _
)
C#
public NotifyTableChangedArgs(
    NotifyTableChangedAction action,
    ByteArray bookmark
)

Parameters

action
Type: Microsoft.Isam.Esent.Serialization..::..NotifyTableChangedAction
bookmark
Type: (Default Namespace)..::..ByteArray

See Also

NotifyTableChangedArgs Structure
NotifyTableChangedArgs Overload
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedArgs Constructor (NotifyTableChangedAction, ByteArray, String)

[image]

EsentSerialization Class Library
NotifyTableChangedArgs Constructor (NotifyTableChangedAction, ByteArray, String)
NotifyTableChangedArgs Structure See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    action As NotifyTableChangedAction, _
    bookmark As ByteArray, _
    field As String _
)
C#
public NotifyTableChangedArgs(
    NotifyTableChangedAction action,
    ByteArray bookmark,
    string field
)

Parameters

action
Type: Microsoft.Isam.Esent.Serialization..::..NotifyTableChangedAction
bookmark
Type: (Default Namespace)..::..ByteArray
field
Type: System..::..String

See Also

NotifyTableChangedArgs Structure
NotifyTableChangedArgs Overload
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedArgs Fields

[image] [image]

EsentSerialization Class Library
NotifyTableChangedArgs Fields
NotifyTableChangedArgs Structure See Also Send Feedback

The NotifyTableChangedArgs type exposes the following members.

Fields

 | Name | Description
Public field | Action | The action that caused the event.
Public field | Bookmark | Bookmark of the affected record. May be null.
Public field | Column | Updated column. May be null, which indicates several columns were updated.

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


Action Field

[image]

EsentSerialization Class Library
NotifyTableChangedArgs..::..Action Field
NotifyTableChangedArgs Structure See Also Send Feedback

The action that caused the event.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Action As NotifyTableChangedAction
C#
public readonly NotifyTableChangedAction Action

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


Bookmark Field

[image]

EsentSerialization Class Library
NotifyTableChangedArgs..::..Bookmark Field
NotifyTableChangedArgs Structure See Also Send Feedback

Bookmark of the affected record. May be null.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Bookmark As ByteArray
C#
public readonly ByteArray Bookmark

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


Column Field

[image]

EsentSerialization Class Library
NotifyTableChangedArgs..::..Column Field
NotifyTableChangedArgs Structure See Also Send Feedback

Updated column. May be null, which indicates several columns were updated.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Column As String
C#
public readonly string Column

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedArgs Methods

[image] [image]

EsentSerialization Class Library
NotifyTableChangedArgs Methods
NotifyTableChangedArgs Structure See Also Send Feedback

The NotifyTableChangedArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

NotifyTableChangedArgs Structure
Microsoft.Isam.Esent.Serialization Namespace


NotifyTableChangedHandler Delegate

[image]

EsentSerialization Class Library
NotifyTableChangedHandler Delegate
See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Delegate Sub NotifyTableChangedHandler ( _
    sender As Object, _
    e As NotifyTableChangedArgs _
)
C#
public delegate void NotifyTableChangedHandler(
    Object sender,
    NotifyTableChangedArgs e
)

Parameters

sender
Type: System..::..Object
e
Type: Microsoft.Isam.Esent.Serialization..::..NotifyTableChangedArgs

See Also

Microsoft.Isam.Esent.Serialization Namespace
Microsoft.Isam.Esent.Serialization..::..iNotifyTableChanged


OptionallyNullableColumn Class

[image]

EsentSerialization Class Library
OptionallyNullableColumn Class
See Also Send Feedback

Abstract base class for the columns that may either be nullable or not, depending on whether the field/property type is nullable or not.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public MustInherit Class OptionallyNullableColumn _
    Inherits EseColumnAttrubuteBase
C#
public abstract class OptionallyNullableColumn : EseColumnAttrubuteBase

Remarks

The specific classes are in the Microsoft.Isam.Esent.Serialization.Attributes namespace.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseBoolAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseByteAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDateTimeAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDateTimeOffsetAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDecimalAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDoubleAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseFloatAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseGuidAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIntAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortIntAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseUShortIntAttribute

See Also

Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Constructor

[image] [image]

EsentSerialization Class Library
OptionallyNullableColumn Constructor
OptionallyNullableColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OptionallyNullableColumn()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | OptionallyNullableColumn(String) | Initialize with non-default column name.

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Constructor

[image]

EsentSerialization Class Library
OptionallyNullableColumn Constructor
OptionallyNullableColumn Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public OptionallyNullableColumn()

See Also

OptionallyNullableColumn Class
OptionallyNullableColumn Overload
Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Constructor (String)

[image]

EsentSerialization Class Library
OptionallyNullableColumn Constructor (String)
OptionallyNullableColumn Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public OptionallyNullableColumn(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

OptionallyNullableColumn Class
OptionallyNullableColumn Overload
Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Fields

[image] [image]

EsentSerialization Class Library
OptionallyNullableColumn Fields
OptionallyNullableColumn Class See Also Send Feedback

The OptionallyNullableColumn type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable.

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


m_bFieldNullable Field

[image]

EsentSerialization Class Library
OptionallyNullableColumn..::..m_bFieldNullable Field
OptionallyNullableColumn Class See Also Send Feedback

true if this column is nullable.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected m_bFieldNullable As Boolean
C#
protected bool m_bFieldNullable

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Methods

[image] [image]

EsentSerialization Class Library
OptionallyNullableColumn Methods
OptionallyNullableColumn Class See Also Send Feedback

The OptionallyNullableColumn type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Inherited from EseColumnAttrubuteBase.)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Inherited from EseColumnAttrubuteBase.)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible.
Public method | verifyTypeSupport | Is called by the framework to verify the attribute is compatible with the field type. The implementation must throw an exception if it's not. (Inherited from EseColumnAttrubuteBase.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
OptionallyNullableColumn..::..getColumnDef Method
OptionallyNullableColumn Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

Remarks

The definition returned by this method contains no column type: it only has ColumndefGrbit.ColumnFixed flag, and optionally ColumndefGrbit.ColumnNotNULL flag.

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


verifyBasicTypeSupport(tDesired) Method

[image]

EsentSerialization Class Library
OptionallyNullableColumn..::..verifyBasicTypeSupport<(Of <(<'tDesired>)>)> Method
OptionallyNullableColumn Class See Also Send Feedback

Verify the type. Throws new SerializationException if the type is incompatible.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub verifyBasicTypeSupport(Of tDesired As {Structure, New}) ( _
    t As Type _
)
C#
protected void verifyBasicTypeSupport<tDesired>(
    Type t
)
where tDesired : struct, new()

Parameters

t
Type: System..::..Type
The type of the property/method this attribute is applied to.

Type Parameters

tDesired
The desired basic type.

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


OptionallyNullableColumn Properties

[image] [image]

EsentSerialization Class Library
OptionallyNullableColumn Properties
OptionallyNullableColumn Class See Also Send Feedback

The OptionallyNullableColumn type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
OptionallyNullableColumn..::..bFieldNullable Property
OptionallyNullableColumn Class See Also Send Feedback

Returns true if this column is nullable.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

OptionallyNullableColumn Class
Microsoft.Isam.Esent.Serialization Namespace


Recordset(tRow) Class

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class represents a subset of records from the Cursor<(Of <(<'tRow>)>)>.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class Recordset(Of tRow As New) _
    Implements IDisposable
C#
public class Recordset<tRow> : IDisposable
where tRow : new()

Type Parameters

tRow
Type of the records stored in the underlying ESENT table (a type marked with [EseTable] attribute).

Remarks

Optionally, the row order is flipped (not every filter supports reverse order, however).

Theoretically, this might be the right place to implement IQueryable interface.
Practically however, all my project based on ESENT can do great with only a subset of querying functionality implemented below, so I have very little motivation to do that.
Besides, the indices are assigned manually by user, so only simple skip/take/count methods can be implemented generically.

Only queries that benefit from indexing are implemented in this class.
For the rest of the query/filter/search/sort/etc functionality, use LINQ on the IEnumerable returned by all()()()() or uniq()()()() methods.

NB! Navigation limit set by filter is volatile. It will be canceled if any navigation other than JetMove is performed on the cursor.
On the other hand, the filter is re-applied frequently, e.g. on each 'all()' call.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..Recordset<(Of <(<'tRow>)>)>
Microsoft.Isam.Esent.Serialization..::..BookmarkedRecordset<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


Recordset(tRow) Constructor

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)> Constructor
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Construct from the cursor

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _cursor As Cursor(Of tRow) _
)
C#
public Recordset(
    Cursor<tRow> _cursor
)

Parameters

_cursor
Type: Microsoft.Isam.Esent.Serialization..::..Cursor <(Of <(<' tRow >)>)>

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Recordset(tRow) Methods

[image] [image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)> Methods
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

The Recordset<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | all | Get the enumerator of the records rows.
Public method | applyFilter | Apply the filter, and move the cursor to the first matching record.
Public method | Clone | Clone the recordset.
Public method | Count | Apply filter, then count the records.
Public method | CountToEnd | Count the records from the current cursor position to the end of the current range.
Public method | CreateOwnCursor | Duplicate the ESENT cursor to get the own copy for this recordset.
Public method | Dispose | Dispose the object.
Public method | Equals | (Inherited from Object.)
Public method | EraseAll | Erase all the items that match the search filter.
Public method | EstimateRecordsCount | Roughly estimate the count of the records matching the currently set filter.
Public method | filterClear()()()() | Clear any filter, i.e. set the sort order to the non-reversed primary index, and cancel navigation limitations.
Public method | filterClear(Boolean) | Set the sort order to the primary index, cancel navigation limitations, and optionally reverse the records.
Public method | filterFindBetween | Filter the recordset only including the records listed on the specified index, where the indexed columns values are between the specified values.
Public method | filterFindBetweenInv | Same as filterFindBetween(String, array<Object>[]()[][], array<Object>[]()[][]), but the order is flipped, i.e. records are returned from end to start.
Public method | filterFindEqual | Include the records where the indexed columns values are exactly the same as the supplied arguments.
Public method | filterFindEqualInv | Include the records, where the indexed columns values are exactly the same as the supplied arguments. The output is reversed.
Public method | filterFindSubstring | Filter the recordset only including the records listed on the specified index, where the indexed columns values are the same as the supplied arguments. The last supplied argument however is threated like it contains the wildcard at the end.
Public method | filterSort | Set the sort order to the specified index, and optionally reverse the records.
Protected method | Finalize | (Inherited from Object.)
Public method | getFirst | Return the first value in the recordset, or default( tRow ) when there's no records matching the filter.
Public method | getFirstBookmark | Get the bookmark of the first record in the recordset, or ByteArray.Empty when there's no records matching the filter.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | isEmpty | Apply the filter, and move the cursor to the first matching record.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | tryGotoBookmark | Apply the search filter, and goto the bookmark
Public method | tryMoveFirst | Move the cursor to the first record.
Public method | tryMoveLast | Move the cursor to the last recored.
Public method | tryMoveNext |
Public method | tryMovePrevious |
Public method | uniq | Same as all(), but unduplicates the output.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


all Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..all Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the enumerator of the records rows.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function all As IEnumerable(Of tRow)
C#
public IEnumerable<tRow> all()

Return Value

Rows enumerator

Remarks

For best performance, it's recommended to execute this method within a transaction.

Remember: by default, all recordset of given table within same session share the cursor state: current index, position, and navigation limits.

So you have 2 options how to handle the result of this function:

  1. Immediately fetch the whole result, e.g. call Enumerable.ToList().
    While fetching the result, don't attempt to use the same table.
    Currently, this race condition is not checked, so you'll see no exceptions, no asserts, just faulty recordset (missing records and/or duplicates).
  2. If you do need lazy evaluations for a good reason (your table is long and/or your objects are huge), then please make sure the recordset is cursor-owning, and don't forget to properly dispose the recordset after you no longer need it.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace
Recordset<(Of <(<'tRow>)>)>..::..CreateOwnCursor()()()()


applyFilter Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..applyFilter Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Apply the filter, and move the cursor to the first matching record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function applyFilter As Boolean
C#
public bool applyFilter()

Return Value

Return false if there's no matching records.

Remarks

This method is called pretty often, e.g. from the all()()()() method.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Clone Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..Clone Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Clone the recordset.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Clone As Recordset(Of tRow)
C#
public Recordset<tRow> Clone()

Remarks

The clone contains the same cursor.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Count Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..Count Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Apply filter, then count the records.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Count As Integer
C#
public int Count()

Return Value

Records count.

Remarks

The execution time is proportional to the count of matched records.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


CountToEnd Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..CountToEnd Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Count the records from the current cursor position to the end of the current range.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function CountToEnd As Integer
C#
public int CountToEnd()

Return Value

Records count

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


CreateOwnCursor Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..CreateOwnCursor Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Duplicate the ESENT cursor to get the own copy for this recordset.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub CreateOwnCursor
C#
public void CreateOwnCursor()

Remarks

This is required e.g. when you're fetching records from the recordset, and process them in a way that requires another query to the same table.
This operation also clears the search/sort filter.
NB! After you've called this method, you must dispose the cursor. Here's the recommended usage:
CopyC#
1rsAux.CreateOwnCursor();
2using( rsAux )
3{
4    // Use rsAux to query the table.
5}

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..Dispose Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Dispose the object.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

Remarks

NB! If you've ever called CreateOwnCursor()()()(), you _must_ properly dispose the recordset.
If you didn't call CreateOwnCursor(), then this recordset will contain an instance of the cursor owned by the session; disposing of sessioon-owned cursor does absolutely nothing.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EraseAll Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..EraseAll Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Erase all the items that match the search filter.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function EraseAll As Integer
C#
public int EraseAll()

Return Value

Count of the erased records.

Remarks

Don't execute this for recordsets with huge number of filtered items: the deletion is _not_ divided across several transactions.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


EstimateRecordsCount Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..EstimateRecordsCount Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Roughly estimate the count of the records matching the currently set filter.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function EstimateRecordsCount As Integer
C#
public int EstimateRecordsCount()

Remarks

Not every search filter type supports this feature, be ready for NotSupportedException.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterClear Method

[image] [image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterClear Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | filterClear()()()() | Clear any filter, i.e. set the sort order to the non-reversed primary index, and cancel navigation limitations.
Public method | filterClear(Boolean) | Set the sort order to the primary index, cancel navigation limitations, and optionally reverse the records.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterClear Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterClear Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Clear any filter, i.e. set the sort order to the non-reversed primary index, and cancel navigation limitations.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterClear
C#
public void filterClear()

Remarks

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
filterClear Overload
Microsoft.Isam.Esent.Serialization Namespace


filterClear Method (Boolean)

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterClear Method (Boolean)
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Set the sort order to the primary index, cancel navigation limitations, and optionally reverse the records.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterClear ( _
    bReverseOrder As Boolean _
)
C#
public void filterClear(
    bool bReverseOrder
)

Parameters

bReverseOrder
Type: System..::..Boolean
set to true to make the recordset to return the results in the reversed order, i.e. from last record to the first record.

Remarks

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
filterClear Overload
Microsoft.Isam.Esent.Serialization Namespace


filterFindBetween Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterFindBetween Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Filter the recordset only including the records listed on the specified index, where the indexed columns values are between the specified values.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterFindBetween ( _
    indName As String, _
    valsStart As Object(), _
    valsEnd As Object() _
)
C#
public void filterFindBetween(
    string indName,
    Object[] valsStart,
    Object[] valsEnd
)

Parameters

indName
Type: System..::..String
Name of the index, as supplied to the [EseIndex] attribute constructor.
valsStart
Type: array< System..::..Object >[]()[][]
Starting values of the indexed columns, in the same order they go in the index.
valsEnd
Type: array< System..::..Object >[]()[][]
Ending values of the indexed columns.

Remarks

For example, if you have a table with 2 integer columns "c1" and "c2", the table has an index "ind" saying "+c1\0+c2\0\0", then calling

CopyC#
1rs.filterFindBetween( "ind", new object[ 1 ] { 50 }, new object[ 2 ] { 70, 100 } );
2return rs.all();
will return the same sequence of records as
CopyC#
1rs.filterClear();
2return rs.all()
3    .Where( r => r.c1 >= 50 )                                   // valsStart condition
4    .Where( r => r.c1 < 70 || ( r.c1 == 70 && r.c2 <= 100 ) )   // valsEnd condition
5    .OrderBy( r => r.c1 ).ThenBy( r => r.c2 );                  // Index order

If you pass null as valsStart (or valsEnd), the result will be all records in the index from the beginning to the valsEnd (or from valsStart to the end of the index). This means calling

CopyC#
1rs.filterFindBetween( "ind", new object[ 2 ] { 500, 900 }, null );
2return rs.all();
will return the same sequence of records as
CopyC#
1rs.filterClear();
2return rs.all()
3    .Where( r => ( r.c1 > 500 || ( r.c1 == 500 && r.c2 >= 900 ) ) )    // valsStart condition
4    .OrderBy( r => r.c1 ).ThenBy( r => r.c2 );                         // Index order

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterFindBetweenInv Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterFindBetweenInv Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Same as filterFindBetween(String, array<Object>[]()[][], array<Object>[]()[][]), but the order is flipped, i.e. records are returned from end to start.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterFindBetweenInv ( _
    indName As String, _
    valsStart As Object(), _
    valsEnd As Object() _
)
C#
public void filterFindBetweenInv(
    string indName,
    Object[] valsStart,
    Object[] valsEnd
)

Parameters

indName
Type: System..::..String
valsStart
Type: array< System..::..Object >[]()[][]
valsEnd
Type: array< System..::..Object >[]()[][]

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterFindEqual Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterFindEqual Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Include the records where the indexed columns values are exactly the same as the supplied arguments.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterFindEqual ( _
    indName As String, _
    ParamArray vals As Object() _
)
C#
public void filterFindEqual(
    string indName,
    params Object[] vals
)

Parameters

indName
Type: System..::..String
Name of the index, as supplied to the [EseIndex] attribute constructor.
vals
Type: array< System..::..Object >[]()[][]
Values of the indexed columns, in the same order they go in the index.

Remarks

For example, if you have a table with 2 integer columns "c1" and "c2", the table has an index "ind" saying "+c1\0+c2\0\0", then calling

CopyC#
1rs.filterFindEqual( "ind", 13, 254 );
2return rs.all();
will return the same sequence of records as
CopyC#
1rs.filterClear();
2return rs.all().Where( r => r.c1 == 13 && r.c2 == 254 );

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterFindEqualInv Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterFindEqualInv Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Include the records, where the indexed columns values are exactly the same as the supplied arguments. The output is reversed.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterFindEqualInv ( _
    indName As String, _
    ParamArray vals As Object() _
)
C#
public void filterFindEqualInv(
    string indName,
    params Object[] vals
)

Parameters

indName
Type: System..::..String
Name of the index, as supplied to the [EseIndex] attribute constructor.
vals
Type: array< System..::..Object >[]()[][]
Values of the indexed columns, in the same order they go in the index.

Remarks

NB: this filter doesn't support bookmarks-based navigation, so the tryGotoBookmark(ByteArray) will throw.

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterFindSubstring Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterFindSubstring Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Filter the recordset only including the records listed on the specified index, where the indexed columns values are the same as the supplied arguments. The last supplied argument however is threated like it contains the wildcard at the end.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterFindSubstring ( _
    indName As String, _
    ParamArray vals As Object() _
)
C#
public void filterFindSubstring(
    string indName,
    params Object[] vals
)

Parameters

indName
Type: System..::..String
Name of the index, as supplied to the [EseIndex] attribute constructor.
vals
Type: array< System..::..Object >[]()[][]
Values of the indexed columns, in the same order they go in the index.

Remarks

NB: this filter doesn't support bookmarks-based navigation, so the tryGotoBookmark(ByteArray) will throw.

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


filterSort Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..filterSort Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Set the sort order to the specified index, and optionally reverse the records.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub filterSort ( _
    indName As String, _
    bReverseOrder As Boolean _
)
C#
public void filterSort(
    string indName,
    bool bReverseOrder
)

Parameters

indName
Type: System..::..String
Name of the index, as supplied to the [EseIndex] attribute constructor.
bReverseOrder
Type: System..::..Boolean
set to true to make the recordset to return the results in the reversed order, i.e. from last record to the first record.

Remarks

For example, if you have a table with 2 integer columns "c1" and "c2", the table has an index "ind" saying "+c1\0+c2\0\0", then calling

CopyC#
1rs.filterSort( "ind", false );
2return rs.all();
will return the same sequence of records as
CopyC#
1rs.filterClear();
2return rs.all().OrderBy( r => r.c1 ).ThenBy( r => r.c2 );

This function does not immediately affect the cursor; instead, it changes the result of e.g. applyFilter()()()(), all()()()(), and getFirst()()()() methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


getFirst Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..getFirst Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Return the first value in the recordset, or default( tRow ) when there's no records matching the filter.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getFirst As tRow
C#
public tRow getFirst()

Return Value

Remarks

After this method returned non-null, the cursor will be positioned on the returned item.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


getFirstBookmark Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..getFirstBookmark Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the bookmark of the first record in the recordset, or ByteArray.Empty when there's no records matching the filter.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getFirstBookmark As ByteArray
C#
public ByteArray getFirstBookmark()

Return Value

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


isEmpty Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..isEmpty Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Apply the filter, and move the cursor to the first matching record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function isEmpty As Boolean
C#
public bool isEmpty()

Return Value

True if there's at least 1 matching record

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


tryGotoBookmark Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..tryGotoBookmark Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Apply the search filter, and goto the bookmark

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryGotoBookmark ( _
    bk As ByteArray _
) As Boolean
C#
public bool tryGotoBookmark(
    ByteArray bk
)

Parameters

bk
Type: (Default Namespace)..::..ByteArray

Return Value

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


tryMoveFirst Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..tryMoveFirst Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Move the cursor to the first record.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMoveFirst As Boolean
C#
public bool tryMoveFirst()

Return Value

False if the recordset is empty.

Remarks

NB: this method ignores the navigation limits set by "filter*" methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


tryMoveLast Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..tryMoveLast Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Move the cursor to the last recored.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMoveLast As Boolean
C#
public bool tryMoveLast()

Return Value

False if the recordset is empty.

Remarks

NB: this method ignores the navigation limits set by "filter*" methods.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


tryMoveNext Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..tryMoveNext Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMoveNext As Boolean
C#
public bool tryMoveNext()

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


tryMovePrevious Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..tryMovePrevious Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function tryMovePrevious As Boolean
C#
public bool tryMovePrevious()

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


uniq Method

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..uniq Method
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Same as all(), but unduplicates the output.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function uniq As IEnumerable(Of tRow)
C#
public IEnumerable<tRow> uniq()

Return Value

Rows enumerator

Remarks

You should use this method instead of all()()()() when you're using tuple indices, or when you're using an index over a multi-valued column: they both may contain a duplicate index entry for the same record.

This method is much faster then unduplicating using LINQ: skipped rows are not even fetched from the DB.
See also the note on laziness in the all()()()() method documentation.

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Recordset(tRow) Properties

[image] [image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)> Properties
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

The Recordset<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | canEstimateRecordsCount | Return true if the EstimateRecordsCount is supported.
Public property | cursor | The table cursor
Public property | idSession | ESENT session ID
Public property | idTable | ESENT table ID
Public property | session | EsentSerialization session

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


canEstimateRecordsCount Property

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..canEstimateRecordsCount Property
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

Return true if the EstimateRecordsCount is supported.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property canEstimateRecordsCount As Boolean
    Get
C#
public bool canEstimateRecordsCount { get; }

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


cursor Property

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..cursor Property
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

The table cursor

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property cursor As Cursor(Of tRow)
    Get
C#
public Cursor<tRow> cursor { get; }

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


idSession Property

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..idSession Property
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

ESENT session ID

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idSession As JET_SESID
    Get
C#
public JET_SESID idSession { get; }

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


idTable Property

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..idTable Property
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

ESENT table ID

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idTable As JET_TABLEID
    Get
C#
public JET_TABLEID idTable { get; }

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


session Property

[image]

EsentSerialization Class Library
Recordset<(Of <(<'tRow>)>)>..::..session Property
Recordset<(Of <(<'tRow>)>)> Class See Also Send Feedback

EsentSerialization session

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property session As iSerializerSession
    Get
C#
public iSerializerSession session { get; }

See Also

Recordset<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


SessionPool Class

[image]

EsentSerialization Class Library
SessionPool Class
See Also Send Feedback

This class maintains the pool of the ESENT sessions, to implement e.g. multithreaded software processing network requests.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class SessionPool _
    Implements IDisposable
C#
public class SessionPool : IDisposable

Remarks

This class encapsulates a SessionPool instance. In the same process, you may use either EseSerializer, SessionPool, or AspSessionPool, but not both.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..SessionPool

See Also

Microsoft.Isam.Esent.Serialization Namespace


SessionPool Constructor

[image]

EsentSerialization Class Library
SessionPool Constructor
SessionPool Class See Also Send Feedback

Construct the session pool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strFolder As String, _
    bEncryptDatabase As Boolean, _
    bSubstituteDriveLetter As Boolean, _
    maxSessions As Integer, _
    ParamArray arrTypes As Type() _
)
C#
public SessionPool(
    string strFolder,
    bool bEncryptDatabase,
    bool bSubstituteDriveLetter,
    int maxSessions,
    params Type[] arrTypes
)

Parameters

strFolder
Type: System..::..String
Database folder
bEncryptDatabase
Type: System..::..Boolean
Set to true to encrypt the database.
bSubstituteDriveLetter
Type: System..::..Boolean
Set to true to use Subst.Mount before opening the DB. This is useful when your environment has restrictive file system permissions.
maxSessions
Type: System..::..Int32
Maximum number of the ESENT sessions to open.
arrTypes
Type: array< System..::..Type >[]()[][]
The array of record types. In every session returned by the pool, the corresponding tables will be already opened for you.

Remarks

You should only create a single instance of this class.

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


SessionPool Fields

[image] [image]

EsentSerialization Class Library
SessionPool Fields
SessionPool Class See Also Send Feedback

The SessionPool type exposes the following members.

Fields

 | Name | Description
Public field | folderDatabase | The folder where the DB is located.
Public field | SessionLimit | Maximum number of the ESENT sessions to open.

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


folderDatabase Field

[image]

EsentSerialization Class Library
SessionPool..::..folderDatabase Field
SessionPool Class See Also Send Feedback

The folder where the DB is located.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly folderDatabase As String
C#
public readonly string folderDatabase

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


SessionLimit Field

[image]

EsentSerialization Class Library
SessionPool..::..SessionLimit Field
SessionPool Class See Also Send Feedback

Maximum number of the ESENT sessions to open.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly SessionLimit As Integer
C#
public readonly int SessionLimit

Remarks

0 = unlimited.
The default is 16.

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


SessionPool Methods

[image] [image]

EsentSerialization Class Library
SessionPool Methods
SessionPool Class See Also Send Feedback

The SessionPool type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSession | Get the ESENT session from the pool.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
SessionPool..::..Dispose Method
SessionPool Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


GetSession Method

[image]

EsentSerialization Class Library
SessionPool..::..GetSession Method
SessionPool Class See Also Send Feedback

Get the ESENT session from the pool.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GetSession As iSerializerSession
C#
public iSerializerSession GetSession()

Return Value

Return the session.

Remarks

This operation is inexpensive: usually the method returns the last session released to the pool.

NB: You must call Dispose exactly once for each iSerializerSession instance returned by this method. The recommended construction is:

CopyC#
1using( iSerializerSession sess = m_sessionPool.GetSession() )
2using( iSerializerTransaction trans = sess.beginTransaction() )
3{
4    // Do whatever you need with the data: obtain cursors/recordsets, search, modify records, etc..
5    trans.Commit();        // Or don't, if you need the transaction to roll back.
6}

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


SessionPool Properties

[image] [image]

EsentSerialization Class Library
SessionPool Properties
SessionPool Class See Also Send Feedback

The SessionPool type exposes the following members.

Properties

 | Name | Description
Public property | isNewDatabase | True if the new DB has been created by the constructor of this instance.

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


isNewDatabase Property

[image]

EsentSerialization Class Library
SessionPool..::..isNewDatabase Property
SessionPool Class See Also Send Feedback

True if the new DB has been created by the constructor of this instance.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property isNewDatabase As Boolean
    Get
C#
public bool isNewDatabase { get; }

See Also

SessionPool Class
Microsoft.Isam.Esent.Serialization Namespace


SessionPool.iPooledSession Interface

[image]

EsentSerialization Class Library
SessionPool..::..iPooledSession Interface
SessionPool Class See Also Send Feedback

This is the helper interface supported by iSerializerSession objects being returned from GetSession()()()() method.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Interface iPooledSession _
    Inherits IDisposable
C#
public interface iPooledSession : IDisposable

Remarks

This interface is internal, and is not designed to be callable by the user.

The SessionPool extends iSerializerSession supporting the reference counting.

When you get iSerializerSession from OpenDatabase(Boolean) method, a new session being opened. When you later call Dispose() on that object, the underlying ESE session is closed.

This behaviour is undesired for a server kind of software: ESE sessions are limited resource, and when the framework opens a new session for you it usually also open cursors on every table.

That's why SessionPool class implements reusable and reference-counted sessions.

See Also

Microsoft.Isam.Esent.Serialization Namespace


SessionPool.iPooledSession Methods

[image] [image]

EsentSerialization Class Library
SessionPool..::..iPooledSession Methods
SessionPool..::..iPooledSession Interface See Also Send Feedback

The SessionPool..::..iPooledSession type exposes the following members.

Methods

 | Name | Description
Public method | AddRef | Increments reference count.
Public method | Dispose | (Inherited from IDisposable.)
Public method | Release | Decrements reference count.
Public method | ResetReferenceCounter | Reset reference counter to the specific value.

See Also

SessionPool..::..iPooledSession Interface
Microsoft.Isam.Esent.Serialization Namespace


AddRef Method

[image]

EsentSerialization Class Library
SessionPool..::..iPooledSession..::..AddRef Method
SessionPool..::..iPooledSession Interface See Also Send Feedback

Increments reference count.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function AddRef As Integer
C#
int AddRef()

Return Value

Returns an integer from 1 to n, the value of the new reference count.

See Also

SessionPool..::..iPooledSession Interface
Microsoft.Isam.Esent.Serialization Namespace


Release Method

[image]

EsentSerialization Class Library
SessionPool..::..iPooledSession..::..Release Method
SessionPool..::..iPooledSession Interface See Also Send Feedback

Decrements reference count.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Function Release As Integer
C#
int Release()

Return Value

Returns the resulting value of the reference count.

See Also

SessionPool..::..iPooledSession Interface
Microsoft.Isam.Esent.Serialization Namespace


ResetReferenceCounter Method

[image]

EsentSerialization Class Library
SessionPool..::..iPooledSession..::..ResetReferenceCounter Method
SessionPool..::..iPooledSession Interface See Also Send Feedback

Reset reference counter to the specific value.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Sub ResetReferenceCounter ( _
    val As Integer _
)
C#
void ResetReferenceCounter(
    int val
)

Parameters

val
Type: System..::..Int32

Remarks

You should never call this method.

See Also

SessionPool..::..iPooledSession Interface
Microsoft.Isam.Esent.Serialization Namespace


Subst Class

[image]

EsentSerialization Class Library
Subst Class
See Also Send Feedback

This utility class maps drive letters just like command line 'subst.exe'.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class Subst
C#
public static class Subst

Remarks

When ESENT is asked to open/create a database located in "A:\BBB\CCC\DDD", the database engine first scans the folders "A:", "A:\BBB" and "A:\BBB\CCC", looking for reparse points.

If the user who's running the code has no permission to access any of those folders (which happenned on my shared Windows hosting), this behaviour will result in EsentFileAccessDeniedException.

This class provides a workaround for the issue.

To do that, it uses the DefineDosDevice Win32 API, to mount "A:\BBB\CCC" as a DOS device "Z:".
When ESENT is instructed to open/create a database located in Z:\DDD, it no longer tries to access A:\ and A:\BBB, and the database engine is initialized successfully.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..Subst

See Also

Microsoft.Isam.Esent.Serialization Namespace
Subst..::..Mount(String)


Subst Methods

[image] [image]

EsentSerialization Class Library
Subst Methods
Subst Class See Also Send Feedback

The Subst type exposes the following members.

Methods

Name | Description
Mount | Mount the folder using DefineDosDevice API (a.k.a. "subst").
UnMount | Remove the DOS device previously mounted with Mount(String) method.

Extension Methods

Name Description

See Also

Subst Class
Microsoft.Isam.Esent.Serialization Namespace


Mount Method

[image]

EsentSerialization Class Library
Subst..::..Mount Method
Subst Class See Also Send Feedback

Mount the folder using DefineDosDevice API (a.k.a. "subst").

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Function Mount ( _
    path As String _
) As String
C#
public static string Mount(
    string path
)

Parameters

path
Type: System..::..String
The path to mount.

Return Value

The path on the newly (or previously) mounted drive, which is the alias for the input path.

Remarks

If supplied "A:\BBB\CCC\DDD\", mounts "A:\BBB\CCC" as "Z:", and returns "Z:\DDD\" (where 'Z' if the last free drive letter).

Before doing that however, this method looks for the existing subst'ed drive which reference "A:\BBB\CCC". If found, it will not mount anything; instead, it will return the path on the previously mounted drive.

See Also

Subst Class
Microsoft.Isam.Esent.Serialization Namespace


UnMount Method

[image]

EsentSerialization Class Library
Subst..::..UnMount Method
Subst Class See Also Send Feedback

Remove the DOS device previously mounted with Mount(String) method.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Sub UnMount ( _
    strDriveLetter As String _
)
C#
public static void UnMount(
    string strDriveLetter
)

Parameters

strDriveLetter
Type: System..::..String
The string e.g. "Y:" with the mounted drive letter.

Remarks

NB: This method is not implemented, and will always throw an exception.

See Also

Subst Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer Class

[image]

EsentSerialization Class Library
TypeSerializer Class
See Also Send Feedback

This class performs table management task for a single serialized type.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class TypeSerializer _
    Implements iTypeSerializer
C#
public class TypeSerializer : iTypeSerializer

Remarks

Among other things, this class implements the reflection magic of the record types.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..TypeSerializer

See Also

Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer Constructor

[image]

EsentSerialization Class Library
TypeSerializer Constructor
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    t As Type, _
    tInfo As EseTableAttribute _
)
C#
public TypeSerializer(
    Type t,
    EseTableAttribute tInfo
)

Parameters

t
Type: System..::..Type
tInfo
Type: Microsoft.Isam.Esent.Serialization.Attributes..::..EseTableAttribute

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer Fields

[image] [image]

EsentSerialization Class Library
TypeSerializer Fields
TypeSerializer Class See Also Send Feedback

The TypeSerializer type exposes the following members.

Fields

 | Name | Description
Public field | recordType | Type of the records
Public field | tableAttribute | The instance of the EseTableAttribute applied to the record class.

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


recordType Field

[image]

EsentSerialization Class Library
TypeSerializer..::..recordType Field
TypeSerializer Class See Also Send Feedback

Type of the records

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly recordType As Type
C#
public readonly Type recordType

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


tableAttribute Field

[image]

EsentSerialization Class Library
TypeSerializer..::..tableAttribute Field
TypeSerializer Class See Also Send Feedback

The instance of the EseTableAttribute applied to the record class.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly tableAttribute As EseTableAttribute
C#
public readonly EseTableAttribute tableAttribute

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer Methods

[image] [image]

EsentSerialization Class Library
TypeSerializer Methods
TypeSerializer Class See Also Send Feedback

The TypeSerializer type exposes the following members.

Methods

 | Name | Description
Public method | CreateTableAndIndices | Create the table, it's columns and indices.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnsSchema | Get the columns schema of the table. Normally, it's only called while importing or exporting the data.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LookupColumnIDs |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | VerifyTableSchema | This method is called before a table is actually opened. This is a good place to upgrade database schema, reconstruct indices, or engage in some other table schema management activity. None of that is implemented in the current version of the codebase, though. The current version just throws an exception if column schema's wrong, and completely ignores the indices schema.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | iTypeSerializer..::..Deserialize |
Explicit interface implemetation | iTypeSerializer..::..DeserializeField |
Explicit interface implemetation | iTypeSerializer..::..FetchSingleField |
Explicit interface implemetation | iTypeSerializer..::..GetColumnId |
Explicit interface implemetation | iTypeSerializer..::..getIndexColumnAttribute |
Explicit interface implemetation | iTypeSerializer..::..getIndexColumnCount |
Explicit interface implemetation | iTypeSerializer..::..RawIndex |
Explicit interface implemetation | iTypeSerializer..::..RawRead |
Explicit interface implemetation | iTypeSerializer..::..RawWrite |
Explicit interface implemetation | iTypeSerializer..::..RecreateTable |
Explicit interface implemetation | iTypeSerializer..::..SaveSingleField |
Explicit interface implemetation | iTypeSerializer..::..Serialize |
Explicit interface implemetation | iTypeSerializer..::..SerializeField |

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


CreateTableAndIndices Method

[image]

EsentSerialization Class Library
TypeSerializer..::..CreateTableAndIndices Method
TypeSerializer Class See Also Send Feedback

Create the table, it's columns and indices.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub CreateTableAndIndices ( _
    idSession As JET_SESID, _
    idDatabase As JET_DBID _
)
C#
public void CreateTableAndIndices(
    JET_SESID idSession,
    JET_DBID idDatabase
)

Parameters

idSession
Type: JET_SESID
idDatabase
Type: JET_DBID

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


getColumnsSchema Method

[image]

EsentSerialization Class Library
TypeSerializer..::..getColumnsSchema Method
TypeSerializer Class See Also Send Feedback

Get the columns schema of the table. Normally, it's only called while importing or exporting the data.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function getColumnsSchema As IList(Of TypeSerializer..::..ColumnInfo)
C#
public IList<TypeSerializer..::..ColumnInfo> getColumnsSchema()

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.Deserialize Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..Deserialize Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub Deserialize ( _
    cur As EseCursorBase, _
    rec As Object _
) Implements iTypeSerializer.Deserialize
C#
void iTypeSerializer.Deserialize(
    EseCursorBase cur,
    Object rec
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
rec
Type: System..::..Object

Implements

iTypeSerializer..::..Deserialize(EseCursorBase, Object)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.DeserializeField Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..DeserializeField Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub DeserializeField ( _
    cur As EseCursorBase, _
    rec As Object, _
    fName As String _
) Implements iTypeSerializer.DeserializeField
C#
void iTypeSerializer.DeserializeField(
    EseCursorBase cur,
    Object rec,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
rec
Type: System..::..Object
fName
Type: System..::..String

Implements

iTypeSerializer..::..DeserializeField(EseCursorBase, Object, String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.FetchSingleField Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..FetchSingleField Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function FetchSingleField ( _
    cur As EseCursorBase, _
    fName As String _
) As Object Implements iTypeSerializer.FetchSingleField
C#
Object iTypeSerializer.FetchSingleField(
    EseCursorBase cur,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
fName
Type: System..::..String

Implements

iTypeSerializer..::..FetchSingleField(EseCursorBase, String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.GetColumnId Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..GetColumnId Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function GetColumnId ( _
    cur As EseCursorBase, _
    fName As String _
) As JET_COLUMNID Implements iTypeSerializer.GetColumnId
C#
JET_COLUMNID iTypeSerializer.GetColumnId(
    EseCursorBase cur,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
fName
Type: System..::..String

Implements

iTypeSerializer..::..GetColumnId(EseCursorBase, String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.getIndexColumnAttribute Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..getIndexColumnAttribute Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function getIndexColumnAttribute ( _
    strIndexName As String, _
    iCol As Integer _
) As EseColumnAttrubuteBase Implements iTypeSerializer.getIndexColumnAttribute
C#
EseColumnAttrubuteBase iTypeSerializer.getIndexColumnAttribute(
    string strIndexName,
    int iCol
)

Parameters

strIndexName
Type: System..::..String
iCol
Type: System..::..Int32

Implements

iTypeSerializer..::..getIndexColumnAttribute(String, Int32)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.getIndexColumnCount Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..getIndexColumnCount Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function getIndexColumnCount ( _
    strIndexName As String _
) As Integer Implements iTypeSerializer.getIndexColumnCount
C#
int iTypeSerializer.getIndexColumnCount(
    string strIndexName
)

Parameters

strIndexName
Type: System..::..String

Implements

iTypeSerializer..::..getIndexColumnCount(String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.RawIndex Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..RawIndex Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function RawIndex ( _
    fieldName As String _
) As Integer Implements iTypeSerializer.RawIndex
C#
int iTypeSerializer.RawIndex(
    string fieldName
)

Parameters

fieldName
Type: System..::..String

Implements

iTypeSerializer..::..RawIndex(String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.RawRead Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..RawRead Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Function RawRead ( _
    cur As EseCursorBase _
) As Byte()() Implements iTypeSerializer.RawRead
C#
byte[][] iTypeSerializer.RawRead(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase

Implements

iTypeSerializer..::..RawRead(EseCursorBase)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.RawWrite Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..RawWrite Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub RawWrite ( _
    cur As EseCursorBase, _
    data As Byte()() _
) Implements iTypeSerializer.RawWrite
C#
void iTypeSerializer.RawWrite(
    EseCursorBase cur,
    byte[][] data
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
data
Type: array<array< System..::..Byte >[]()[][]>[]()[][]

Implements

iTypeSerializer..::..RawWrite(EseCursorBase, array<array<Byte>[]()[][]>[]()[][])

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.RecreateTable Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..RecreateTable Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub RecreateTable ( _
    sess As iSerializerSession _
) Implements iTypeSerializer.RecreateTable
C#
void iTypeSerializer.RecreateTable(
    iSerializerSession sess
)

Parameters

sess
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession

Implements

iTypeSerializer..::..RecreateTable(iSerializerSession)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.SaveSingleField Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..SaveSingleField Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub SaveSingleField ( _
    cur As EseCursorBase, _
    fName As String, _
    value As Object _
) Implements iTypeSerializer.SaveSingleField
C#
void iTypeSerializer.SaveSingleField(
    EseCursorBase cur,
    string fName,
    Object value
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
fName
Type: System..::..String
value
Type: System..::..Object

Implements

iTypeSerializer..::..SaveSingleField(EseCursorBase, String, Object)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.Serialize Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..Serialize Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub Serialize ( _
    cur As EseCursorBase, _
    rec As Object, _
    bNewRecord As Boolean _
) Implements iTypeSerializer.Serialize
C#
void iTypeSerializer.Serialize(
    EseCursorBase cur,
    Object rec,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
rec
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

Implements

iTypeSerializer..::..Serialize(EseCursorBase, Object, Boolean)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.SerializeField Method

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..SerializeField Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private Sub SerializeField ( _
    cur As EseCursorBase, _
    rec As Object, _
    fName As String _
) Implements iTypeSerializer.SerializeField
C#
void iTypeSerializer.SerializeField(
    EseCursorBase cur,
    Object rec,
    string fName
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
rec
Type: System..::..Object
fName
Type: System..::..String

Implements

iTypeSerializer..::..SerializeField(EseCursorBase, Object, String)

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


LookupColumnIDs Method

[image]

EsentSerialization Class Library
TypeSerializer..::..LookupColumnIDs Method
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub LookupColumnIDs ( _
    idSession As JET_SESID, _
    idTable As JET_TABLEID _
)
C#
public void LookupColumnIDs(
    JET_SESID idSession,
    JET_TABLEID idTable
)

Parameters

idSession
Type: JET_SESID
idTable
Type: JET_TABLEID

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


VerifyTableSchema Method

[image]

EsentSerialization Class Library
TypeSerializer..::..VerifyTableSchema Method
TypeSerializer Class See Also Send Feedback

This method is called before a table is actually opened. This is a good place to upgrade database schema, reconstruct indices, or engage in some other table schema management activity. None of that is implemented in the current version of the codebase, though. The current version just throws an exception if column schema's wrong, and completely ignores the indices schema.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub VerifyTableSchema ( _
    idSession As JET_SESID, _
    idDatabase As JET_DBID _
)
C#
public void VerifyTableSchema(
    JET_SESID idSession,
    JET_DBID idDatabase
)

Parameters

idSession
Type: JET_SESID
idDatabase
Type: JET_DBID

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer Properties

[image] [image]

EsentSerialization Class Library
TypeSerializer Properties
TypeSerializer Class See Also Send Feedback

The TypeSerializer type exposes the following members.

Properties

 | Name | Description
Public property | tableName | Name of the table

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | iTypeSerializer..::..tableAttribute |

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


iTypeSerializer.tableAttribute Property

[image]

EsentSerialization Class Library
TypeSerializer..::..iTypeSerializer..::..tableAttribute Property
TypeSerializer Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Private ReadOnly Property tableAttribute As EseTableAttribute
    Implements iTypeSerializer.tableAttribute
    Get
C#
EseTableAttribute iTypeSerializer.tableAttribute { get; }

Implements

iTypeSerializer..::..tableAttribute

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


tableName Property

[image]

EsentSerialization Class Library
TypeSerializer..::..tableName Property
TypeSerializer Class See Also Send Feedback

Name of the table

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property tableName As String
    Get
C#
public string tableName { get; }

See Also

TypeSerializer Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer.ColumnInfo Class

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo Class
TypeSerializer Class See Also Send Feedback

This class represents the table column, and implements the get/set operations.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class ColumnInfo
C#
public class ColumnInfo

Remarks

Hopefully, the boxing/unboxing on every getValue/setValue operation is not that big deal in terms of performance.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..TypeSerializer..::..ColumnInfo

See Also

Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer.ColumnInfo Constructor

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo Constructor
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _name As String, _
    member As MemberInfo, _
    _attr As EseColumnAttrubuteBase _
)
C#
public ColumnInfo(
    string _name,
    MemberInfo member,
    EseColumnAttrubuteBase _attr
)

Parameters

_name
Type: System..::..String
The name of the column.
member
Type: System.Reflection..::..MemberInfo
Either FieldInfo or PropertyInfo of the member who has the _attr attribute applied.
_attr
Type: Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
The attribute.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer.ColumnInfo Methods

[image] [image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo Methods
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

The TypeSerializer..::..ColumnInfo type exposes the following members.

Methods

 | Name | Description
Public method | DeSerialize(EseCursorBase) | Just get the value from the DB, and return.
Public method | DeSerialize(EseCursorBase, Object) | Get the value from the DB, and put it to the object.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RefreshAutoincValue | Retrieve an auto-increment column value
Public method | Serialize | Get the value from object, store it in the DB.
Public method | SerializeSingleField | Update a single columt in the DB.
Public method | setColumnID | This operation is very rare, and is only used internally. That's why it's the separate method, instead of just 'set' accessor for the idColumn property.
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


DeSerialize Method

[image] [image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..DeSerialize Method
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeSerialize(EseCursorBase) | Just get the value from the DB, and return.
Public method | DeSerialize(EseCursorBase, Object) | Get the value from the DB, and put it to the object.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


DeSerialize Method (EseCursorBase)

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..DeSerialize Method (EseCursorBase)
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Just get the value from the DB, and return.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function DeSerialize ( _
    cur As EseCursorBase _
) As Object
C#
public Object DeSerialize(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.

Return Value

Column value for the current record of the cursor.

See Also

TypeSerializer..::..ColumnInfo Class
DeSerialize Overload
Microsoft.Isam.Esent.Serialization Namespace


DeSerialize Method (EseCursorBase, Object)

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..DeSerialize Method (EseCursorBase, Object)
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Get the value from the DB, and put it to the object.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub DeSerialize ( _
    cur As EseCursorBase, _
    rec As Object _
)
C#
public void DeSerialize(
    EseCursorBase cur,
    Object rec
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
rec
Type: System..::..Object
The record object.

See Also

TypeSerializer..::..ColumnInfo Class
DeSerialize Overload
Microsoft.Isam.Esent.Serialization Namespace


RefreshAutoincValue Method

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..RefreshAutoincValue Method
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Retrieve an auto-increment column value

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub RefreshAutoincValue ( _
    cur As EseCursorBase, _
    rec As Object _
)
C#
public void RefreshAutoincValue(
    EseCursorBase cur,
    Object rec
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
rec
Type: System..::..Object
The object.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace
http://managedesent.codeplex.com/wikipage?title=HowDoI


Serialize Method

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..Serialize Method
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Get the value from object, store it in the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Serialize ( _
    cur As EseCursorBase, _
    rec As Object, _
    bNewRecord As Boolean _
)
C#
public void Serialize(
    EseCursorBase cur,
    Object rec,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
rec
Type: System..::..Object
The object.
bNewRecord
Type: System..::..Boolean
True for INSERT operations, false for UPDATE operations.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


SerializeSingleField Method

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..SerializeSingleField Method
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Update a single columt in the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub SerializeSingleField ( _
    cur As EseCursorBase, _
    value As Object _
)
C#
public void SerializeSingleField(
    EseCursorBase cur,
    Object value
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The table cursor.
value
Type: System..::..Object
The new value for the column.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


setColumnID Method

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..setColumnID Method
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

This operation is very rare, and is only used internally. That's why it's the separate method, instead of just 'set' accessor for the idColumn property.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub setColumnID ( _
    _idColumn As JET_COLUMNID _
)
C#
public void setColumnID(
    JET_COLUMNID _idColumn
)

Parameters

_idColumn
Type: JET_COLUMNID

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


TypeSerializer.ColumnInfo Properties

[image] [image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo Properties
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

The TypeSerializer..::..ColumnInfo type exposes the following members.

Properties

 | Name | Description
Public property | attrib | The instance of the EseColumnAttrubuteBase-derived attribute applied to the property or method of the record class.
Public property | columnName | The name of the ESENT column.
Public property | idColumn | Column ID.

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


attrib Property

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..attrib Property
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

The instance of the EseColumnAttrubuteBase-derived attribute applied to the property or method of the record class.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property attrib As EseColumnAttrubuteBase
    Get
C#
public EseColumnAttrubuteBase attrib { get; }

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


columnName Property

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..columnName Property
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

The name of the ESENT column.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property columnName As String
    Get
C#
public string columnName { get; }

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


idColumn Property

[image]

EsentSerialization Class Library
TypeSerializer..::..ColumnInfo..::..idColumn Property
TypeSerializer..::..ColumnInfo Class See Also Send Feedback

Column ID.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property idColumn As JET_COLUMNID
    Get
C#
public JET_COLUMNID idColumn { get; }

See Also

TypeSerializer..::..ColumnInfo Class
Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Class

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Class
See Also Send Feedback

This class implements virtual-mode data grid view.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class VirtualMode(Of tRow As New) _
    Implements IDisposable
C#
public class VirtualMode<tRow> : IDisposable
where tRow : new()

Type Parameters

tRow

Remarks

Achtung: the code in this class is practically untested. Use it on your own risk, be ready for debugging.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization..::..VirtualMode<(Of <(<'tRow>)>)>

See Also

Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Constructor

[image] [image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Constructor
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VirtualMode<(Of <(<'tRow>)>)>(iSerializerSession) | Include the whole table.
Public method | VirtualMode<(Of <(<'tRow>)>)>(Recordset<(Of <<'(tRow>)>>)) | Include only the subset of records and/or reverse ordered.

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Constructor (iSerializerSession)

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Constructor (iSerializerSession)
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Include the whole table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _sess As iSerializerSession _
)
C#
public VirtualMode(
    iSerializerSession _sess
)

Parameters

_sess
Type: Microsoft.Isam.Esent.Serialization..::..iSerializerSession

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
VirtualMode<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Constructor (Recordset(tRow))

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Constructor (Recordset<(Of <(<'tRow>)>)>)
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Include only the subset of records and/or reverse ordered.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    rs As Recordset(Of tRow) _
)
C#
public VirtualMode(
    Recordset<tRow> rs
)

Parameters

rs
Type: Microsoft.Isam.Esent.Serialization..::..Recordset <(Of <(<' tRow >)>)>

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
VirtualMode<(Of <(<'tRow>)>)> Overload
Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Methods

[image] [image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Methods
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

The VirtualMode<(Of <(<'tRow>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add the new item to the table.
Public method | BindToDataGrid | Bind to the DataGridView.
Public method | Dispose | Free the resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAt | Get the object from the specified index.
Public method | GetCount | Get the records count.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GotoBookmarkAt | Navigate the cursor to the specified indexed position.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh | Refresh the control from the DB.
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Add Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..Add Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Add the new item to the table.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Add ( _
    newItem As tRow _
)
C#
public void Add(
    tRow newItem
)

Parameters

newItem
Type: tRow

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


BindToDataGrid Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..BindToDataGrid Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Bind to the DataGridView.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub BindToDataGrid ( _
    dgView As DataGridView _
)
C#
public void BindToDataGrid(
    DataGridView dgView
)

Parameters

dgView
Type: System.Windows.Forms..::..DataGridView

Remarks

If the data grid's AutoGenerateColumns property is set to true, this will also auto-generate columns, and wire the CellValueNeeded event to the internal event handler.

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Dispose Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..Dispose Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Free the resources.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Dispose
C#
public void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


GetAt Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..GetAt Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the object from the specified index.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GetAt ( _
    nRecord As Integer _
) As tRow
C#
public tRow GetAt(
    int nRecord
)

Parameters

nRecord
Type: System..::..Int32
The continuous zero-based index to navigate.

Return Value

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


GetCount Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..GetCount Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Get the records count.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GetCount As Integer
C#
public int GetCount()

Return Value

The value may be approximate.

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


GotoBookmarkAt Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..GotoBookmarkAt Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Navigate the cursor to the specified indexed position.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function GotoBookmarkAt ( _
    nRecord As Integer _
) As ByteArray
C#
public ByteArray GotoBookmarkAt(
    int nRecord
)

Parameters

nRecord
Type: System..::..Int32
The continuous zero-based index to navigate.

Return Value

On success, returns the bookmark of the destination record. On failure, returns ByteArray.Empty

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Refresh Method

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..Refresh Method
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

Refresh the control from the DB.

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub Refresh
C#
public void Refresh()

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


VirtualMode(tRow) Properties

[image] [image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)> Properties
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

The VirtualMode<(Of <(<'tRow>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | cursor | DB cursor
Public property | recordset | DB recordset
Public property | session | DB session

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


cursor Property

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..cursor Property
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

DB cursor

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property cursor As Cursor(Of tRow)
    Get
C#
public Cursor<tRow> cursor { get; }

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


recordset Property

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..recordset Property
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

DB recordset

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property recordset As Recordset(Of tRow)
    Get
C#
public Recordset<tRow> recordset { get; }

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


session Property

[image]

EsentSerialization Class Library
VirtualMode<(Of <(<'tRow>)>)>..::..session Property
VirtualMode<(Of <(<'tRow>)>)> Class See Also Send Feedback

DB session

Namespace: Microsoft.Isam.Esent.Serialization
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property session As iSerializerSession
    Get
C#
public iSerializerSession session { get; }

See Also

VirtualMode<(Of <(<'tRow>)>)> Class
Microsoft.Isam.Esent.Serialization Namespace


Microsoft.Isam.Esent.Serialization.Attributes Namespace

[image]

EsentSerialization Class Library
Microsoft.Isam.Esent.Serialization.Attributes Namespace
Send Feedback

This namespace contains attribute to define your database schema.

You declare the table by applying [EseTable] to your record class.

You declare the columns by applying column attributes to the fields and/or properties of your record class. All the column attributes are located in the Attributes namespace, and are derived from EseColumnAttrubuteBase class.

You declare the indices by applying [EseIndex] (and/or derived attributes) to your record class.

Classes

 | Class | Description
Public class | EseAutoIdAttribute | Automatically-incremented integer column.
Public class | EseBinaryStreamAttribute | Column containing arbitrary binary data.
Public class | EseBoolAttribute | The column holding Boolean.
Public class | EseByteArrayAttribute | Column containing arbitrary binary data.
Public class | EseByteAttribute | The column holding Byte.
Public class | EseDateTimeAttribute | Date-time column type.
Public class | EseDateTimeOffsetAttribute | The column to hold DateTimeOffset structure.
Public class | EseDCSAttribute | Column containing the object serialized into binary XML using data contract serializer.
Public class | EseDecimalAttribute | This fixed length 16-bytes binary column stores an instance of Decimal structure.
Public class | EseDoubleAttribute | The column holding Double.
Public class | EseEnumAttribute | Enum-typed column.
Public class | EseFloatAttribute | The column holding Single.
Public class | EseGuidAttribute | The column holding Guid.
Public class | EseIndexAttribute | This attribute defines an index over a table.
Public class | EseInt64ArrayAttribute | The column holding array of Int64.
Public class | EseInt64Attribute | The column holding Int64.
Public class | EseIntAttribute | The column holding Int32.
Public class | EseLongTextAttribute | Column containing long text, either ASCII of Unicode.
Public class | EseMultiTextAttribute | Column containing several string values, either ASCII of Unicode.
Public class | EseOacDecimalAttribute | This column type holds a Decimal value stored in the "OLE Automation Currency" format.
Public class | EsePrimaryIndexAttribute | This attribute defines the primary (clustered) index.
Public class | EseShortBinaryAttribute | A fixed or variable length, raw binary column can be up to 255 bytes in length.
Public class | EseShortIntAttribute | The column holding Int16.
Public class | EseSimpleIndexAttribute | This attribute defines a simple index attribute, that indexes only a single column in ascending order.
Public class | EseStreamValue | This class represents the value serialized by [EseBinaryStream].
Public class | EseTableAttribute | This attribute marks the object as the ESE record.
Public class | EseTextAttribute | Column containing short text, either ASCII of Unicode.
Public class | EseTimeZoneAttribute | The column to hold TimeZoneInfo class.
Public class | EseTupleIndexAttribute | This attribute defines a tuple index.
Public class | EseUInt64Attribute | The column holding UInt64.
Public class | EseUShortIntAttribute | The column holding UInt16.
Public class | EseVersionAttribute | Automatically-incremented row version column.
Public class | EseXmlSerializedAttribute | Column containing the object serialized into XML encoded in UTF8.

Remarks

In the following code snippet, you can see the example of defining a "persons" table, with 4 columns of different types, and 2 secondary indices.

CopyC#
 1using Microsoft.Isam.Esent.Serialization.Attributes;
 2
 3[EseTable( "persons" )]
 4[EsePrimaryIndex( "id", "+id\0\0" )]
 5[EseIndex( "sex", "+sex\0\0" )]
 6[EseTupleIndex( "name" )]
 7public class Person
 8{
 9    // Sometimes it's nice to have an integer person ID, instead of just bookmarks.
10    // Bookmarks are byte arrays, takes a memory allocations to deal with.
11    // Fortunately, ESENT provides auto-incremented columns, which do great being a primary index, BTW.
12    [EseAutoId( "id" )]
13    private int m_id;
14
15    public int id { get { return m_id; } }
16
17    // Enum column
18    public enum eSex { Male, Female, Other };
19    [EseEnum]
20    public eSex sex { get; set; }
21
22    // Short unicode text column.
23    [EseText( maxChars = 71 )]
24    // See http://stackoverflow.com/questions/30485//30509#30509 for why "71"
25    public string name { get; set; }
26
27    // Multi-values ASCII text column, every value no longer then 32 characters.
28    [EseMultiText( bUnicode = false, maxChars = 32 )]
29    public List<string> phones { get; private set; }
30
31    // The framework requires your record class to have public parameterless constructor.
32    public Person() { }
33}


EseAutoIdAttribute Class

[image]

EsentSerialization Class Library
EseAutoIdAttribute Class
See Also Send Feedback

Automatically-incremented integer column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseAutoIdAttribute _
    Inherits EseColumnAttrubuteBase
C#
public sealed class EseAutoIdAttribute : EseColumnAttrubuteBase

Remarks

Must be applied to a field/property of type 'int' or 'long'.

The underlying ESENT column type is JET_coltypLong or JET_coltypCurrency, with JET_bitColumnFixed and JET_bitColumnAutoincrement flags.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseAutoIdAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseAutoIdAttribute Constructor
EseAutoIdAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseAutoIdAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseAutoIdAttribute(String) | Initialize with non-default column name.

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Constructor

[image]

EsentSerialization Class Library
EseAutoIdAttribute Constructor
EseAutoIdAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseAutoIdAttribute()

See Also

EseAutoIdAttribute Class
EseAutoIdAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseAutoIdAttribute Constructor (String)
EseAutoIdAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseAutoIdAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseAutoIdAttribute Class
EseAutoIdAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Fields

[image] [image]

EsentSerialization Class Library
EseAutoIdAttribute Fields
EseAutoIdAttribute Class See Also Send Feedback

The EseAutoIdAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Methods

[image] [image]

EsentSerialization Class Library
EseAutoIdAttribute Methods
EseAutoIdAttribute Class See Also Send Feedback

The EseAutoIdAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RetrieveCopy | Retrieve copy of the auto-incremented value.
Public method | Serialize | Do nothing, as the value is set by the ESENT. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..Deserialize Method
EseAutoIdAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..getColumnDef Method
EseAutoIdAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..MakeKey Method
EseAutoIdAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


RetrieveCopy Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..RetrieveCopy Method
EseAutoIdAttribute Class See Also Send Feedback

Retrieve copy of the auto-incremented value.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function RetrieveCopy ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public Object RetrieveCopy(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

Remarks

See the "How do I?" page in managed ESENT wiki, section "How Do I Retrieve an Auto-Increment Column Value?"

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..Serialize Method
EseAutoIdAttribute Class See Also Send Feedback

Do nothing, as the value is set by the ESENT.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..verifyTypeSupport Method
EseAutoIdAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseAutoIdAttribute Properties

[image] [image]

EsentSerialization Class Library
EseAutoIdAttribute Properties
EseAutoIdAttribute Class See Also Send Feedback

The EseAutoIdAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Always false. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseAutoIdAttribute..::..bFieldNullable Property
EseAutoIdAttribute Class See Also Send Feedback

Always false.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseAutoIdAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Class

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute Class
See Also Send Feedback

Column containing arbitrary binary data.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseBinaryStreamAttribute _
    Inherits EseByteArrayAttribute
C#
public class EseBinaryStreamAttribute : EseByteArrayAttribute

Remarks

Must be applied to a field/property of type 'EseStreamValue'.

The underlying ESENT column type is JET_coltypLongBinary.

Unlike the rest of the column types, this one does not save or load anything.
Instead, it only supplies the EseStreamValue value, that can be used later to save or load the data.
To access the data, you should use Read(EseCursorBase) / Write(EseCursorBase) methods.

You must open a transaction before calling Read(EseCursorBase) / Write(EseCursorBase) methods, and you must keep the transaction open for the lifetime of the ColumnStream object returned by those methods.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortBinaryAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseByteArrayAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseBinaryStreamAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace
Microsoft.Isam.Esent.Serialization.Attributes..::..EseStreamValue


EseBinaryStreamAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseBinaryStreamAttribute Constructor
EseBinaryStreamAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseBinaryStreamAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseBinaryStreamAttribute(String) | Initialize with non-default column name.

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Constructor

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute Constructor
EseBinaryStreamAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseBinaryStreamAttribute()

See Also

EseBinaryStreamAttribute Class
EseBinaryStreamAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute Constructor (String)
EseBinaryStreamAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseBinaryStreamAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseBinaryStreamAttribute Class
EseBinaryStreamAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Fields

[image] [image]

EsentSerialization Class Library
EseBinaryStreamAttribute Fields
EseBinaryStreamAttribute Class See Also Send Feedback

The EseBinaryStreamAttribute type exposes the following members.

Fields

 | Name | Description
Public field | bFixedLength | If set to true, it will always use the same amount of space in a row, regardless of how much data is being stored in the column. (Inherited from EseShortBinaryAttribute.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Public field | maxBytes | The maximum length, in bytes, of a column. (Inherited from EseShortBinaryAttribute.)

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Methods

[image] [image]

EsentSerialization Class Library
EseBinaryStreamAttribute Methods
EseBinaryStreamAttribute Class See Also Send Feedback

The EseBinaryStreamAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Just store the IDs and the row bookmark. (Overrides EseShortBinaryAttribute..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Inherited from EseByteArrayAttribute.)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseShortBinaryAttribute.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | This method does nothing. (Overrides EseShortBinaryAttribute..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute was not applied to the class member of type EseStreamValue. (Overrides EseShortBinaryAttribute..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute..::..Deserialize Method
EseBinaryStreamAttribute Class See Also Send Feedback

Just store the IDs and the row bookmark.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

Return Value

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute..::..Serialize Method
EseBinaryStreamAttribute Class See Also Send Feedback

This method does nothing.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

Remarks

To save the column value, call Write(EseCursorBase) while in a transaction.

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute..::..verifyTypeSupport Method
EseBinaryStreamAttribute Class See Also Send Feedback

Throw an exception if this attribute was not applied to the class member of type EseStreamValue.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBinaryStreamAttribute Properties

[image] [image]

EsentSerialization Class Library
EseBinaryStreamAttribute Properties
EseBinaryStreamAttribute Class See Also Send Feedback

The EseBinaryStreamAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Inherited from EseShortBinaryAttribute.)
Public property | maxGB | The maximum length, in GigaBytes, of a column.
Public property | maxKB | The maximum length, in KiloBytes, of a column. (Inherited from EseByteArrayAttribute.)
Public property | maxMB | The maximum length, in MegaBytes, of a column. (Inherited from EseByteArrayAttribute.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


maxGB Property

[image]

EsentSerialization Class Library
EseBinaryStreamAttribute..::..maxGB Property
EseBinaryStreamAttribute Class See Also Send Feedback

The maximum length, in GigaBytes, of a column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property maxGB As Double
    Get
    Set
C#
public double maxGB { get; set; }

See Also

EseBinaryStreamAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Class

[image]

EsentSerialization Class Library
EseBoolAttribute Class
See Also Send Feedback

The column holding Boolean.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseBoolAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseBoolAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'bool' or 'bool?'.

The underlying ESENT column type is JET_coltypBit with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseBoolAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseBoolAttribute Constructor
EseBoolAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseBoolAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseBoolAttribute(String) | Initialize with non-default column name.

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Constructor

[image]

EsentSerialization Class Library
EseBoolAttribute Constructor
EseBoolAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseBoolAttribute()

See Also

EseBoolAttribute Class
EseBoolAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseBoolAttribute Constructor (String)
EseBoolAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseBoolAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseBoolAttribute Class
EseBoolAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Fields

[image] [image]

EsentSerialization Class Library
EseBoolAttribute Fields
EseBoolAttribute Class See Also Send Feedback

The EseBoolAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Methods

[image] [image]

EsentSerialization Class Library
EseBoolAttribute Methods
EseBoolAttribute Class See Also Send Feedback

The EseBoolAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseBoolAttribute..::..Deserialize Method
EseBoolAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseBoolAttribute..::..getColumnDef Method
EseBoolAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseBoolAttribute..::..MakeKey Method
EseBoolAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseBoolAttribute..::..Serialize Method
EseBoolAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseBoolAttribute..::..verifyTypeSupport Method
EseBoolAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseBoolAttribute Properties

[image] [image]

EsentSerialization Class Library
EseBoolAttribute Properties
EseBoolAttribute Class See Also Send Feedback

The EseBoolAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseBoolAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Class

[image]

EsentSerialization Class Library
EseByteArrayAttribute Class
See Also Send Feedback

Column containing arbitrary binary data.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseByteArrayAttribute _
    Inherits EseShortBinaryAttribute
C#
public class EseByteArrayAttribute : EseShortBinaryAttribute

Remarks

Must be applied to a field/property of type 'ByteArray'.

The underlying ESENT column type is JET_coltypLongBinary.

Don't use it with items over few kilobytes: the whole value lives in RAM when deserialized. If you ever need handling megabytes-sized binary fields, use EseBinaryStreamAttribute instead.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortBinaryAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseByteArrayAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseBinaryStreamAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseByteArrayAttribute Constructor
EseByteArrayAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseByteArrayAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseByteArrayAttribute(String) | Initialize with non-default column name.

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Constructor

[image]

EsentSerialization Class Library
EseByteArrayAttribute Constructor
EseByteArrayAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseByteArrayAttribute()

See Also

EseByteArrayAttribute Class
EseByteArrayAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseByteArrayAttribute Constructor (String)
EseByteArrayAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseByteArrayAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseByteArrayAttribute Class
EseByteArrayAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Fields

[image] [image]

EsentSerialization Class Library
EseByteArrayAttribute Fields
EseByteArrayAttribute Class See Also Send Feedback

The EseByteArrayAttribute type exposes the following members.

Fields

 | Name | Description
Public field | bFixedLength | If set to true, it will always use the same amount of space in a row, regardless of how much data is being stored in the column. (Inherited from EseShortBinaryAttribute.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Public field | maxBytes | The maximum length, in bytes, of a column. (Inherited from EseShortBinaryAttribute.)

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Methods

[image] [image]

EsentSerialization Class Library
EseByteArrayAttribute Methods
EseByteArrayAttribute Class See Also Send Feedback

The EseByteArrayAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Inherited from EseShortBinaryAttribute.)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseShortBinaryAttribute..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseShortBinaryAttribute.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Inherited from EseShortBinaryAttribute.)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Inherited from EseShortBinaryAttribute.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseByteArrayAttribute..::..getColumnDef Method
EseByteArrayAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteArrayAttribute Properties

[image] [image]

EsentSerialization Class Library
EseByteArrayAttribute Properties
EseByteArrayAttribute Class See Also Send Feedback

The EseByteArrayAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Inherited from EseShortBinaryAttribute.)
Public property | maxKB | The maximum length, in KiloBytes, of a column.
Public property | maxMB | The maximum length, in MegaBytes, of a column.
Public property | TypeId | (Inherited from Attribute.)

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


maxKB Property

[image]

EsentSerialization Class Library
EseByteArrayAttribute..::..maxKB Property
EseByteArrayAttribute Class See Also Send Feedback

The maximum length, in KiloBytes, of a column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property maxKB As Double
    Get
    Set
C#
public double maxKB { get; set; }

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


maxMB Property

[image]

EsentSerialization Class Library
EseByteArrayAttribute..::..maxMB Property
EseByteArrayAttribute Class See Also Send Feedback

The maximum length, in MegaBytes, of a column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property maxMB As Double
    Get
    Set
C#
public double maxMB { get; set; }

See Also

EseByteArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Class

[image]

EsentSerialization Class Library
EseByteAttribute Class
See Also Send Feedback

The column holding Byte.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseByteAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseByteAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'byte' or 'byte?'.

The underlying ESENT column type is JET_coltypUnsignedByte with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseByteAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseByteAttribute Constructor
EseByteAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseByteAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseByteAttribute(String) | Initialize with non-default column name.

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Constructor

[image]

EsentSerialization Class Library
EseByteAttribute Constructor
EseByteAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseByteAttribute()

See Also

EseByteAttribute Class
EseByteAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseByteAttribute Constructor (String)
EseByteAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseByteAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseByteAttribute Class
EseByteAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Fields

[image] [image]

EsentSerialization Class Library
EseByteAttribute Fields
EseByteAttribute Class See Also Send Feedback

The EseByteAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Methods

[image] [image]

EsentSerialization Class Library
EseByteAttribute Methods
EseByteAttribute Class See Also Send Feedback

The EseByteAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseByteAttribute..::..Deserialize Method
EseByteAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseByteAttribute..::..getColumnDef Method
EseByteAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseByteAttribute..::..MakeKey Method
EseByteAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseByteAttribute..::..Serialize Method
EseByteAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseByteAttribute..::..verifyTypeSupport Method
EseByteAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseByteAttribute Properties

[image] [image]

EsentSerialization Class Library
EseByteAttribute Properties
EseByteAttribute Class See Also Send Feedback

The EseByteAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseByteAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Class

[image]

EsentSerialization Class Library
EseDateTimeAttribute Class
See Also Send Feedback

Date-time column type.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseDateTimeAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseDateTimeAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'DateTime' or 'DateTime?'.

Only UTC values are allowed.

The underlying ESENT column type is JET_coltypDateTime with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDateTimeAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseDateTimeAttribute Constructor
EseDateTimeAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseDateTimeAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseDateTimeAttribute(String) | Initialize with non-default column name.

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Constructor

[image]

EsentSerialization Class Library
EseDateTimeAttribute Constructor
EseDateTimeAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseDateTimeAttribute()

See Also

EseDateTimeAttribute Class
EseDateTimeAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseDateTimeAttribute Constructor (String)
EseDateTimeAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseDateTimeAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseDateTimeAttribute Class
EseDateTimeAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Fields

[image] [image]

EsentSerialization Class Library
EseDateTimeAttribute Fields
EseDateTimeAttribute Class See Also Send Feedback

The EseDateTimeAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Methods

[image] [image]

EsentSerialization Class Library
EseDateTimeAttribute Methods
EseDateTimeAttribute Class See Also Send Feedback

The EseDateTimeAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseDateTimeAttribute..::..Deserialize Method
EseDateTimeAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseDateTimeAttribute..::..getColumnDef Method
EseDateTimeAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseDateTimeAttribute..::..MakeKey Method
EseDateTimeAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseDateTimeAttribute..::..Serialize Method
EseDateTimeAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseDateTimeAttribute..::..verifyTypeSupport Method
EseDateTimeAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeAttribute Properties

[image] [image]

EsentSerialization Class Library
EseDateTimeAttribute Properties
EseDateTimeAttribute Class See Also Send Feedback

The EseDateTimeAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseDateTimeAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Class

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Class
See Also Send Feedback

The column to hold DateTimeOffset structure.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseDateTimeOffsetAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseDateTimeOffsetAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'DateTimeOffset' or 'DateTimeOffset?'.

The underlying ESENT column type is JET_coltypBinary, fixed, 16 bytes long.

DateTimeOffset values are stored as 16 bytes fixed binary value. First 8 bytes are ToBinary()()()() value of the DateTime field, the last 8 bytes are Ticks of the Offset field.
Indexing over such columns is not supported.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDateTimeOffsetAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Constructor
EseDateTimeOffsetAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseDateTimeOffsetAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseDateTimeOffsetAttribute(String) | Initialize with non-default column name.

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Constructor

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Constructor
EseDateTimeOffsetAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseDateTimeOffsetAttribute()

See Also

EseDateTimeOffsetAttribute Class
EseDateTimeOffsetAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Constructor (String)
EseDateTimeOffsetAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseDateTimeOffsetAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseDateTimeOffsetAttribute Class
EseDateTimeOffsetAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Fields

[image] [image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Fields
EseDateTimeOffsetAttribute Class See Also Send Feedback

The EseDateTimeOffsetAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Methods

[image] [image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Methods
EseDateTimeOffsetAttribute Class See Also Send Feedback

The EseDateTimeOffsetAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the DateTimeOffset value in the database, as a pair of 64-bit values. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute..::..Deserialize Method
EseDateTimeOffsetAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute..::..getColumnDef Method
EseDateTimeOffsetAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute..::..Serialize Method
EseDateTimeOffsetAttribute Class See Also Send Feedback

Store the DateTimeOffset value in the database, as a pair of 64-bit values.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute..::..verifyTypeSupport Method
EseDateTimeOffsetAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDateTimeOffsetAttribute Properties

[image] [image]

EsentSerialization Class Library
EseDateTimeOffsetAttribute Properties
EseDateTimeOffsetAttribute Class See Also Send Feedback

The EseDateTimeOffsetAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseDateTimeOffsetAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Class

[image]

EsentSerialization Class Library
EseDCSAttribute Class
See Also Send Feedback

Column containing the object serialized into binary XML using data contract serializer.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseDCSAttribute _
    Inherits EseColumnAttrubuteBase
C#
public sealed class EseDCSAttribute : EseColumnAttrubuteBase

Remarks

May be applied to a field/property of any type marked with DataContractAttribute.

The underlying ESENT column type is JET_coltypLongBinary.

The attribute instance holds the System.Runtime.Serialization.DataContractSerializer object that performs the [de]serialization.

The documentation on DataContractSerializer says:
"Instances of this class are thread safe except when the instance is used with an implementation of the IDataContractSurrogateor DataContractResolver".
That's why no locks is ever needed, even when different threads are [de]serializing the same column of different records, which is perfectly legal way of using the library.

The data contract serializer is more efficient then XML serializer that is used by the [EseXmlSerialized] column.

This column uses the .NET Binary XML Format, a Microsoft-specific binary representation for XML Information Sets that generally yields a smaller footprint than the equivalent XML 1.0 representation.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDCSAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseDCSAttribute Constructor
EseDCSAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseDCSAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseDCSAttribute(String) | Initialize with non-default column name.

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Constructor

[image]

EsentSerialization Class Library
EseDCSAttribute Constructor
EseDCSAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseDCSAttribute()

See Also

EseDCSAttribute Class
EseDCSAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseDCSAttribute Constructor (String)
EseDCSAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseDCSAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseDCSAttribute Class
EseDCSAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Fields

[image] [image]

EsentSerialization Class Library
EseDCSAttribute Fields
EseDCSAttribute Class See Also Send Feedback

The EseDCSAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Public field | DictionaryType | A user-supplied dictionary with right values can reduce the size of the serialized document drastically.

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


DictionaryType Field

[image]

EsentSerialization Class Library
EseDCSAttribute..::..DictionaryType Field
EseDCSAttribute Class See Also Send Feedback

A user-supplied dictionary with right values can reduce the size of the serialized document drastically.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public DictionaryType As Type
C#
public Type DictionaryType

Remarks

The type must have public parameterless constructor, and it must implement System.Xml.IXmlDictionary interface.

The implementation must be thread-safe: it'll be used concurrently by every thread who serialize/deserialize this column.

If you inherit from System.Xml.XmlDictionary, be sure to override and fix TryLookup( XmlDictionaryString, XmlDictionaryString ) method: .NET framework implementation doesn't try to lookup the string by value, instead it just fails silently.

The dictionary must be stable, so I think it's a bad idea to build it dynamically by reflecting the serialized type. During the lifetime of your software, you may only add new entries to that dictionary, you may not remove or change the entries. Failing to do that will lead to an incompatible database format.

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Methods

[image] [image]

EsentSerialization Class Library
EseDCSAttribute Methods
EseDCSAttribute Class See Also Send Feedback

The EseDCSAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Construct the data contract serializer for the specified type. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseDCSAttribute..::..Deserialize Method
EseDCSAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseDCSAttribute..::..getColumnDef Method
EseDCSAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseDCSAttribute..::..Serialize Method
EseDCSAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseDCSAttribute..::..verifyTypeSupport Method
EseDCSAttribute Class See Also Send Feedback

Construct the data contract serializer for the specified type.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDCSAttribute Properties

[image] [image]

EsentSerialization Class Library
EseDCSAttribute Properties
EseDCSAttribute Class See Also Send Feedback

The EseDCSAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseDCSAttribute..::..bFieldNullable Property
EseDCSAttribute Class See Also Send Feedback

Is always true.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseDCSAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Class

[image]

EsentSerialization Class Library
EseDecimalAttribute Class
See Also Send Feedback

This fixed length 16-bytes binary column stores an instance of Decimal structure.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseDecimalAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseDecimalAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'decimal' or 'decimal?'.

The underlying ESENT column type is JET_coltypBinary, fixed, 16 bytes long.

Indexing over such columns is useless hence unsupported. If you need indexing, use [EseOacDecimal] instead.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDecimalAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace
Microsoft.Isam.Esent.Serialization.Attributes..::..EseOacDecimalAttribute


EseDecimalAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseDecimalAttribute Constructor
EseDecimalAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseDecimalAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseDecimalAttribute(String) | Initialize with non-default column name.

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Constructor

[image]

EsentSerialization Class Library
EseDecimalAttribute Constructor
EseDecimalAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseDecimalAttribute()

See Also

EseDecimalAttribute Class
EseDecimalAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseDecimalAttribute Constructor (String)
EseDecimalAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseDecimalAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseDecimalAttribute Class
EseDecimalAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Fields

[image] [image]

EsentSerialization Class Library
EseDecimalAttribute Fields
EseDecimalAttribute Class See Also Send Feedback

The EseDecimalAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Methods

[image] [image]

EsentSerialization Class Library
EseDecimalAttribute Methods
EseDecimalAttribute Class See Also Send Feedback

The EseDecimalAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseDecimalAttribute..::..Deserialize Method
EseDecimalAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseDecimalAttribute..::..getColumnDef Method
EseDecimalAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseDecimalAttribute..::..Serialize Method
EseDecimalAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseDecimalAttribute..::..verifyTypeSupport Method
EseDecimalAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDecimalAttribute Properties

[image] [image]

EsentSerialization Class Library
EseDecimalAttribute Properties
EseDecimalAttribute Class See Also Send Feedback

The EseDecimalAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Class

[image]

EsentSerialization Class Library
EseDoubleAttribute Class
See Also Send Feedback

The column holding Double.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseDoubleAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseDoubleAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'double' or 'double?'.

The underlying ESENT column type is JET_coltypIEEEDouble with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDoubleAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseDoubleAttribute Constructor
EseDoubleAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseDoubleAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseDoubleAttribute(String) | Initialize with non-default column name.

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Constructor

[image]

EsentSerialization Class Library
EseDoubleAttribute Constructor
EseDoubleAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseDoubleAttribute()

See Also

EseDoubleAttribute Class
EseDoubleAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseDoubleAttribute Constructor (String)
EseDoubleAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseDoubleAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseDoubleAttribute Class
EseDoubleAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Fields

[image] [image]

EsentSerialization Class Library
EseDoubleAttribute Fields
EseDoubleAttribute Class See Also Send Feedback

The EseDoubleAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Methods

[image] [image]

EsentSerialization Class Library
EseDoubleAttribute Methods
EseDoubleAttribute Class See Also Send Feedback

The EseDoubleAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseDoubleAttribute..::..Deserialize Method
EseDoubleAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseDoubleAttribute..::..getColumnDef Method
EseDoubleAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseDoubleAttribute..::..Serialize Method
EseDoubleAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseDoubleAttribute..::..verifyTypeSupport Method
EseDoubleAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseDoubleAttribute Properties

[image] [image]

EsentSerialization Class Library
EseDoubleAttribute Properties
EseDoubleAttribute Class See Also Send Feedback

The EseDoubleAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseDoubleAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Class

[image]

EsentSerialization Class Library
EseEnumAttribute Class
See Also Send Feedback

Enum-typed column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseEnumAttribute _
    Inherits EseIntAttribute
C#
public sealed class EseEnumAttribute : EseIntAttribute

Remarks

Must be applied to a field/property of type 'e' or 'e?', where e is an enum.

The underlying ESENT column type is JET_coltypLong with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIntAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseEnumAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseEnumAttribute Constructor
EseEnumAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseEnumAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseEnumAttribute(String) | Initialize with non-default column name.

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Constructor

[image]

EsentSerialization Class Library
EseEnumAttribute Constructor
EseEnumAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseEnumAttribute()

See Also

EseEnumAttribute Class
EseEnumAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseEnumAttribute Constructor (String)
EseEnumAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseEnumAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseEnumAttribute Class
EseEnumAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Fields

[image] [image]

EsentSerialization Class Library
EseEnumAttribute Fields
EseEnumAttribute Class See Also Send Feedback

The EseEnumAttribute type exposes the following members.

Fields

 | Name | Description
Public field | bEscrowUpdate | If true, specifies that a column is an escrow update column. (Inherited from EseIntAttribute.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Methods

[image] [image]

EsentSerialization Class Library
EseEnumAttribute Methods
EseEnumAttribute Class See Also Send Feedback

The EseEnumAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseIntAttribute..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Inherited from EseIntAttribute.)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseIntAttribute.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Inherited from EseIntAttribute.)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseIntAttribute..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseEnumAttribute..::..Deserialize Method
EseEnumAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseEnumAttribute..::..verifyTypeSupport Method
EseEnumAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseEnumAttribute Properties

[image] [image]

EsentSerialization Class Library
EseEnumAttribute Properties
EseEnumAttribute Class See Also Send Feedback

The EseEnumAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseEnumAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Class

[image]

EsentSerialization Class Library
EseFloatAttribute Class
See Also Send Feedback

The column holding Single.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseFloatAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseFloatAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'float' or 'float?'.

The underlying ESENT column type is JET_coltypIEEESingle with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseFloatAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseFloatAttribute Constructor
EseFloatAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseFloatAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseFloatAttribute(String) | Initialize with non-default column name.

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Constructor

[image]

EsentSerialization Class Library
EseFloatAttribute Constructor
EseFloatAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseFloatAttribute()

See Also

EseFloatAttribute Class
EseFloatAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseFloatAttribute Constructor (String)
EseFloatAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseFloatAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseFloatAttribute Class
EseFloatAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Fields

[image] [image]

EsentSerialization Class Library
EseFloatAttribute Fields
EseFloatAttribute Class See Also Send Feedback

The EseFloatAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Methods

[image] [image]

EsentSerialization Class Library
EseFloatAttribute Methods
EseFloatAttribute Class See Also Send Feedback

The EseFloatAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseFloatAttribute..::..Deserialize Method
EseFloatAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseFloatAttribute..::..getColumnDef Method
EseFloatAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseFloatAttribute..::..Serialize Method
EseFloatAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseFloatAttribute..::..verifyTypeSupport Method
EseFloatAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseFloatAttribute Properties

[image] [image]

EsentSerialization Class Library
EseFloatAttribute Properties
EseFloatAttribute Class See Also Send Feedback

The EseFloatAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseFloatAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Class

[image]

EsentSerialization Class Library
EseGuidAttribute Class
See Also Send Feedback

The column holding Guid.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseGuidAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseGuidAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'Guid' or 'Guid?'.

The underlying ESENT column type is JET_coltypGUID on Vista and above, or JET_coltypBinary on 2003 and below.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseGuidAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseGuidAttribute Constructor
EseGuidAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseGuidAttribute()()()() | Initialize with the default column name, which is the name of the field/property, BTW.
Public method | EseGuidAttribute(String) | Initialize with non-default column name.

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Constructor

[image]

EsentSerialization Class Library
EseGuidAttribute Constructor
EseGuidAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property, BTW.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseGuidAttribute()

See Also

EseGuidAttribute Class
EseGuidAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseGuidAttribute Constructor (String)
EseGuidAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseGuidAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseGuidAttribute Class
EseGuidAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Fields

[image] [image]

EsentSerialization Class Library
EseGuidAttribute Fields
EseGuidAttribute Class See Also Send Feedback

The EseGuidAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Methods

[image] [image]

EsentSerialization Class Library
EseGuidAttribute Methods
EseGuidAttribute Class See Also Send Feedback

The EseGuidAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseGuidAttribute..::..Deserialize Method
EseGuidAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseGuidAttribute..::..getColumnDef Method
EseGuidAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseGuidAttribute..::..MakeKey Method
EseGuidAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    value As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object value,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
value
Type: System..::..Object
flags
Type: MakeKeyGrbit

Remarks

NB! The native GUID columns are only supported by ESENT shipped with Vista and above. You'll get different sort order between Server 2003 and Vista. On Server 2003 and below, the sort order will be just memcmp() of the GUID's 16 bytes, while on Vista and above the sort order will be OK.

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseGuidAttribute..::..Serialize Method
EseGuidAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseGuidAttribute..::..verifyTypeSupport Method
EseGuidAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseGuidAttribute Properties

[image] [image]

EsentSerialization Class Library
EseGuidAttribute Properties
EseGuidAttribute Class See Also Send Feedback

The EseGuidAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseGuidAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIndexAttribute Class

[image]

EsentSerialization Class Library
EseIndexAttribute Class
See Also Send Feedback

This attribute defines an index over a table.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class, Inherited := False, AllowMultiple := True)> _
Public Class EseIndexAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, Inherited = false, AllowMultiple = true)]
public class EseIndexAttribute : Attribute

Remarks

This attribute has no effect unless the EseTableAttribute is also applied to this class.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EsePrimaryIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseSimpleIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTupleIndexAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIndexAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseIndexAttribute Constructor
EseIndexAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseIndexAttribute(String, String) | Declare the index.
Public method | EseIndexAttribute(String, String, CreateIndexGrbit) | Declare the index, specifying the flags as well.

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIndexAttribute Constructor (String, String)

[image]

EsentSerialization Class Library
EseIndexAttribute Constructor (String, String)
EseIndexAttribute Class See Also Send Feedback

Declare the index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _strName As String, _
    _strKey As String _
)
C#
public EseIndexAttribute(
    string _strName,
    string _strKey
)

Parameters

_strName
Type: System..::..String
The name of the index.
_strKey
Type: System..::..String
Double null-terminated string of null-delimited tokens.

Remarks

Each token within the _strKey is of the form "<direction-specifier><column-name>", where direction-specification is either "+" or "-". For example, a _strKey of "+abc\0-def\0+ghi\0\0" will index over the three columns "abc" (in ascending order), "def" (in descending order), and "ghi" (in ascending order).

See Also

EseIndexAttribute Class
EseIndexAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace
JET_INDEXCREATE


EseIndexAttribute Constructor (String, String, )

[image]

EsentSerialization Class Library
EseIndexAttribute Constructor (String, String, )
EseIndexAttribute Class See Also Send Feedback

Declare the index, specifying the flags as well.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _strName As String, _
    _strKey As String, _
    _flags As CreateIndexGrbit _
)
C#
public EseIndexAttribute(
    string _strName,
    string _strKey,
    CreateIndexGrbit _flags
)

Parameters

_strName
Type: System..::..String
The name of the index.
_strKey
Type: System..::..String
Double null-terminated string of null-delimited tokens.
_flags
Type: CreateIndexGrbit
Options for JetCreateIndex.

Remarks

Each token within the _strKey is of the form "<direction-specifier><column-name>", where direction-specification is either "+" or "-". For example, a _strKey of "+abc\0-def\0+ghi\0\0" will index over the three columns "abc" (in ascending order), "def" (in descending order), and "ghi" (in ascending order).

See Also

EseIndexAttribute Class
EseIndexAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace
JET_INDEXCREATE


EseIndexAttribute Fields

[image] [image]

EsentSerialization Class Library
EseIndexAttribute Fields
EseIndexAttribute Class See Also Send Feedback

The EseIndexAttribute type exposes the following members.

Fields

 | Name | Description
Public field | condition | The string specifying the conditional columns for this attribute.
 | flagsNoNulls | Do not add an index entry for a row if any of the columns being indexed are NULL.
 | flagsUnique | Duplicate index entries (keys) are disallowed
 | flagsUniqueNoNulls | The combination of flagsUnique and flagsNoNulls.
Public field | strKey | Double null-terminated string of null-delimited tokens, defining the indexed columns.
Public field | strName | The name of the index.

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


condition Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..condition Field
EseIndexAttribute Class See Also Send Feedback

The string specifying the conditional columns for this attribute.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public condition As String
C#
public string condition

Remarks

The value must be e.g. "+col1" or "-col1\0+col2\0+col3",
where "col1", "col2" and "col3" the columns defined in this table,
"+" stands for "the column must be non-NULL for an index entry for a given row to appear in this index",
"-" stands for "the column must be NULL for an index entry in order for a given row to appear in this index".

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


flagsNoNulls Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..flagsNoNulls Field
EseIndexAttribute Class See Also Send Feedback

Do not add an index entry for a row if any of the columns being indexed are NULL.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Const flagsNoNulls As CreateIndexGrbit
C#
public const CreateIndexGrbit flagsNoNulls

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


flagsUnique Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..flagsUnique Field
EseIndexAttribute Class See Also Send Feedback

Duplicate index entries (keys) are disallowed

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Const flagsUnique As CreateIndexGrbit
C#
public const CreateIndexGrbit flagsUnique

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


flagsUniqueNoNulls Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..flagsUniqueNoNulls Field
EseIndexAttribute Class See Also Send Feedback

The combination of flagsUnique and flagsNoNulls.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Const flagsUniqueNoNulls As CreateIndexGrbit
C#
public const CreateIndexGrbit flagsUniqueNoNulls

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


strKey Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..strKey Field
EseIndexAttribute Class See Also Send Feedback

Double null-terminated string of null-delimited tokens, defining the indexed columns.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly strKey As String
C#
public readonly string strKey

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


strName Field

[image]

EsentSerialization Class Library
EseIndexAttribute..::..strName Field
EseIndexAttribute Class See Also Send Feedback

The name of the index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly strName As String
C#
public readonly string strName

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIndexAttribute Methods

[image] [image]

EsentSerialization Class Library
EseIndexAttribute Methods
EseIndexAttribute Class See Also Send Feedback

The EseIndexAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | getIndexDef | Construct the basic JET_INDEXCREATE structure. Override this method to set additional parameters of the structure, such as conditional columns, or density.
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | setConditionalColumns | Add conditional columns data to the supplied JET_INDEXCREATE.
Public method | ToString | (Inherited from Object.)
Public method | verifyColumnsSupport | Verify the index is compatible with the columns.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getIndexDef Method

[image]

EsentSerialization Class Library
EseIndexAttribute..::..getIndexDef Method
EseIndexAttribute Class See Also Send Feedback

Construct the basic JET_INDEXCREATE structure. Override this method to set additional parameters of the structure, such as conditional columns, or density.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overridable Function getIndexDef As JET_INDEXCREATE
C#
public virtual JET_INDEXCREATE getIndexDef()

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


setConditionalColumns Method

[image]

EsentSerialization Class Library
EseIndexAttribute..::..setConditionalColumns Method
EseIndexAttribute Class See Also Send Feedback

Add conditional columns data to the supplied JET_INDEXCREATE.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Protected Sub setConditionalColumns ( _
    ic As JET_INDEXCREATE _
)
C#
protected void setConditionalColumns(
    JET_INDEXCREATE ic
)

Parameters

ic
Type: JET_INDEXCREATE

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyColumnsSupport Method

[image]

EsentSerialization Class Library
EseIndexAttribute..::..verifyColumnsSupport Method
EseIndexAttribute Class See Also Send Feedback

Verify the index is compatible with the columns.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overridable Sub verifyColumnsSupport ( _
    arrIndexedColumns As EseColumnAttrubuteBase() _
)
C#
public virtual void verifyColumnsSupport(
    EseColumnAttrubuteBase[] arrIndexedColumns
)

Parameters

arrIndexedColumns
Type: array< Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase >[]()[][]
Array of the columns covered by this index

Remarks

This method is called once for every index.
This is the right place to check the compatibility of the index and indexed columns.
The implementation should throw exceptions if they are not compatible.
NB! This method is not implemented and does nothing.

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIndexAttribute Properties

[image] [image]

EsentSerialization Class Library
EseIndexAttribute Properties
EseIndexAttribute Class See Also Send Feedback

The EseIndexAttribute type exposes the following members.

Properties

 | Name | Description
Public property | isPrimaryIndex | Is true if this is the primary (clustering) index.
Public property | TypeId | (Inherited from Attribute.)

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


isPrimaryIndex Property

[image]

EsentSerialization Class Library
EseIndexAttribute..::..isPrimaryIndex Property
EseIndexAttribute Class See Also Send Feedback

Is true if this is the primary (clustering) index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly Property isPrimaryIndex As Boolean
    Get
C#
public bool isPrimaryIndex { get; }

See Also

EseIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Class

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute Class
See Also Send Feedback

The column holding array of Int64.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseInt64ArrayAttribute _
    Inherits EseColumnAttrubuteBase
C#
public class EseInt64ArrayAttribute : EseColumnAttrubuteBase

Remarks

Must be applied to a field/property of type 'long[]'.

The underlying ESENT column type is JET_coltypCurrency with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64ArrayAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseInt64ArrayAttribute Constructor
EseInt64ArrayAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseInt64ArrayAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseInt64ArrayAttribute(String) | Initialize with non-default column name.

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Constructor

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute Constructor
EseInt64ArrayAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseInt64ArrayAttribute()

See Also

EseInt64ArrayAttribute Class
EseInt64ArrayAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute Constructor (String)
EseInt64ArrayAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseInt64ArrayAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseInt64ArrayAttribute Class
EseInt64ArrayAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Fields

[image] [image]

EsentSerialization Class Library
EseInt64ArrayAttribute Fields
EseInt64ArrayAttribute Class See Also Send Feedback

The EseInt64ArrayAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Methods

[image] [image]

EsentSerialization Class Library
EseInt64ArrayAttribute Methods
EseInt64ArrayAttribute Class See Also Send Feedback

The EseInt64ArrayAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute..::..Deserialize Method
EseInt64ArrayAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute..::..getColumnDef Method
EseInt64ArrayAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute..::..Serialize Method
EseInt64ArrayAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute..::..verifyTypeSupport Method
EseInt64ArrayAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64ArrayAttribute Properties

[image] [image]

EsentSerialization Class Library
EseInt64ArrayAttribute Properties
EseInt64ArrayAttribute Class See Also Send Feedback

The EseInt64ArrayAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always false. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseInt64ArrayAttribute..::..bFieldNullable Property
EseInt64ArrayAttribute Class See Also Send Feedback

Is always false.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseInt64ArrayAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Class

[image]

EsentSerialization Class Library
EseInt64Attribute Class
See Also Send Feedback

The column holding Int64.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseInt64Attribute _
    Inherits OptionallyNullableColumn
C#
public class EseInt64Attribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'long' or 'long?'.

The underlying ESENT column type is JET_coltypCurrency with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseOacDecimalAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseUInt64Attribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Constructor

[image] [image]

EsentSerialization Class Library
EseInt64Attribute Constructor
EseInt64Attribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseInt64Attribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseInt64Attribute(String) | Initialize with non-default column name.

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Constructor

[image]

EsentSerialization Class Library
EseInt64Attribute Constructor
EseInt64Attribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseInt64Attribute()

See Also

EseInt64Attribute Class
EseInt64Attribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Constructor (String)

[image]

EsentSerialization Class Library
EseInt64Attribute Constructor (String)
EseInt64Attribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseInt64Attribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseInt64Attribute Class
EseInt64Attribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Fields

[image] [image]

EsentSerialization Class Library
EseInt64Attribute Fields
EseInt64Attribute Class See Also Send Feedback

The EseInt64Attribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Methods

[image] [image]

EsentSerialization Class Library
EseInt64Attribute Methods
EseInt64Attribute Class See Also Send Feedback

The EseInt64Attribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseInt64Attribute..::..Deserialize Method
EseInt64Attribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseInt64Attribute..::..getColumnDef Method
EseInt64Attribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseInt64Attribute..::..MakeKey Method
EseInt64Attribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseInt64Attribute..::..Serialize Method
EseInt64Attribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseInt64Attribute..::..verifyTypeSupport Method
EseInt64Attribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseInt64Attribute Properties

[image] [image]

EsentSerialization Class Library
EseInt64Attribute Properties
EseInt64Attribute Class See Also Send Feedback

The EseInt64Attribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Class

[image]

EsentSerialization Class Library
EseIntAttribute Class
See Also Send Feedback

The column holding Int32.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseIntAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseIntAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'int' or 'int?'.

The underlying ESENT column type is JET_coltypLong with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIntAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseEnumAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseIntAttribute Constructor
EseIntAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseIntAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseIntAttribute(String) | Initialize with non-default column name.

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Constructor

[image]

EsentSerialization Class Library
EseIntAttribute Constructor
EseIntAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseIntAttribute()

See Also

EseIntAttribute Class
EseIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseIntAttribute Constructor (String)
EseIntAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseIntAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseIntAttribute Class
EseIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Fields

[image] [image]

EsentSerialization Class Library
EseIntAttribute Fields
EseIntAttribute Class See Also Send Feedback

The EseIntAttribute type exposes the following members.

Fields

 | Name | Description
Public field | bEscrowUpdate | If true, specifies that a column is an escrow update column.
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bEscrowUpdate Field

[image]

EsentSerialization Class Library
EseIntAttribute..::..bEscrowUpdate Field
EseIntAttribute Class See Also Send Feedback

If true, specifies that a column is an escrow update column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public bEscrowUpdate As Boolean
C#
public bool bEscrowUpdate

Remarks

An escrow update column can be updated concurrently by different sessions with Api.EscrowUpdate and will maintain transactional consistency.

The default is false.

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Methods

[image] [image]

EsentSerialization Class Library
EseIntAttribute Methods
EseIntAttribute Class See Also Send Feedback

The EseIntAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseIntAttribute..::..Deserialize Method
EseIntAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseIntAttribute..::..getColumnDef Method
EseIntAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseIntAttribute..::..MakeKey Method
EseIntAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseIntAttribute..::..Serialize Method
EseIntAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseIntAttribute..::..verifyTypeSupport Method
EseIntAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseIntAttribute Properties

[image] [image]

EsentSerialization Class Library
EseIntAttribute Properties
EseIntAttribute Class See Also Send Feedback

The EseIntAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Class

[image]

EsentSerialization Class Library
EseLongTextAttribute Class
See Also Send Feedback

Column containing long text, either ASCII of Unicode.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseLongTextAttribute _
    Inherits EseTextAttribute
C#
public sealed class EseLongTextAttribute : EseTextAttribute

Remarks

Must be applied to a field/property of type 'string'.

The underlying ESENT column type is JET_coltypLongText, either Unicode (which is the default), or ASCII.

Please spare the memory manager, don't use it with items over few kilobytes, as the whole value lives in RAM as the System.String object.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..EseTextFieldBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTextAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseLongTextAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseLongTextAttribute Constructor
EseLongTextAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseLongTextAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseLongTextAttribute(String) | Initialize with non-default column name.

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Constructor

[image]

EsentSerialization Class Library
EseLongTextAttribute Constructor
EseLongTextAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseLongTextAttribute()

See Also

EseLongTextAttribute Class
EseLongTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseLongTextAttribute Constructor (String)
EseLongTextAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseLongTextAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseLongTextAttribute Class
EseLongTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Fields

[image] [image]

EsentSerialization Class Library
EseLongTextAttribute Fields
EseLongTextAttribute Class See Also Send Feedback

The EseLongTextAttribute type exposes the following members.

Fields

 | Name | Description
Public field | allowNulls | (Inherited from EseTextFieldBase.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_maxChars | Maximum value length, in characters. (Inherited from EseTextFieldBase.)

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Methods

[image] [image]

EsentSerialization Class Library
EseLongTextAttribute Methods
EseLongTextAttribute Class See Also Send Feedback

The EseLongTextAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Inherited from EseTextAttribute.)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseTextAttribute..::..getColumnDef()()()().)
Public method | getColumnKind | (Inherited from EseTextFieldBase.)
Protected method | getEncoding | Get the System.Text.Encoding to use. (Inherited from EseTextFieldBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Protected method | getTextBaseColumnDef | (Inherited from EseTextFieldBase.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseTextFieldBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Inherited from EseTextAttribute.)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Inherited from EseTextAttribute.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseLongTextAttribute..::..getColumnDef Method
EseLongTextAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseLongTextAttribute Properties

[image] [image]

EsentSerialization Class Library
EseLongTextAttribute Properties
EseLongTextAttribute Class See Also Send Feedback

The EseLongTextAttribute type exposes the following members.

Properties

 | Name | Description
Public property | _fixed | Throws NotSupportedException.
Public property | bFieldNullable | Is always true, since the strings in C# are nullable. (Inherited from EseTextAttribute.)
Public property | bUnicode | Is this column stores the Unicode text? (Inherited from EseTextFieldBase.)
Public property | maxChars | Maximum text length, in characters.
Public property | TypeId | (Inherited from Attribute.)

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


_fixed Property

[image]

EsentSerialization Class Library
EseLongTextAttribute..::.._fixed Property
EseLongTextAttribute Class See Also Send Feedback

Throws NotSupportedException.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property _fixed As Boolean
    Get
    Set
C#
public bool _fixed { get; set; }

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


maxChars Property

[image]

EsentSerialization Class Library
EseLongTextAttribute..::..maxChars Property
EseLongTextAttribute Class See Also Send Feedback

Maximum text length, in characters.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property maxChars As Integer
    Get
    Set
C#
public int maxChars { get; set; }

See Also

EseLongTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Class

[image]

EsentSerialization Class Library
EseMultiTextAttribute Class
See Also Send Feedback

Column containing several string values, either ASCII of Unicode.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseMultiTextAttribute _
    Inherits EseTextFieldBase
C#
public sealed class EseMultiTextAttribute : EseTextFieldBase

Remarks

Must be applied to a field/property of type List<string>. Each value can be up to 255 ASCII characters in length, or 127 Unicode characters in length.

The underlying ESENT column type is JET_coltypText, either Unicode (which is the default) or ASCII, with JET_bitColumnMultiValued and JET_bitColumnTagged flags.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..EseTextFieldBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseMultiTextAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseMultiTextAttribute Constructor
EseMultiTextAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseMultiTextAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseMultiTextAttribute(String) | Initialize with non-default column name.

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Constructor

[image]

EsentSerialization Class Library
EseMultiTextAttribute Constructor
EseMultiTextAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseMultiTextAttribute()

See Also

EseMultiTextAttribute Class
EseMultiTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseMultiTextAttribute Constructor (String)
EseMultiTextAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strName As String _
)
C#
public EseMultiTextAttribute(
    string strName
)

Parameters

strName
Type: System..::..String

See Also

EseMultiTextAttribute Class
EseMultiTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Fields

[image] [image]

EsentSerialization Class Library
EseMultiTextAttribute Fields
EseMultiTextAttribute Class See Also Send Feedback

The EseMultiTextAttribute type exposes the following members.

Fields

 | Name | Description
Public field | allowNulls | (Inherited from EseTextFieldBase.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_maxChars | Maximum value length, in characters. (Inherited from EseTextFieldBase.)

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Methods

[image] [image]

EsentSerialization Class Library
EseMultiTextAttribute Methods
EseMultiTextAttribute Class See Also Send Feedback

The EseMultiTextAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | (Inherited from EseTextFieldBase.)
Protected method | getEncoding | Get the System.Text.Encoding to use. (Inherited from EseTextFieldBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Protected method | getTextBaseColumnDef | (Inherited from EseTextFieldBase.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseTextFieldBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseMultiTextAttribute..::..Deserialize Method
EseMultiTextAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseMultiTextAttribute..::..getColumnDef Method
EseMultiTextAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseMultiTextAttribute..::..Serialize Method
EseMultiTextAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseMultiTextAttribute..::..verifyTypeSupport Method
EseMultiTextAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseMultiTextAttribute Properties

[image] [image]

EsentSerialization Class Library
EseMultiTextAttribute Properties
EseMultiTextAttribute Class See Also Send Feedback

The EseMultiTextAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | bUnicode | Is this column stores the Unicode text? (Inherited from EseTextFieldBase.)
Public property | maxChars | Maximum value length, in characters. (Inherited from EseTextFieldBase.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseMultiTextAttribute..::..bFieldNullable Property
EseMultiTextAttribute Class See Also Send Feedback

Is always true.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseMultiTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Class

[image]

EsentSerialization Class Library
EseOacDecimalAttribute Class
See Also Send Feedback

This column type holds a Decimal value stored in the "OLE Automation Currency" format.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseOacDecimalAttribute _
    Inherits EseInt64Attribute
C#
public class EseOacDecimalAttribute : EseInt64Attribute

Remarks

Must be applied to a field/property of type 'decimal' or 'decimal?'.

The underlying ESENT column type is JET_coltypCurrency with JET_bitColumnFixed flag.

The "OLE Automation Currency" format is signed 64-bit integer holding ( value * 10000 ).
Unlike EseDecimalAttribute, this allows indexing over such column, for the downside of degraded precision and range.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseOacDecimalAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace
Microsoft.Isam.Esent.Serialization.Attributes..::..EseDecimalAttribute


EseOacDecimalAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseOacDecimalAttribute Constructor
EseOacDecimalAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseOacDecimalAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseOacDecimalAttribute(String) | Initialize with non-default column name.

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Constructor

[image]

EsentSerialization Class Library
EseOacDecimalAttribute Constructor
EseOacDecimalAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseOacDecimalAttribute()

See Also

EseOacDecimalAttribute Class
EseOacDecimalAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseOacDecimalAttribute Constructor (String)
EseOacDecimalAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseOacDecimalAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseOacDecimalAttribute Class
EseOacDecimalAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Fields

[image] [image]

EsentSerialization Class Library
EseOacDecimalAttribute Fields
EseOacDecimalAttribute Class See Also Send Feedback

The EseOacDecimalAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Methods

[image] [image]

EsentSerialization Class Library
EseOacDecimalAttribute Methods
EseOacDecimalAttribute Class See Also Send Feedback

The EseOacDecimalAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseInt64Attribute..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Inherited from EseInt64Attribute.)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseInt64Attribute..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseInt64Attribute..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseInt64Attribute..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseOacDecimalAttribute..::..Deserialize Method
EseOacDecimalAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseOacDecimalAttribute..::..MakeKey Method
EseOacDecimalAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    value As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object value,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
value
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseOacDecimalAttribute..::..Serialize Method
EseOacDecimalAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseOacDecimalAttribute..::..verifyTypeSupport Method
EseOacDecimalAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseOacDecimalAttribute Properties

[image] [image]

EsentSerialization Class Library
EseOacDecimalAttribute Properties
EseOacDecimalAttribute Class See Also Send Feedback

The EseOacDecimalAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseOacDecimalAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EsePrimaryIndexAttribute Class

[image]

EsentSerialization Class Library
EsePrimaryIndexAttribute Class
See Also Send Feedback

This attribute defines the primary (clustered) index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class, Inherited := False, AllowMultiple := False)> _
Public NotInheritable Class EsePrimaryIndexAttribute _
    Inherits EseIndexAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, Inherited = false, AllowMultiple = false)]
public sealed class EsePrimaryIndexAttribute : EseIndexAttribute

Remarks

This attribute has no effect unless the EseTableAttribute is also applied to this class.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EsePrimaryIndexAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EsePrimaryIndexAttribute Constructor

[image]

EsentSerialization Class Library
EsePrimaryIndexAttribute Constructor
EsePrimaryIndexAttribute Class See Also Send Feedback

Declare the index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _strName As String, _
    _strKey As String _
)
C#
public EsePrimaryIndexAttribute(
    string _strName,
    string _strKey
)

Parameters

_strName
Type: System..::..String
The name of the index.
_strKey
Type: System..::..String
Double null-terminated string of null-delimited tokens.

Remarks

Each token within the _strKey is of the form "<direction-specifier><column-name>", where direction-specification is either "+" or "-". For example, a _strKey of "+abc\0-def\0+ghi\0\0" will index over the three columns "abc" (in ascending order), "def" (in descending order), and "ghi" (in ascending order).

See Also

EsePrimaryIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace
JET_INDEXCREATE


EsePrimaryIndexAttribute Fields

[image] [image]

EsentSerialization Class Library
EsePrimaryIndexAttribute Fields
EsePrimaryIndexAttribute Class See Also Send Feedback

The EsePrimaryIndexAttribute type exposes the following members.

Fields

 | Name | Description
Public field | condition | The string specifying the conditional columns for this attribute. (Inherited from EseIndexAttribute.)
Public field | strKey | Double null-terminated string of null-delimited tokens, defining the indexed columns. (Inherited from EseIndexAttribute.)
Public field | strName | The name of the index. (Inherited from EseIndexAttribute.)

See Also

EsePrimaryIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EsePrimaryIndexAttribute Methods

[image] [image]

EsentSerialization Class Library
EsePrimaryIndexAttribute Methods
EsePrimaryIndexAttribute Class See Also Send Feedback

The EsePrimaryIndexAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | getIndexDef | Construct the basic JET_INDEXCREATE structure. Override this method to set additional parameters of the structure, such as conditional columns, or density. (Inherited from EseIndexAttribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | setConditionalColumns | Add conditional columns data to the supplied JET_INDEXCREATE. (Inherited from EseIndexAttribute.)
Public method | ToString | (Inherited from Object.)
Public method | verifyColumnsSupport | Verify the index is compatible with the columns. (Inherited from EseIndexAttribute.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EsePrimaryIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EsePrimaryIndexAttribute Properties

[image] [image]

EsentSerialization Class Library
EsePrimaryIndexAttribute Properties
EsePrimaryIndexAttribute Class See Also Send Feedback

The EsePrimaryIndexAttribute type exposes the following members.

Properties

 | Name | Description
Public property | isPrimaryIndex | Is true if this is the primary (clustering) index. (Inherited from EseIndexAttribute.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EsePrimaryIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Class

[image]

EsentSerialization Class Library
EseShortBinaryAttribute Class
See Also Send Feedback

A fixed or variable length, raw binary column can be up to 255 bytes in length.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseShortBinaryAttribute _
    Inherits EseColumnAttrubuteBase
C#
public class EseShortBinaryAttribute : EseColumnAttrubuteBase

Remarks

Must be applied to a field/property of type 'ByteArray'.

The underlying ESENT column type is JET_coltypBinary.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortBinaryAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseByteArrayAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseShortBinaryAttribute Constructor
EseShortBinaryAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseShortBinaryAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseShortBinaryAttribute(String) | Initialize with non-default column name.

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Constructor

[image]

EsentSerialization Class Library
EseShortBinaryAttribute Constructor
EseShortBinaryAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseShortBinaryAttribute()

See Also

EseShortBinaryAttribute Class
EseShortBinaryAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseShortBinaryAttribute Constructor (String)
EseShortBinaryAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseShortBinaryAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseShortBinaryAttribute Class
EseShortBinaryAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Fields

[image] [image]

EsentSerialization Class Library
EseShortBinaryAttribute Fields
EseShortBinaryAttribute Class See Also Send Feedback

The EseShortBinaryAttribute type exposes the following members.

Fields

 | Name | Description
Public field | bFixedLength | If set to true, it will always use the same amount of space in a row, regardless of how much data is being stored in the column.
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Public field | maxBytes | The maximum length, in bytes, of a column.

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFixedLength Field

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..bFixedLength Field
EseShortBinaryAttribute Class See Also Send Feedback

If set to true, it will always use the same amount of space in a row, regardless of how much data is being stored in the column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public bFixedLength As Boolean
C#
public bool bFixedLength

Remarks

The default is false.

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


maxBytes Field

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..maxBytes Field
EseShortBinaryAttribute Class See Also Send Feedback

The maximum length, in bytes, of a column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public maxBytes As Integer
C#
public int maxBytes

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Methods

[image] [image]

EsentSerialization Class Library
EseShortBinaryAttribute Methods
EseShortBinaryAttribute Class See Also Send Feedback

The EseShortBinaryAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..Deserialize Method
EseShortBinaryAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..getColumnDef Method
EseShortBinaryAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..MakeKey Method
EseShortBinaryAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..Serialize Method
EseShortBinaryAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..verifyTypeSupport Method
EseShortBinaryAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortBinaryAttribute Properties

[image] [image]

EsentSerialization Class Library
EseShortBinaryAttribute Properties
EseShortBinaryAttribute Class See Also Send Feedback

The EseShortBinaryAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseShortBinaryAttribute..::..bFieldNullable Property
EseShortBinaryAttribute Class See Also Send Feedback

Is always true.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseShortBinaryAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Class

[image]

EsentSerialization Class Library
EseShortIntAttribute Class
See Also Send Feedback

The column holding Int16.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseShortIntAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseShortIntAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'short' or 'short?'.

The underlying ESENT column type is JET_coltypShort.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseShortIntAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseShortIntAttribute Constructor
EseShortIntAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseShortIntAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseShortIntAttribute(String) | Initialize with non-default column name.

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Constructor

[image]

EsentSerialization Class Library
EseShortIntAttribute Constructor
EseShortIntAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseShortIntAttribute()

See Also

EseShortIntAttribute Class
EseShortIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseShortIntAttribute Constructor (String)
EseShortIntAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseShortIntAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseShortIntAttribute Class
EseShortIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Fields

[image] [image]

EsentSerialization Class Library
EseShortIntAttribute Fields
EseShortIntAttribute Class See Also Send Feedback

The EseShortIntAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Methods

[image] [image]

EsentSerialization Class Library
EseShortIntAttribute Methods
EseShortIntAttribute Class See Also Send Feedback

The EseShortIntAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseShortIntAttribute..::..Deserialize Method
EseShortIntAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseShortIntAttribute..::..getColumnDef Method
EseShortIntAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseShortIntAttribute..::..MakeKey Method
EseShortIntAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseShortIntAttribute..::..Serialize Method
EseShortIntAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseShortIntAttribute..::..verifyTypeSupport Method
EseShortIntAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseShortIntAttribute Properties

[image] [image]

EsentSerialization Class Library
EseShortIntAttribute Properties
EseShortIntAttribute Class See Also Send Feedback

The EseShortIntAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseSimpleIndexAttribute Class

[image]

EsentSerialization Class Library
EseSimpleIndexAttribute Class
See Also Send Feedback

This attribute defines a simple index attribute, that indexes only a single column in ascending order.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseSimpleIndexAttribute _
    Inherits EseIndexAttribute
C#
public sealed class EseSimpleIndexAttribute : EseIndexAttribute

Remarks

Index name is the same as the column's name.
This attribute has no effect unless the EseTableAttribute is also applied to this class.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseSimpleIndexAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseSimpleIndexAttribute Constructor

[image]

EsentSerialization Class Library
EseSimpleIndexAttribute Constructor
EseSimpleIndexAttribute Class See Also Send Feedback

Declare the index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _strName As String _
)
C#
public EseSimpleIndexAttribute(
    string _strName
)

Parameters

_strName
Type: System..::..String
Both index name, and column name.

See Also

EseSimpleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseSimpleIndexAttribute Fields

[image] [image]

EsentSerialization Class Library
EseSimpleIndexAttribute Fields
EseSimpleIndexAttribute Class See Also Send Feedback

The EseSimpleIndexAttribute type exposes the following members.

Fields

 | Name | Description
Public field | condition | The string specifying the conditional columns for this attribute. (Inherited from EseIndexAttribute.)
Public field | strKey | Double null-terminated string of null-delimited tokens, defining the indexed columns. (Inherited from EseIndexAttribute.)
Public field | strName | The name of the index. (Inherited from EseIndexAttribute.)

See Also

EseSimpleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseSimpleIndexAttribute Methods

[image] [image]

EsentSerialization Class Library
EseSimpleIndexAttribute Methods
EseSimpleIndexAttribute Class See Also Send Feedback

The EseSimpleIndexAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | getIndexDef | Construct the basic JET_INDEXCREATE structure. Override this method to set additional parameters of the structure, such as conditional columns, or density. (Inherited from EseIndexAttribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | setConditionalColumns | Add conditional columns data to the supplied JET_INDEXCREATE. (Inherited from EseIndexAttribute.)
Public method | ToString | (Inherited from Object.)
Public method | verifyColumnsSupport | Verify the index is compatible with the columns. (Inherited from EseIndexAttribute.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseSimpleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseSimpleIndexAttribute Properties

[image] [image]

EsentSerialization Class Library
EseSimpleIndexAttribute Properties
EseSimpleIndexAttribute Class See Also Send Feedback

The EseSimpleIndexAttribute type exposes the following members.

Properties

 | Name | Description
Public property | isPrimaryIndex | Is true if this is the primary (clustering) index. (Inherited from EseIndexAttribute.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseSimpleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseStreamValue Class

[image]

EsentSerialization Class Library
EseStreamValue Class
See Also Send Feedback

This class represents the value serialized by [EseBinaryStream].

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseStreamValue
C#
public class EseStreamValue

Remarks

This class stores column ID, row bookmark, and value length.

To access the data, call Read(EseCursorBase) or Write(EseCursorBase) methods.

Inheritance Hierarchy

System..::..Object
Microsoft.Isam.Esent.Serialization.Attributes..::..EseStreamValue

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace
Microsoft.Isam.Esent.Serialization.Attributes..::..EseBinaryStreamAttribute


EseStreamValue Constructor

[image]

EsentSerialization Class Library
EseStreamValue Constructor
EseStreamValue Class See Also Send Feedback

Construct the object

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    cur As EseCursorBase, _
    _idColumn As JET_COLUMNID _
)
C#
public EseStreamValue(
    EseCursorBase cur,
    JET_COLUMNID _idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
_idColumn
Type: JET_COLUMNID

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseStreamValue Fields

[image] [image]

EsentSerialization Class Library
EseStreamValue Fields
EseStreamValue Class See Also Send Feedback

The EseStreamValue type exposes the following members.

Fields

 | Name | Description
Public field | length | Data length in bytes.

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


length Field

[image]

EsentSerialization Class Library
EseStreamValue..::..length Field
EseStreamValue Class See Also Send Feedback

Data length in bytes.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly length As Integer
C#
public readonly int length

Remarks

This field holds the length at the time this value has been deserialized. If you've called Open() and modified the stream, you'll need to deserialize the field again to update the length field.

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseStreamValue Methods

[image] [image]

EsentSerialization Class Library
EseStreamValue Methods
EseStreamValue Class See Also Send Feedback

The EseStreamValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Read | Open the stream as read-only.
Public method | ToString | (Inherited from Object.)
Public method | Write | Open the stream as read-write.

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Read Method

[image]

EsentSerialization Class Library
EseStreamValue..::..Read Method
EseStreamValue Class See Also Send Feedback

Open the stream as read-only.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Read ( _
    cur As EseCursorBase _
) As ColumnStream
C#
public ColumnStream Read(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The cursor; it must be on the same table.

Return Value

The read-only ColumnStream object.

Remarks

Calling this method will change DB cursor position, setting it to the row where the record is located.

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Write Method

[image]

EsentSerialization Class Library
EseStreamValue..::..Write Method
EseStreamValue Class See Also Send Feedback

Open the stream as read-write.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Function Write ( _
    cur As EseCursorBase _
) As ColumnStream
C#
public ColumnStream Write(
    EseCursorBase cur
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
The cursor; it must be on the same table.

Return Value

The read-write ColumnStream object

Remarks

Calling this method will change DB cursor position, setting it to the row where the record is located.

NB! You must call Dispose() on the returned stream. Failing to do that will cancel the update and leak the unmanaged resources.

See Also

EseStreamValue Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Class

[image]

EsentSerialization Class Library
EseTableAttribute Class
See Also Send Feedback

This attribute marks the object as the ESE record.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class, Inherited := False, AllowMultiple := False)> _
Public NotInheritable Class EseTableAttribute _
    Inherits Attribute _
    Implements iNotifyTableChanged
C#
[AttributeUsageAttribute(AttributeTargets.Class, Inherited = false, AllowMultiple = false)]
public sealed class EseTableAttribute : Attribute,
    iNotifyTableChanged

Remarks

Applying this attribute to a class declares a new table in the ESE database, with its schema suitable for storing instances of the record class.
Table columns are defined by 'Ese*Attribute' attributes applied to the properties and/or fields of the record class.
Table indices are defined by 'EseIndexAttribute' (or derived classes) attributes applied to the record class.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTableAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseTableAttribute Constructor
EseTableAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseTableAttribute()()()() | Initialize with the default table name, which is the name of the class.
Public method | EseTableAttribute(String) | Initialize with non-default table name.

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Constructor

[image]

EsentSerialization Class Library
EseTableAttribute Constructor
EseTableAttribute Class See Also Send Feedback

Initialize with the default table name, which is the name of the class.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseTableAttribute()

See Also

EseTableAttribute Class
EseTableAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseTableAttribute Constructor (String)
EseTableAttribute Class See Also Send Feedback

Initialize with non-default table name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strTableName As String _
)
C#
public EseTableAttribute(
    string strTableName
)

Parameters

strTableName
Type: System..::..String

See Also

EseTableAttribute Class
EseTableAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Fields

[image] [image]

EsentSerialization Class Library
EseTableAttribute Fields
EseTableAttribute Class See Also Send Feedback

The EseTableAttribute type exposes the following members.

Fields

 | Name | Description
Public field | tableName | The name of the ESE table

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


tableName Field

[image]

EsentSerialization Class Library
EseTableAttribute..::..tableName Field
EseTableAttribute Class See Also Send Feedback

The name of the ESE table

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public ReadOnly tableName As String
C#
public readonly string tableName

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Methods

[image] [image]

EsentSerialization Class Library
EseTableAttribute Methods
EseTableAttribute Class See Also Send Feedback

The EseTableAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | onTableChanged | Fire the TableChanged event.
 | setEventsDispatcher | Call this static method to set the thread that will receive the table change notifications.
Public method | ToString | (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


onTableChanged Method

[image]

EsentSerialization Class Library
EseTableAttribute..::..onTableChanged Method
EseTableAttribute Class See Also Send Feedback

Fire the TableChanged event.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub onTableChanged ( _
    objSender As Object, _
    ntcArgs As NotifyTableChangedArgs _
)
C#
public void onTableChanged(
    Object objSender,
    NotifyTableChangedArgs ntcArgs
)

Parameters

objSender
Type: System..::..Object
ntcArgs
Type: Microsoft.Isam.Esent.Serialization..::..NotifyTableChangedArgs

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


setEventsDispatcher Method

[image]

EsentSerialization Class Library
EseTableAttribute..::..setEventsDispatcher Method
EseTableAttribute Class See Also Send Feedback

Call this static method to set the thread that will receive the table change notifications.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Shared Sub setEventsDispatcher
C#
public static void setEventsDispatcher()

Remarks

Please note that in the current implementation, the event dispatcher mechanism has severe design flaws. It fires event too early, i.e. before the transaction is committed, i.e. when another thread receives a notification, the new data is still not available to him until the source thread commits the top-level transaction. Moreover, if the transaction is rolled back instead of being committed, the events are still fired. If I were you, I wouldn't use this mechanism at all.

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Properties

[image] [image]

EsentSerialization Class Library
EseTableAttribute Properties
EseTableAttribute Class See Also Send Feedback

The EseTableAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | (Inherited from Attribute.)

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTableAttribute Events

[image] [image]

EsentSerialization Class Library
EseTableAttribute Events
EseTableAttribute Class See Also Send Feedback

The EseTableAttribute type exposes the following members.

Events

 | Name | Description
Public event | TableChanged | This event is fired when the table data has changed.

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


TableChanged Event

[image]

EsentSerialization Class Library
EseTableAttribute..::..TableChanged Event
EseTableAttribute Class See Also Send Feedback

This event is fired when the table data has changed.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Event TableChanged As NotifyTableChangedHandler
C#
public event NotifyTableChangedHandler TableChanged

Implements

iNotifyTableChanged..::..TableChanged

See Also

EseTableAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Class

[image]

EsentSerialization Class Library
EseTextAttribute Class
See Also Send Feedback

Column containing short text, either ASCII of Unicode.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseTextAttribute _
    Inherits EseTextFieldBase
C#
public class EseTextAttribute : EseTextFieldBase

Remarks

Must be applied to a field/property of type 'string'. The value can be up to 255 ASCII characters in length or 127 Unicode characters in length.

The underlying ESENT column type is JET_coltypText, either Unicode (which is the default), or ASCII.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..EseTextFieldBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTextAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseLongTextAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseTextAttribute Constructor
EseTextAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseTextAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseTextAttribute(String) | Initialize with non-default column name.

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Constructor

[image]

EsentSerialization Class Library
EseTextAttribute Constructor
EseTextAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseTextAttribute()

See Also

EseTextAttribute Class
EseTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseTextAttribute Constructor (String)
EseTextAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    strName As String _
)
C#
public EseTextAttribute(
    string strName
)

Parameters

strName
Type: System..::..String

See Also

EseTextAttribute Class
EseTextAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Fields

[image] [image]

EsentSerialization Class Library
EseTextAttribute Fields
EseTextAttribute Class See Also Send Feedback

The EseTextAttribute type exposes the following members.

Fields

 | Name | Description
Public field | allowNulls | (Inherited from EseTextFieldBase.)
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_maxChars | Maximum value length, in characters. (Inherited from EseTextFieldBase.)

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Methods

[image] [image]

EsentSerialization Class Library
EseTextAttribute Methods
EseTextAttribute Class See Also Send Feedback

The EseTextAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | (Inherited from EseTextFieldBase.)
Protected method | getEncoding | Get the System.Text.Encoding to use. (Inherited from EseTextFieldBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Protected method | getTextBaseColumnDef | (Inherited from EseTextFieldBase.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Inherited from EseTextFieldBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseTextAttribute..::..Deserialize Method
EseTextAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseTextAttribute..::..getColumnDef Method
EseTextAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseTextAttribute..::..Serialize Method
EseTextAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseTextAttribute..::..verifyTypeSupport Method
EseTextAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTextAttribute Properties

[image] [image]

EsentSerialization Class Library
EseTextAttribute Properties
EseTextAttribute Class See Also Send Feedback

The EseTextAttribute type exposes the following members.

Properties

 | Name | Description
Public property | _fixed | True if the column will always use the same amount of space, regardless of how much data is stored in the column
Public property | bFieldNullable | Is always true, since the strings in C# are nullable. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | bUnicode | Is this column stores the Unicode text? (Inherited from EseTextFieldBase.)
Public property | maxChars | Maximum value length, in characters. (Inherited from EseTextFieldBase.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


_fixed Property

[image]

EsentSerialization Class Library
EseTextAttribute..::.._fixed Property
EseTextAttribute Class See Also Send Feedback

True if the column will always use the same amount of space, regardless of how much data is stored in the column

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Property _fixed As Boolean
    Get
    Set
C#
public bool _fixed { get; set; }

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseTextAttribute..::..bFieldNullable Property
EseTextAttribute Class See Also Send Feedback

Is always true, since the strings in C# are nullable.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseTextAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Class

[image]

EsentSerialization Class Library
EseTimeZoneAttribute Class
See Also Send Feedback

The column to hold TimeZoneInfo class.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseTimeZoneAttribute _
    Inherits EseColumnAttrubuteBase
C#
public class EseTimeZoneAttribute : EseColumnAttrubuteBase

Remarks

Must be applied to a field/property of type 'TimeZoneInfo'.

The underlying ESENT column type is JET_coltypText, ASCII, up to 32 bytes long. The column stores the time zone identifier, which is a name of the registry key in "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones" key. That's why this column can only hold a time zone listed in the registry.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTimeZoneAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseTimeZoneAttribute Constructor
EseTimeZoneAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseTimeZoneAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseTimeZoneAttribute(String) | Initialize with non-default column name.

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Constructor

[image]

EsentSerialization Class Library
EseTimeZoneAttribute Constructor
EseTimeZoneAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseTimeZoneAttribute()

See Also

EseTimeZoneAttribute Class
EseTimeZoneAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseTimeZoneAttribute Constructor (String)
EseTimeZoneAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseTimeZoneAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseTimeZoneAttribute Class
EseTimeZoneAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Fields

[image] [image]

EsentSerialization Class Library
EseTimeZoneAttribute Fields
EseTimeZoneAttribute Class See Also Send Feedback

The EseTimeZoneAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Methods

[image] [image]

EsentSerialization Class Library
EseTimeZoneAttribute Methods
EseTimeZoneAttribute Class See Also Send Feedback

The EseTimeZoneAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the value from the DB, and call FindSystemTimeZoneById(String) to get the time zone. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the TimeZoneInfo.id value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseTimeZoneAttribute..::..Deserialize Method
EseTimeZoneAttribute Class See Also Send Feedback

Retrieve the value from the DB, and call FindSystemTimeZoneById(String) to get the time zone.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseTimeZoneAttribute..::..getColumnDef Method
EseTimeZoneAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseTimeZoneAttribute..::..Serialize Method
EseTimeZoneAttribute Class See Also Send Feedback

Store the TimeZoneInfo.id value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseTimeZoneAttribute..::..verifyTypeSupport Method
EseTimeZoneAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTimeZoneAttribute Properties

[image] [image]

EsentSerialization Class Library
EseTimeZoneAttribute Properties
EseTimeZoneAttribute Class See Also Send Feedback

The EseTimeZoneAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Always returns true. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseTimeZoneAttribute..::..bFieldNullable Property
EseTimeZoneAttribute Class See Also Send Feedback

Always returns true.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseTimeZoneAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTupleIndexAttribute Class

[image]

EsentSerialization Class Library
EseTupleIndexAttribute Class
See Also Send Feedback

This attribute defines a tuple index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseTupleIndexAttribute _
    Inherits EseIndexAttribute
C#
public sealed class EseTupleIndexAttribute : EseIndexAttribute

Remarks

The minimum tuple length is specified in the s_paramIndexTuplesLengthMin field. The default setting is 3.
This attribute has no effect unless the EseTableAttribute is also applied to this class.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseIndexAttribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseTupleIndexAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace
Tuple indices in wikipedia


EseTupleIndexAttribute Constructor

[image]

EsentSerialization Class Library
EseTupleIndexAttribute Constructor
EseTupleIndexAttribute Class See Also Send Feedback

Declare the index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _strName As String _
)
C#
public EseTupleIndexAttribute(
    string _strName
)

Parameters

_strName
Type: System..::..String
Both index name, and column name.

See Also

EseTupleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTupleIndexAttribute Fields

[image] [image]

EsentSerialization Class Library
EseTupleIndexAttribute Fields
EseTupleIndexAttribute Class See Also Send Feedback

The EseTupleIndexAttribute type exposes the following members.

Fields

 | Name | Description
Public field | condition | The string specifying the conditional columns for this attribute. (Inherited from EseIndexAttribute.)
Public field | strKey | Double null-terminated string of null-delimited tokens, defining the indexed columns. (Inherited from EseIndexAttribute.)
Public field | strName | The name of the index. (Inherited from EseIndexAttribute.)

See Also

EseTupleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTupleIndexAttribute Methods

[image] [image]

EsentSerialization Class Library
EseTupleIndexAttribute Methods
EseTupleIndexAttribute Class See Also Send Feedback

The EseTupleIndexAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | getIndexDef | Construct the JET_INDEXCREATE structure for this index. (Overrides EseIndexAttribute..::..getIndexDef()()()().)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | setConditionalColumns | Add conditional columns data to the supplied JET_INDEXCREATE. (Inherited from EseIndexAttribute.)
Public method | ToString | (Inherited from Object.)
Public method | verifyColumnsSupport | Verify the index is compatible with the columns. (Inherited from EseIndexAttribute.)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseTupleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getIndexDef Method

[image]

EsentSerialization Class Library
EseTupleIndexAttribute..::..getIndexDef Method
EseTupleIndexAttribute Class See Also Send Feedback

Construct the JET_INDEXCREATE structure for this index.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getIndexDef As JET_INDEXCREATE
C#
public override JET_INDEXCREATE getIndexDef()

See Also

EseTupleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseTupleIndexAttribute Properties

[image] [image]

EsentSerialization Class Library
EseTupleIndexAttribute Properties
EseTupleIndexAttribute Class See Also Send Feedback

The EseTupleIndexAttribute type exposes the following members.

Properties

 | Name | Description
Public property | isPrimaryIndex | Is true if this is the primary (clustering) index. (Inherited from EseIndexAttribute.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseTupleIndexAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Class

[image]

EsentSerialization Class Library
EseUInt64Attribute Class
See Also Send Feedback

The column holding UInt64.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseUInt64Attribute _
    Inherits EseInt64Attribute
C#
public class EseUInt64Attribute : EseInt64Attribute

Remarks

Must be applied to a field/property of type 'ulong' or 'ulong?'.

The underlying ESENT column type is JET_coltypCurrency with JET_bitColumnFixed flag.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseInt64Attribute
Microsoft.Isam.Esent.Serialization.Attributes..::..EseUInt64Attribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Constructor

[image] [image]

EsentSerialization Class Library
EseUInt64Attribute Constructor
EseUInt64Attribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseUInt64Attribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseUInt64Attribute(String) | Initialize with non-default column name.

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Constructor

[image]

EsentSerialization Class Library
EseUInt64Attribute Constructor
EseUInt64Attribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseUInt64Attribute()

See Also

EseUInt64Attribute Class
EseUInt64Attribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Constructor (String)

[image]

EsentSerialization Class Library
EseUInt64Attribute Constructor (String)
EseUInt64Attribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseUInt64Attribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseUInt64Attribute Class
EseUInt64Attribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Fields

[image] [image]

EsentSerialization Class Library
EseUInt64Attribute Fields
EseUInt64Attribute Class See Also Send Feedback

The EseUInt64Attribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Methods

[image] [image]

EsentSerialization Class Library
EseUInt64Attribute Methods
EseUInt64Attribute Class See Also Send Feedback

The EseUInt64Attribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseInt64Attribute..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Inherited from EseInt64Attribute.)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseInt64Attribute..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseInt64Attribute..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseInt64Attribute..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseUInt64Attribute..::..Deserialize Method
EseUInt64Attribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseUInt64Attribute..::..MakeKey Method
EseUInt64Attribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseUInt64Attribute..::..Serialize Method
EseUInt64Attribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseUInt64Attribute..::..verifyTypeSupport Method
EseUInt64Attribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUInt64Attribute Properties

[image] [image]

EsentSerialization Class Library
EseUInt64Attribute Properties
EseUInt64Attribute Class See Also Send Feedback

The EseUInt64Attribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseUInt64Attribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Class

[image]

EsentSerialization Class Library
EseUShortIntAttribute Class
See Also Send Feedback

The column holding UInt16.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Class EseUShortIntAttribute _
    Inherits OptionallyNullableColumn
C#
public class EseUShortIntAttribute : OptionallyNullableColumn

Remarks

Must be applied to a field/property of type 'ushort' or 'ushort?'.

The underlying ESENT column type is JET_coltypBinary, 2 bytes long.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization..::..OptionallyNullableColumn
Microsoft.Isam.Esent.Serialization.Attributes..::..EseUShortIntAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseUShortIntAttribute Constructor
EseUShortIntAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseUShortIntAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseUShortIntAttribute(String) | Initialize with non-default column name.

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Constructor

[image]

EsentSerialization Class Library
EseUShortIntAttribute Constructor
EseUShortIntAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseUShortIntAttribute()

See Also

EseUShortIntAttribute Class
EseUShortIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseUShortIntAttribute Constructor (String)
EseUShortIntAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseUShortIntAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseUShortIntAttribute Class
EseUShortIntAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Fields

[image] [image]

EsentSerialization Class Library
EseUShortIntAttribute Fields
EseUShortIntAttribute Class See Also Send Feedback

The EseUShortIntAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)
Protected field | m_bFieldNullable | true if this column is nullable. (Inherited from OptionallyNullableColumn.)

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Methods

[image] [image]

EsentSerialization Class Library
EseUShortIntAttribute Methods
EseUShortIntAttribute Class See Also Send Feedback

The EseUShortIntAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides OptionallyNullableColumn..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Protected method | verifyBasicTypeSupport<(Of <<'(tDesired>)>>) | Verify the type. Throws new SerializationException if the type is incompatible. (Inherited from OptionallyNullableColumn.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseUShortIntAttribute..::..Deserialize Method
EseUShortIntAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseUShortIntAttribute..::..getColumnDef Method
EseUShortIntAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseUShortIntAttribute..::..MakeKey Method
EseUShortIntAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseUShortIntAttribute..::..Serialize Method
EseUShortIntAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseUShortIntAttribute..::..verifyTypeSupport Method
EseUShortIntAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseUShortIntAttribute Properties

[image] [image]

EsentSerialization Class Library
EseUShortIntAttribute Properties
EseUShortIntAttribute Class See Also Send Feedback

The EseUShortIntAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Returns true if this column is nullable. (Inherited from OptionallyNullableColumn.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseUShortIntAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Class

[image]

EsentSerialization Class Library
EseVersionAttribute Class
See Also Send Feedback

Automatically-incremented row version column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseVersionAttribute _
    Inherits EseColumnAttrubuteBase
C#
public sealed class EseVersionAttribute : EseColumnAttrubuteBase

Remarks

Must be applied to a field/property of type 'int'.

The underlying ESENT column type is JET_coltypLong, with JET_bitColumnFixed and JET_bitColumnVersion flags.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseVersionAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseVersionAttribute Constructor
EseVersionAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseVersionAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseVersionAttribute(String) | Initialize with non-default column name.

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Constructor

[image]

EsentSerialization Class Library
EseVersionAttribute Constructor
EseVersionAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseVersionAttribute()

See Also

EseVersionAttribute Class
EseVersionAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseVersionAttribute Constructor (String)
EseVersionAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseVersionAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseVersionAttribute Class
EseVersionAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Fields

[image] [image]

EsentSerialization Class Library
EseVersionAttribute Fields
EseVersionAttribute Class See Also Send Feedback

The EseVersionAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Methods

[image] [image]

EsentSerialization Class Library
EseVersionAttribute Methods
EseVersionAttribute Class See Also Send Feedback

The EseVersionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make the search key for this column. (Overrides EseColumnAttrubuteBase..::..MakeKey(EseCursorBase, Object, MakeKeyGrbit).)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Do nothing, as the value is set by the ESENT. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Throw an exception if this attribute is not compatible with the type of the field/property. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseVersionAttribute..::..Deserialize Method
EseVersionAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseVersionAttribute..::..getColumnDef Method
EseVersionAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


MakeKey Method

[image]

EsentSerialization Class Library
EseVersionAttribute..::..MakeKey Method
EseVersionAttribute Class See Also Send Feedback

Make the search key for this column.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub MakeKey ( _
    cur As EseCursorBase, _
    val As Object, _
    flags As MakeKeyGrbit _
)
C#
public override void MakeKey(
    EseCursorBase cur,
    Object val,
    MakeKeyGrbit flags
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
val
Type: System..::..Object
flags
Type: MakeKeyGrbit

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseVersionAttribute..::..Serialize Method
EseVersionAttribute Class See Also Send Feedback

Do nothing, as the value is set by the ESENT.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseVersionAttribute..::..verifyTypeSupport Method
EseVersionAttribute Class See Also Send Feedback

Throw an exception if this attribute is not compatible with the type of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseVersionAttribute Properties

[image] [image]

EsentSerialization Class Library
EseVersionAttribute Properties
EseVersionAttribute Class See Also Send Feedback

The EseVersionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Always false. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseVersionAttribute..::..bFieldNullable Property
EseVersionAttribute Class See Also Send Feedback

Always false.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseVersionAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Class

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute Class
See Also Send Feedback

Column containing the object serialized into XML encoded in UTF8.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public NotInheritable Class EseXmlSerializedAttribute _
    Inherits EseColumnAttrubuteBase
C#
public sealed class EseXmlSerializedAttribute : EseColumnAttrubuteBase

Remarks

This column type is here mainly for backward compatibility. For the new projects, consider using [EseDCS] instead.

May be applied to a field/property of any type suitable for serialization with XmlSerializer class.

The underlying ESENT column type is JET_coltypLongText, ASCII-encoded, holding a UTF-8 XML stream.

The attribute instance holds the System.Xml.Serialization.XmlSerializer object that performs the [de]serialization.
Please, don't apply this attribute to the fields/properties of type "object", provide the correct type. the correct type that will be serialized must be passed to the verifyTypeSupport method, to construct the right XmlSerializer instance.

The documentation on XmlSerializer says:
"This type is safe for multithreaded operations".
That's why no locks is ever needed, even when different threads are [de]serializing the same column of different records, which is perfectly legal way of using the library.

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Microsoft.Isam.Esent.Serialization..::..EseColumnAttrubuteBase
Microsoft.Isam.Esent.Serialization.Attributes..::..EseXmlSerializedAttribute

See Also

Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Constructor

[image] [image]

EsentSerialization Class Library
EseXmlSerializedAttribute Constructor
EseXmlSerializedAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EseXmlSerializedAttribute()()()() | Initialize with the default column name, which is the name of the field/property.
Public method | EseXmlSerializedAttribute(String) | Initialize with non-default column name.

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Constructor

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute Constructor
EseXmlSerializedAttribute Class See Also Send Feedback

Initialize with the default column name, which is the name of the field/property.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New
C#
public EseXmlSerializedAttribute()

See Also

EseXmlSerializedAttribute Class
EseXmlSerializedAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Constructor (String)

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute Constructor (String)
EseXmlSerializedAttribute Class See Also Send Feedback

Initialize with non-default column name.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Sub New ( _
    _columnName As String _
)
C#
public EseXmlSerializedAttribute(
    string _columnName
)

Parameters

_columnName
Type: System..::..String

See Also

EseXmlSerializedAttribute Class
EseXmlSerializedAttribute Overload
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Fields

[image] [image]

EsentSerialization Class Library
EseXmlSerializedAttribute Fields
EseXmlSerializedAttribute Class See Also Send Feedback

The EseXmlSerializedAttribute type exposes the following members.

Fields

 | Name | Description
Public field | columnName | Name for this column in the DB. (Inherited from EseColumnAttrubuteBase.)

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Methods

[image] [image]

EsentSerialization Class Library
EseXmlSerializedAttribute Methods
EseXmlSerializedAttribute Class See Also Send Feedback

The EseXmlSerializedAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Deserialize | Retrieve the column value from the DB. (Overrides EseColumnAttrubuteBase..::..Deserialize(EseCursorBase, JET_COLUMNID).)
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | getColumnDef | Get column definition. (Overrides EseColumnAttrubuteBase..::..getColumnDef()()()().)
Public method | getColumnKind | Get the Column kind (Inherited from EseColumnAttrubuteBase.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | MakeKey | Make search key for this column. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeKeyException | Throw new "MakeKey failed" exception. (Inherited from EseColumnAttrubuteBase.)
Protected method | makeNullKey | Try to make a null key. (Inherited from EseColumnAttrubuteBase.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize | Store the column value in the database. (Overrides EseColumnAttrubuteBase..::..Serialize(EseCursorBase, JET_COLUMNID, Object, Boolean).)
Protected method | serializeNull | Try to store a null value. (Inherited from EseColumnAttrubuteBase.)
Public method | ToString | (Inherited from Object.)
Public method | verifyTypeSupport | Construct the XML serializer for the specified type. (Overrides EseColumnAttrubuteBase..::..verifyTypeSupport(Type).)

Extension Methods

 | Name | Description
Public Extension Method | GetPropertiesCollection | Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned. (Defined by EnumerableEx.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | _Attribute..::..GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfo | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implemetation | _Attribute..::..Invoke | (Inherited from Attribute.)

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Deserialize Method

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute..::..Deserialize Method
EseXmlSerializedAttribute Class See Also Send Feedback

Retrieve the column value from the DB.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function Deserialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID _
) As Object
C#
public override Object Deserialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


getColumnDef Method

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute..::..getColumnDef Method
EseXmlSerializedAttribute Class See Also Send Feedback

Get column definition.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Function getColumnDef As JET_COLUMNDEF
C#
public override JET_COLUMNDEF getColumnDef()

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


Serialize Method

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute..::..Serialize Method
EseXmlSerializedAttribute Class See Also Send Feedback

Store the column value in the database.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub Serialize ( _
    cur As EseCursorBase, _
    idColumn As JET_COLUMNID, _
    value As Object, _
    bNewRecord As Boolean _
)
C#
public override void Serialize(
    EseCursorBase cur,
    JET_COLUMNID idColumn,
    Object value,
    bool bNewRecord
)

Parameters

cur
Type: Microsoft.Isam.Esent.Serialization..::..EseCursorBase
idColumn
Type: JET_COLUMNID
value
Type: System..::..Object
bNewRecord
Type: System..::..Boolean

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


verifyTypeSupport Method

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute..::..verifyTypeSupport Method
EseXmlSerializedAttribute Class See Also Send Feedback

Construct the XML serializer for the specified type.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides Sub verifyTypeSupport ( _
    t As Type _
)
C#
public override void verifyTypeSupport(
    Type t
)

Parameters

t
Type: System..::..Type
The type of the field/property this attribute is applied.

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


EseXmlSerializedAttribute Properties

[image] [image]

EsentSerialization Class Library
EseXmlSerializedAttribute Properties
EseXmlSerializedAttribute Class See Also Send Feedback

The EseXmlSerializedAttribute type exposes the following members.

Properties

 | Name | Description
Public property | bFieldNullable | Is always true. (Overrides EseColumnAttrubuteBase..::..bFieldNullable.)
Public property | TypeId | (Inherited from Attribute.)

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


bFieldNullable Property

[image]

EsentSerialization Class Library
EseXmlSerializedAttribute..::..bFieldNullable Property
EseXmlSerializedAttribute Class See Also Send Feedback

Is always true.

Namespace: Microsoft.Isam.Esent.Serialization.Attributes
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
Public Overrides ReadOnly Property bFieldNullable As Boolean
    Get
C#
public override bool bFieldNullable { get; }

See Also

EseXmlSerializedAttribute Class
Microsoft.Isam.Esent.Serialization.Attributes Namespace


GetPropertiesCollection Method (Object)

[image]

EsentSerialization Class Library
EnumerableEx..::..GetPropertiesCollection Method (Object)
EnumerableEx Class See Also Send Feedback

Return all public properties & fields of the specified object as a collection of name-value pairs. The result is sorted by the name, case-agnostic. Indexed properties are not returned.

Namespace: (Default Namespace)
Assembly: EsentSerialization (in EsentSerialization.dll)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetPropertiesCollection ( _
    obj As Object _
) As IEnumerable(Of pair(Of String, Object))
C#
public static IEnumerable<pair<string, Object>> GetPropertiesCollection(
    this Object obj
)

Parameters

obj
Type: System..::..Object

Return Value

See Also

EnumerableEx Class
GetPropertiesCollection Overload
(Default Namespace) Namespace